Showing results for 
Search instead for 
Did you mean: 

Photo URL in jabber-config.xml file

Level 5
Level 5

Hello all,


I am trying to figure out how to retrieve contact photos from a webserver.


So I set these few paremeters in the jabber-config.xml file, but it is not working. Jabber client can't get photos.



From the installation guide, I notice the sample what the document provides is to use sAMAccountName.jpg. So I am not sure if it still works if I combine the token with a suffix.

   <SearchBase1>ou=xxx, dc=domain, dc=com</SearchBase1>

Anyone ever made it working?




1 Accepted Solution

Accepted Solutions

Its this defect


View solution in original post

4 Replies 4

Amit Kumar
Cisco Employee
Cisco Employee

there is a need to recontruct the URL from what it looks like; as it does not seem that jabber is attempting to appropiately replace the sAMAccountName value. In order to proceed further you will need to take wireshark where you can clearly see what jabber thwors as a request for the photo URL fetch; most probably this is going to move with a 404 not found error message.

Thanks Amit.


I did some sniffer and notice Jabber inteprete the URL wrongly so it tried to access a wrong URL.

For example,  the correct URL should be:


but it is trying to access:



I think Jabber doesn't regonize the % charater? I tried use both space and %20 in the URL but got the same issue.


Checking with TAC to see is this something should be fix from Cisco side.




Its this defect


I would like to give an update for the issue.

We can work around the %20 with just the original space. Another issue for this setting not to be working is the authentication from the server side. Jabber doesn't support it.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: