cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4382
Views
0
Helpful
4
Replies
Highlighted
Beginner

Unable to disable docked window in config xml

Hi

I'm trying to disable the docked window in the jabber-config.xml file in J4W 9.2.

Here is a copy of my xml file:

<?xml version="1.0" encoding="utf-8"?>

<config version="1.0">
<Client>
</Client>
<Directory>
  <DirectoryServerType>EDI</DirectoryServerType>
  <DisableSecondaryNumberLookups>0</DisableSecondaryNumberLookups>
  <MinimumCharacterQuery>2</MinimumCharacterQuery>
  <SearchBase1>OU=xxxxx,DC=xxxx,dc=XXXXX,DC=com</SearchBase1>
  <HomePhone>otherHomePhone</HomePhone>
  <OtherPhone>otherHomePhone</OtherPhone>
  <PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
  <PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
  <PhotoUriWithToken>http://www.xxxxxxxxxxx.com</PhotoUriWithToken>
  <PhoneNumberMasks>+45XXXXXXXX|+## #### ####|+45XXXXXXXX|+## #### ####</PhoneNumberMasks>
</Directory>
<Options>
  <StartCallWithVideo>false</StartCallWithVideo>
  <Start_Client_On_Start_OS>true</Start_Client_On_Start_OS>
  <DockedWindowVisible>FALSE</DockedWindowVisible>
</Options>
<Policies>
  <Screen_Capture_Enabled>true</Screen_Capture_Enabled>
  <File_Transfer_Enabled>false</File_Transfer_Enabled>
  <Disallowed_File_Transfer_Types>.exe;.msi;.rar;.zip;.mp3</Disallowed_File_Transfer_Types>
  <InitialPhoneSelection>softphone</InitialPhoneSelection>
  <EnableAccessoriesManager>true</EnableAccessoriesManager>
</Policies>
<Voicemail>
  <VoiceMailService_UseCredentialsFrom>phone</VoiceMailService_UseCredentialsFrom>
</Voicemail>
</config>

But the docked window are still showed, however the mark is removed if I look in the View menu in Jabber. If turn it on in View menu and turn it off again, the docked window if finaly disabled. But not trough the config file :\

Also this value: <userConfig name="dockedwindowvisible" value="FALSE"/> is not written to the jabberLocalConfig.xml file thorugh the jabber-config.xml file. Only if I turn it on and off, the value is set in the jabberLocalConfig.xml file.

Are I'm the only one with this issue?

Best regards

Kristian                   

Everyone's tags (3)
4 REPLIES 4
Contributor

Re: Unable to disable docked window in config xml

Hi Kristian,

Let me try to recapitulate all steps needed.

In jabber-config.xml you should have following lines (this file needs to be changed on server side):

      FALSE

Same thing you can accomplish locally by adding these lines into jabber-config-user.xml file (this file you can generate by copying and renaming jabber-config.xml to jabber-config-user.xml).

Keep in mind that corresponding line in jabberLocalConfig.xml is:

Most important is that priority of jabberLocalConfig.xml is higher then priority of jabber-config-user.xml. Also jabber-config-user.xml has higher priority than jabber-config.xml. That means that settings in jabberLocalConfig.xml will override any settings in jabber-config-user.xml or jabber-config.xml. So if you want to add DockedWindowVisible into jabber-config.xml you will have to delete setting in jabberLocalConfig.xml (or jabber-config-user.xml).

Hope this info will be usefull.

Regards,

Nebojsa

Beginner

Re: Unable to disable docked window in config xml

Hi Nebojsa

Have you read my post? If so you will understand that I already have added the needed option. Here a copy of my defined options in my XML fille:

false

true

FALSE

The file is located on my TFTP server. Also when I'm testing I always delates the local config files (including jabberLocalConfig.xml), so new files can be generated.

So as I see it, I can't disable the dockedwindows in the XML file.

Any idea?

Best regards

K.

Contributor

Unable to disable docked window in config xml

Hi Kristian,

I have just tried to do a same thing (Jabber version 9.2.0 Build 496) and for me it is working.

Here are the steps I have used:

1 - started Jabber and immediatelly exit. jabber-config.xml is downloaded from TPFT server and stored locally. This file is NOT user/device specific (it is general config file)

2 - added following into jabber-config.xml file:

      false

3 - deleted original jabber-config.xml on TFTP server and uploaded edited version of jabber-config.xml

4 - deleted jabber config folder and restarted Jabber

If you are using same Jabber version and general jabber-config.xml file then please create a problem report and attach with this thread. If you are not comfortable to attach report here, then raise a TAC case for further assistance.

If not - I would like to know what is different in your case.

Regards,

Nebojsa

Enthusiast

Unable to disable docked window in config xml

Why isnt this off by default?

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards