Showing results for 
Search instead for 
Did you mean: 

Unable to enter Webex room on windows 10

I have been using windows 10 for the past month and regularly attend Webex meetings without problems. Suddenly this week I receive the following message on any windows 10 machine running any browser whenever I try to attend a meeting and even if I just try to enter my own room.

Invalid input or system error. Please try again or contact your site administrator.

I have tested IE11, Edge, Chrome and Firefox, and I have tried 3 different windows 10 computers (desktop, laptop and surface pro). If I use windows 7 or 8.1 machines I have no issue accessing meetings. I understand that windows 10 may not be fully supported yet, however I don't see why this was working fine on windows 10 up until the end of last week and has suddenly changed. I certainly have not changed anything across all three of the windows 10 devices in the last few days so am reasonably sure the problem is not caused by any action I have taken.


I'm having the exact same issue, and all I could find on the internet was this post, and only one other on a Microsoft site:


I've tested in all of the following browsers and they all fail:

  • Firefox 40.0.3
  • Chrome 45.0.2454.85 m
  • Microsoft Edge 20.10240.16384.0
  • Internet Explorer 11.0.10240.16431


NOTE: The strange thing is, if I use the Productivity Tools and click on Meet Now, it works fine. However, if I attempt to join someone else's meeting it fails as well since it tries to load it in a browser.

There is another thread on this topic at


Still no answers, but confirmation that others are experiencing the problem and that it is very recent.

I get the error message "Invalid input or system error. Please try again or contact your site administrator." using Windows 10.

Can you do something so that this is working.


I was able to enter WebEx meetings using IE; after first using developer tools to switch to IE 9 compatibility.

As of last week, that stopped working and now I get a message:

"Your version of Cisco WebEx does not support Windows 10. If you want to use WebEx on Windows 10, contact your administrator for more information."

The IE 9 compatibility no longer works...I also tried the Chrome suggestion without positive results. As someone else indicated, I can schedule and start my own WebEx meetings...I can't join other people's.

UPDATE: The Chrome fix worked.

Download IETabs from the Chrome web store.

Install it and you'll see a little icon off to the right of the address bar.

In the Webex meeting, right click on the JOIN MEETING hyperlink and copy hyperlink.

Open Chrome, paste the meeting hyperlink and press enter. When you see the join webex meeting screen, press the IETAB icon and you should be able to enter the meeting.

Whew....I hope MS/Cisco are working on a fix

When do you get this error displayed? When the meeting client starts to load, or even before you enter the name, e-mail, and optionally meeting password?

Have you tried removing the meeting client and trying to use the temporary client?


It happens immediately after I click on the big green "Enter Room" button and no I have not tried using the temporary client instead of the real client. If the only way to pick the temp client is to remove the real client, then I'll have to try that later today.

I can confirm that for me the problem exists regardless of whether the meeting client is installed or not. As soon as I either try to enter my own meeting room or click on the link in an invitation I see the error. If I try to attend a meeting from the meeting center (by entering the room ID), then I get the error after the green button is pressed.

Webex was working fine on Windows 10 till this week. There was a windows 10 update and a productivity tools update at some point it stopped working. 


Invalid input or system error. Please try again or contact your site administrator. 


I can circumvent this by using Jabber or Productivity Tools. But if you try any browser, none of them work. Uninstalled Productivity Tools and Webex plugins several times, temp file, etc.. Webex is basically not functional on Windows 10 anymore.


Try this for webex issue -  

    1) Use Chrome as web browser
    2) In the chrome web store, search and install “IE tab” extension
    3) First time you click on the logo an executable will be installed. From this point on, each time you click on the extension icon you will see a secondary bar in which you can add the webex URL by copy-pasting.
    4) The program emulates internet explorer over chrome and makes webex work.

The solution worked for me.  Had to re-launch Chrome, then all good!  Thanks for the tip!


In IE 11 open dev tools [F12] under emulation set document mode to 9 and user agent string to IE 9 and it seems to work for me.

I am having the same issue, but was able to join a meeting successfully in Chrome. To get it to work in IE11 I used this suggestion of changing the settings under the Dev Tools and it worked. One difference was I set the User agent string to IE10 instead of IE9 and it loaded the meeting properly. I also tried leaving the Document mode as 10 (default) and just changed the User agent string and it loaded correctly so it seems to be associated with the Document mode.

Yes this works.


Recognize Your Peers
Content for Community-Ad