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Sharath Gudemella
Cisco Employee
Cisco Employee

Symptoms

Cisco Finesse Not Ready - Call Overlap status is very a very common issue seen on Finesse desktop. Agents miss two calls and they are put in Not Ready - Call Overlap status. This is very likely related to CVP server and it's unreachable table mechanism. Cisco Unified Communications Manager (CUCM) server has a big role here as well

Diagnosis

When CVP receives specific Session Initiation Protocol (SIP) messages from CUCM (5XX and 4XX) or any other SIP endpoint, CVP deems the server is in trouble and stops to route calls to the SIP element. The SIP element (in this case, CUCM) is placed into the unreachable table.


There can be multiple conditions that affect this behaviour:


1. Heartbeats are enabled on CVP SIP Server Group. Recovery can be faster than three minutes.

2. Heartbeats are not enabled (CSCuy30406). Recovery can take upto three minutes.

3. Cisco Unified IP Communicator (CIPC) or any endpoints registered with private IP (CSCuy10282).


In this example, if CVP receives SIP 503 Service Unavailable from any CUCM server, it blocks to route calls to that endpoint as well as any other call related signal for the entire time the element is in the unreachable table. 


Since Agent PG is successfully able to reserve the agent via Finesse and agent phone does not receive call from CVP and CUCM, agent is seen in Call Overlap state after it misses two such calls.


CVP Call Server Log Analysis

CVP shows this error when the issue happens:

“Can’t connect to SIP server."

 

Log Snippet :

Mar 18 2021 13:32:16.635 -0600: %_Connection-4-com.dynamicsoft.DsLibs.DsUALibs.DsSipLlApi.Connection: DsTcpNBConnection(): I/O Exception: java.net.SocketTimeoutException at sun.nio.ch.SocketAdaptor.connect(SocketAdaptor.java:109) at com.dynamicsoft.DsLibs.DsSipLlApi.DsTcpNBConnection.<init>(DsTcpNBConnection.java:259) at com.dynamicsoft.DsLibs.DsSipLlApi.DsSipTcpNBConnection.<init>(DsSipTcpNBConnection.java:120) at com.dynamicsoft.DsLibs.DsSipLlApi.DsSipConnectionFactory.createConnection(DsSipConnectionFactory.java:417) at com.dynamicsoft.DsLibs.DsSipLlApi.DsSipConnectionFactory.createConnection(DsSipConnectionFactory.java:239) at com.dynamicsoft.DsLibs.DsSipLlApi.DsTransportLayer.getConnection(DsTransportLayer.java:768)

 

Solution:

Disable CVP Unreachable table

https://www.cisco.com/c/en/us/support/docs/customer-collaboration/unified-customer-voice-portal/2009...


Configure SIP Options Ping heartbeat on SIP Server Group:

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/customer_voice_porta... 


CVP 11.6 ES7 added paremeters to further tweak unreachable destination table:


CVP 11.6 ES7 Release Notes 

  • When CVP receives a 503 Service Unavailable , it first checks reason header of this 503 based on values in “SIP.System.ExcludedCauseCodeFromUnreachableTable =”. If there is no match, then CVP puts destination to unreachable table.
  • If there is match, then CVP does not put destination to unreachable table.
  • The values which in “SIP.System.ExcludedCauseCodeFromUnreachableTable =” purely depends on your environment. In another word what kind of Q.850 cause code is generated in your environment. Cause code 47 is very common with CUCM that is related to media resources.

Based on the CVP log snippet, here's one example to tweak unreacahble table parameters:

SIP.System.ExcludedCauseCodeFromUnreachableTable = 34,41,47

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