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schm196
Level 1
Level 1

Symptoms

There's probably not a single UCCX installation that doesn't have some scripts requiring alternative handling options due to some sort of federal, state, local and/or company holidays.  Widely circulated solutions require annual modifications to scripts, which can be forgotten.  Some require complex array variables to be edited, and others need some sort of external XML or other documents, which must be hosted somewhere and maintained.

Diagnosis

I don't like the complexity of hosting external documents for such a simple task, and I certainly have forgotten about changing a script or document once or twice before and experienced the dreaded "call center open on a holiday" complaints.  Statically describing holidays using specific occurrence dates is therefore not desirable.

Solution

Keeping it simple, an elegant solution is a perpetual calendar script that logically describes holidays using expressions rather than pre-defined dates.  It can be called as a subflow from any UCCX application to check whether or not there's a holiday at runtime by handing over the boolean check variable.

Other open/close tests for the call center (weekday/weekend, business or after hours, override using parameter variable, etc.) are intentionally left out because they can be dealt with easily by the calling application.

This script is an extremely simple top-to-bottom-flow sequence of IF statements.  No attempts have been made to optimize it by running specific sections only on certain months, weeks or days.  I have also intentionally not optimized the logical expressions used to describe each holiday in favor of keeping the logic very easily readable and understandable.

I work for a local City government, hence the script name and variable name references.  Obviously, you can change these to whatever you prefer.  Add or remove holiday observances for your own organization as desired.

Credits for the original idea must go to Bruce Wilkinson, Cisco Contact Center Specialist, and his "UCCX Administration" online class in the Cisco Platinum Library Limited.  The usual disclaimers apply:  Free to use; that's why it's posted here.  No explicit or implied warranties; you must adapt the script to your own needs and test that it works for you.

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