cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1657
Views
0
Helpful
2
Replies

Can't send HTTP request to Finesse - Access to the specified resource has been forbidden

SMerezhko
Beginner
Beginner

Hi,

I'm trying to send a simple HTTP request to Finesse using Poster for Firefox, as described in Chapter 2 in this guide:

https://developer.cisco.com/fileMedia/download/90f66367-13f0-41a9-aadd-84df32057afe

Here is my request:

URL: http://myfinesseserver/finesse/api/User/testagent
User auth: testagent / password
Content type: application/XML
Content: <User><state>LOGIN</state><extension>1234</extension></User>

When I press PUT I'm always receiving the following error:
"HTTP Status 403 - Access to the specified resource has been forbidden"

GET request doesn't work either, getting "404 - The requested resource is not available."

I can login to Finesse desktop with this agent's account details, so I'm sure the password is correct.

Actually, it doesn't matter what username or password or request content I send, the result is always the same..

1 Accepted Solution

Accepted Solutions

Deepak Rawat
Cisco Employee
Cisco Employee

Check the Sign In to Finesse section of the developer guide. The one (Chapter 2) you are looking at is just for an illustration purpose.


Actual URL will be like below:


https://<FQDN of your UCCX Server>:8445/finesse/api/User/<userid of agent>

In the area under Content Options, enter the following:

<User>
<state>LOGIN</state>
<extension>agents extension</extension>
</User>

Regards

Deepak

- Rate Helpful Posts -

View solution in original post

2 Replies 2

Deepak Rawat
Cisco Employee
Cisco Employee

Check the Sign In to Finesse section of the developer guide. The one (Chapter 2) you are looking at is just for an illustration purpose.


Actual URL will be like below:


https://<FQDN of your UCCX Server>:8445/finesse/api/User/<userid of agent>

In the area under Content Options, enter the following:

<User>
<state>LOGIN</state>
<extension>agents extension</extension>
</User>

Regards

Deepak

- Rate Helpful Posts -

It works with "https", thank you so much!

Can't believe I missed that..

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: