cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
964
Views
0
Helpful
1
Replies

JDBC Connection (via Crystal Reports) to UCCX 10.X Database

Mark Swanson
Enthusiast
Enthusiast

Trying to establish an database connection between Crystal Reports and UCCX 10.6 using the IBM Informix JDBC Driver per the following discussion;

https://supportforums.cisco.com/discussion/11274556/jdbc-connection-url-uccx-8x-historical-db

Additionally, I referenced the following URLs;

https://supportforums.cisco.com/discussion/12542926/informix-jdbc-driver-ifxjdbcjar-file-version

https://apps.support.sap.com/sap/support/knowledge/public/en/1527666

https://ninomartinez.wordpress.com/tag/cisco/

I attempted to install the Informixmsi provided by Deepak but he was a little unclear how to do so. Do I install this driver as a Custom File or regular Database Driver. Plus, the Informixmsi file doesn't contain jar files. And, I assume this driver needs to be installed on the desktop running the Crystal Reports. Therefore, I attempted to install the Informix JDBC Driver v3.50.JC9 as well as v3.70.JC8 via the following URL;

https://www-01.ibm.com/marketing/iwm/tnd/search.jsp?go=y&rs=ifxjdbc

When I launch the SAP Crystal Reports 2008 application, I select 'Create New Connection' and the connection type as 'JDBC (JDNI)'. Within the JDBC Connection parameters, I configured the following;

For example)

Connection URL = jdbc:informix-sqli://192.10.20.30:1504/db_cra:INFORMIXSERVER=uccxserver01_uccx

Database Classname = com.informix.jdbc.IfxDriver

Then I click 'Next' and enter the Database (db_cra), Username (uccxhruser) and Password for uccxhruser.

However, Crystal Reports prompts the following Error Message:

"Failed to open the connection. Details: JDBC driver not found."

Again, I get this error message AFTER installing the Informix JDBC Driver on the desktop, to the default location (i.e. C:\Program Files\IBM\Informix_JBDC_Driver). The desktop is running Windows 7 Enterprise SP1 64bit.

If I change the Connection URL to;

jdbc:informix-sqli://uccxserver01:1504/db_cra:INFORMIXSERVER=uccxserver01_uccx

I get the same error message. Any ideas? Thank you.

1 Reply 1

Chakshu Piplani
Cisco Employee
Cisco Employee

Here are the steps if you follow them as it is you should get a successful connection.

Install informix MSI which will give you IBM INFORMIX ODBC DRIVER 3.00.00.13219

Now since most of the systems are 64 bit machines this driver will not show up in odbc if you go via start menu.

go to this path and the file

C:\Windows\SysWOW64\odbcad32.exe

Go to the drivers page and verify you have the exact version as I mentioned above.

Now we create a system DSN using that driver.

Put any datasource name

Go to connection tab

servername:servername_uccx

hostname:IP

service:1504

protocol:olsoctcp

options:leave bank

database name:db_cra

userid:uccxhruser

password:password you set at password management page

Apply and test connection, you might get error the locale does not match.

now go to environment tab:

check, use server database locale, it will take sometime to fetch the locale and auto change it to "en_US.57372"

go back to connection tab and test.

HTH

Regards,

Chakshu

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers