cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
547
Views
5
Helpful
8
Replies
Beginner

Script Question

Hi Everyone

I'm in the process of teaching myself how to create scripts for UCCX. So I watched a video on youtube and I followed the steps but when I call my trigger the  phone just rings and I get an annunciator saying that we have system issues instead of playing the prompt. What I've done so far is I've created my script and setup a parameter so I can pick the wav file for script. The wav file was recording through the prompt recorder and it's in the repository. I wanted to know can someone take a look at my screen shot and tell me does this look right.

 

Eric

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Script Question

So now the script is actually working.
first verify that you are using correct language and a prompt is present.
Next, read the manual about the menu step.
3rd you are missing a hangup step. when the script goes past the menu step, you just end. and the call is not disconnected.

View solution in original post

8 REPLIES 8

Re: Script Question

Have you validated your script from the script editor?

 

Also you can try and use one of the predefined scripts and verify that the triggers and cti-port configuration is correct. 

Next step could be to do a reactive debugging from the editor on the script to see how far you get.

Beginner

Re: Script Question

I took for granted that the script was correct and didn't run the validation tool and it came back with an error, I've attached a screen shot of the error.

Highlighted

Re: Script Question

okay, so you are refering to a prompt that is not present.
The way you have configured now is you first play a prompt, from a parameter. next you have a Menu, which also needs to play a prompt. so you need to select a valid prompt here. Perhaps you just need to play the one prompt. Then remove the play prompt step and select you parameter in the Menu.
Beginner

Re: Script Question

I deleted the prompt and right clicked the menu and assigned the prompt there and also validated the prompt which comes back as good now. But when I call my trigger now it says are you still there 3 times and then it says we are having system issues.

Re: Script Question

So now the script is actually working.
first verify that you are using correct language and a prompt is present.
Next, read the manual about the menu step.
3rd you are missing a hangup step. when the script goes past the menu step, you just end. and the call is not disconnected.

View solution in original post

Beginner

Re: Script Question

Thanks for the help Martin, what I'm going to do is just delete the script and start over gain tomorrow. What I'm trying to do is get decent at UCCX  because TAC won't help with Scripts and consultants want to charge you an arm and a leg to do the work. I'm going to watch the YouTube video again and also do some of the practice scripts in the getting started with Scripts Cisco manual. I'll eventually get it I just need to practice more and post more on the board. Again thanks for the help and I'll be talking to you again sooner than later :)

 

Eric

VIP Advisor

Re: Script Question

You seem like a nice person, and also seem excited to learn, and I like that. But I think your view of TAC and Consultants might be a little skewed. I'd encourage, as you spend time posting more on the board, to ask yourself who the people are answering the majority of the questions on here. I think you'll find that it's TAC and Consultants. We're people too man. Good luck with your learning.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
Beginner

Re: Script Question

Thanks Anthony and I'm about to really start asking more question on scripting because even though we don't make a lot of changes to our script environment when question arise I need to have an answer.

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards