Showing results for 
Search instead for 
Did you mean: 

1010 stuck at loader prompt

Patrick Colbeck


I just installed a new VSM on my 1010 pair and the secondary suddenly died.

When I ssh to the CMIC and connect to the 1010 it is at the "loader >" prompt.

If then issue a "boot nexus-1010-kickstart-mz.4.2.1.SP1.4.bin" it starts loading it but after awhile drops back to the same prompt with no errors displayed.

If I leave it eventual;ly it reboots by itself and again drops to teh loader prompt.

Any ideas ?

7 Replies 7

Patrick Colbeck

Spent hours playing with this. It looks like there is nothing you can do from the CMIC when its like this. Its in a lights out DC so I will have to drive down there tommorow and stick a CD in the drive and rebuild tha damn thing, I hope its just a corrupt file not a disc drive dying.

Have you call Cisco TAC on this?  They can help rebuild that 1010 via a remote ISO image to boot instead of physically going to the site to place a CD ROM into the 1010.  It sounds like the image on the 1010 is either missing or corrupted and can't boot from that image.


Thanks Cuong

That will save a drive. I have got my customer to raise a TAC case to find out how to do this. Will be very usefull as both the DCs are quite a way from where the newtork ops team live.


Yes I would definitely open a TAC case and they can help you rebuild it.  Since you are able to get to the console (i.e. CIMC connection), the 1010 allows to remote boot from an ISO image.  So TAC will be able to help here.



I figured it out myself in the end without TAC. Once we ditched IE (which was all that was available by default on the DC admin PC) and used Firefox instead the CMIC GUI worked properly and I could see the option to attatch an ISO as a virtual CD. Worked like a charm. It crashed again after the reinstall though again back to "loader" but I have an idea. Will update this thread once I have checked a couple of things out. 

The UCS C series manuals are much more detailed on using the CMIC than the 1010 manuals and since the 1010 is a C series UCS ....

OK think I fixed it. This is a weird gottcha though.

The problem started when I was adding a new VSB, half way through deploying it was when we had the first crash,

After reinstalling it was during "enable secondary" that it crashed again.

I checked the new VSB config and it had the same domain id as the 1010s domain id. I therefore changed the VSB domain id to something else reinstalled the secondary 1010 and now when I synch them back up the secondary 1010 doesn't crash !

Weird result for a config error that isn't even warned about in the docs though. Setting a VSB domain ID the same as the 1010 domain ID seems to completely corrupt the OS on the secondary 1010. Looks for all the world like a hard drive failing.

Yeah that will be a problem with your VSB Domain ID is the same as the 1010 Domain ID.  If the control vlan was different then it probably would be alright but as a best practice, probably want to use a unique Domain ID for your 1010 and VSB (i.e. VSMs).


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers