Showing results for 
Search instead for 
Did you mean: 

problems when adding host


Has anyone hit the problem of adding one host, while the other host works just fine (and appears as VEM). When trying to add the host vsphere replies with the following error:".....SysinfoException: Node (VSI_NODE_net_create); Status(bad003)=Not found; Message= Instance(0): Input (3) DvsPortset-0 256 cisco_nexus_1000v got (vim.fault.PlatformConfigFault) exception"


Has anyone observed the same problem?

Thanks a lot


5 Replies 5


Does the command "net-dvs -l" show any output? If so, does the dv switch name (in the 1st line of output) match the name of the DVS you are trying to create?

BTW, if you have an ESX (with Service Console), the net-dvs command is in the path /usr/lib/vmware/bin/.



Hi Sundar,

thanks for your suggestion. I have checked the particular ESXi host for any distributed switches via vCLI. There were only standard switches in the output. Thus I have tried to manually add dvs n1kv. I got "DVSwitch n1kv is not found".

However the second EXSi host (where the VSM resides) was added without any problems. Also when searching for switches, the working ESXi host shows n1kv as a dvs switch and is included as a VEM in sh modules.

What I don´t undesrstand is when n1kv is created in VC, the connection VC-VSM is enabled, one ESXi host is just fine while being added...what´s up with the second ESXi host:(

There might be a issue with different builds. The working ESXi has 171294 build, the problematic one 208167. So do you think I should downgrade the not working one?

I realy dunno...

Thanks a lotfor your help


Hi Helena,

   From your reply, it looks like the problem host does not have the VEM installed.

Different ESX builds require different Nexus 1000V VIBs for compatibility. I suspect you may have tried to install an incompatible VIB version on the problem host.

If you are using N1k release 4.0(4)SV1(2), you will find VMware EX build + VIB compatibility info at:

If you are using release 4.0(4)SV1(1), please use:


Hi Sundar,

thanks for your advice. I had suspected the mismatch in versions as well, but...the ESXi build is 208167 and the installed VEM is VEM400-200911014-BG which seems to be correct according to the compatibility matrix. Sorry for my poor server knowledge, I am still more networking than a server girl;)

Thanks a lot for your patience


Hi Helena,

   You are welcome anytime. Are you open to doing a webex so I can take a look at the host and the VC?

Thanks & Regards,


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers