cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1498
Views
0
Helpful
5
Replies
Highlighted
Participant

2801 H323 Gateway PRI - All Circuits Busy

We are having an issue at one of our branch offices. We randomly receive an "All Circuits Busy" or simply a "Busy Tone" when attempting to call into the site. A reboot the the router/gateway resolves the issue.

Running-Config:

hostname C2801-ACC01

!

boot-start-marker

boot system flash c2801-advipservicesk9-mz.151-3.T4.bin

boot-end-marker

!

!

logging queue-limit 10000

logging buffered 3000000

logging rate-limit 10000

no logging console

no logging monitor

clock timezone AST -4 0

clock summer-time AST recurring

network-clock-participate wic 1

network-clock-select 1 T1 0/1/0

dot11 syslog

no ip source-route

no ip gratuitous-arps

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.130.1 10.10.130.50

ip dhcp excluded-address 192.168.230.1 192.168.230.50

ip dhcp excluded-address 192.168.230.254

ip dhcp excluded-address 172.20.130.1 172.20.130.10

ip dhcp excluded-address 172.20.130.240 172.20.130.254

!

ip dhcp pool DATA

   network 10.10.130.0 255.255.255.0

   default-router 10.10.130.1

   option 150 ip 192.168.111.20

   dns-server 10.1.200.50 10.209.10.6

   netbios-name-server 10.1.200.50 10.209.10.6

!

ip dhcp pool VOICE

   network 192.168.230.0 255.255.255.0

   option 150 ip 192.168.111.20

   default-router 192.168.230.1

   dns-server 10.1.200.50 10.209.10.6

!

ip dhcp pool GUEST-DMZ

   network 172.20.130.0 255.255.255.0

   default-router 172.20.130.1

   dns-server 10.1.200.50

   lease 0 1

!

!

!

ip inspect log drop-pkt

ip inspect WAAS flush-timeout 10

ip inspect one-minute high 1000

ip inspect one-minute low 800

ip inspect tcp max-incomplete host 150 block-time 0

ip inspect name FIREWALL dns

ip inspect name FIREWALL udp

ip inspect name FIREWALL ftp

ip inspect name FIREWALL fragment maximum 256 timeout 1

ip inspect name FIREWALL ntp

ip inspect name FIREWALL pptp

ip inspect name FIREWALL skinny

ip inspect name FIREWALL tcp

ip inspect name FIREWALL icmp router-traffic

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

parameter-map type inspect global

log dropped-packets enable

isdn switch-type primary-dms100

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

voice class h323 1

  h225 timeout tcp establish 3

!

voice class dualtone-detect-params 2

freq-min-power 35

!

voice class custom-cptone CA-custom

dualtone disconnect

  frequency 475 625

  cadence continuous

!

!

!

!

!

voice-card 0

dsp services dspfarm

!

redundancy

!

!

controller T1 0/1/0

pri-group timeslots 1-16,24

!

interface FastEthernet0/0

description 00/ardu/902/454/5033

bandwidth 5120

removed

ip access-group INBOUND in

no ip redirects

no ip unreachables

ip nat outside

ip inspect FIREWALL out

ip virtual-reassembly in

ip verify unicast reverse-path

duplex auto

speed auto

no cdp enable

crypto map removed

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.130

encapsulation dot1Q 130

ip address 10.10.130.1 255.255.255.0

ip access-group OUTBOUND in

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly in

!

interface FastEthernet0/1.230

description VOICE NETWORK

encapsulation dot1Q 230

ip address 192.168.230.1 255.255.255.0

ip access-group OUTBOUND in

ip nat inside

ip virtual-reassembly in

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.230.1

!

interface FastEthernet0/1.330

description GUEST DMZ

encapsulation dot1Q 330

ip address 172.20.130.1 255.255.255.0

ip access-group GUEST in

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Serial0/1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Internal-Service-Module0/0

ip unnumbered FastEthernet0/1.230

service-module ip address 192.168.230.254 255.255.255.0

!Application: CUE Running on AIM2

service-module ip default-gateway 192.168.230.1

hold-queue 512 out

!

ip local policy route-map ICMP-ISP1

ip forward-protocol nd

!

ip flow-cache timeout active 1

ip flow-export source FastEthernet0/1.130

ip flow-export version 9

ip flow-export destination 10.1.200.63 2055

!

no ip http server

ip http secure-server

ip nat inside source list NAT interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 142.176.145.93 track 10

ip route 0.0.0.0 0.0.0.0 184.151.146.1 254

ip route 192.168.230.254 255.255.255.255 Internal-Service-Module0/0

!

!

control-plane

!

!

voice-port 0/1/0:23

connection plar 2700

!

!

!

mgcp profile default

!

sccp local FastEthernet0/1.230

sccp ccm 192.168.10.20 identifier 2 version 5.0.1

sccp ccm 192.168.111.20 identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register CFB00269966A505

associate profile 2 register MTP00269966A505

!

dspfarm profile 2 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 3

associate application SCCP

!

dspfarm profile 1 conference 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

associate application SCCP

!

dial-peer voice 2700 voip

preference 1

destination-pattern [1-8]...

progress_ind setup enable 3

session target ipv4:192.168.111.20

incoming called-number .

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 2701 voip

preference 2

destination-pattern [1-8]...

progress_ind setup enable 3

session target ipv4:192.168.10.20

voice-class codec 1 

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 2702 voip

description CUE AA

destination-pattern 2700

session protocol sipv2

session target ipv4:192.168.230.254

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2703 voip

description CUE AA

destination-pattern 2799

session protocol sipv2

session target ipv4:192.168.230.254

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 3 pots

destination-pattern 918[8,7,0,6][8,7,0,6].......

port 0/1/0:23

forward-digits 11

!

dial-peer voice 4 pots

destination-pattern 9[2-9]11

port 0/1/0:23

forward-digits 3

!

dial-peer voice 5 pots

destination-pattern 90[2-9]..[2-9]......

port 0/1/0:23

forward-digits 11

!

dial-peer voice 6 pots

destination-pattern 9011T

port 0/1/0:23

prefix 011

!

dial-peer voice 7 pots

destination-pattern 90

port 0/1/0:23

prefix 0

!

dial-peer voice 8 pots

incoming called-number .

direct-inward-dial

port 0/1/0:23

!

dial-peer voice 2 pots

destination-pattern 91[2-9]..[2-9]......

port 0/1/0:23

forward-digits 11

!

dial-peer voice 1 pots

destination-pattern 9[2-9]......

port 0/1/0:23

forward-digits 7

!

!

sip-ua

mwi-server ipv4:192.168.230.254 expires 3600 port 5060 transport udp

!

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 192.168.230.1 port 2000

max-ephones 24

max-dn 30

voicemail 2799

call-forward busy 2799

call-forward noan 2799 timeout 18

My new home on the web: www.closetgeek.ca       

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hello Adam,

I had the same issue too.

Just paste these commands into your Router and let me know if there is any difference.

call threshold global cpu-avg low 85 high 90 busyout

call threshold global total-mem low 85 high 90 busyout

call threshold global total-calls low 5 high 5000 busyout

You may have to reboot your router.

Hope this helps.

Regards,

Venkitesh

View solution in original post

5 REPLIES 5
Highlighted
Hall of Fame Master

Update IOS and check again.

Highlighted

I should have specified before. I have upgraded a few times - most recently to:

(C2801-ADVIPSERVICESK9-M), Version 15.1(3)T4

Still facing the same issues.

My new home on the web: www.closetgeek.ca

Highlighted

Plase update again to latest, if still trouble will need traces for when it happens.

Highlighted

Hello Adam,

I had the same issue too.

Just paste these commands into your Router and let me know if there is any difference.

call threshold global cpu-avg low 85 high 90 busyout

call threshold global total-mem low 85 high 90 busyout

call threshold global total-calls low 5 high 5000 busyout

You may have to reboot your router.

Hope this helps.

Regards,

Venkitesh

View solution in original post

Highlighted
Participant

Hi Venkitesh,

I made these changes a couple weeks ago and have not seen any issues since.

Can you give me some details around these commands? I know they worked, but would like to know why

My new home on the web: www.closetgeek.ca