cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1163
Views
0
Helpful
0
Replies

9951 with firmware 9.3.2-10 and Asterisk

alfredos
Beginner
Beginner

Hi,

I had the idea of upgrading a 9951, which was happily talking to Asterisk, to version 9.3.2-10 from 9.2.3-27, in order to try get a fix for a few cosmetic issues. Now it won't register with Asterisk.

The phone downloads its configuration file as usual, as well as the files mentioned in it (dialplan.xml, DefaultFP.xml, etc) but won't register with Asterisk. About 3 minutes later it re-tries the same, endlessly.

A packet capture shows the phone saying things in XML within SIP/TCP REFER messages to the configured Asterisk box, which the Asterisk acknowledges. It doesn't try to REGISTER, though.

Status messages complain about the trust list and VPN not configured. It doesn't say whether these are mere warnings or critical errors.

I tried messing around with the xml configuration file, but couldn't make it work. I tried many searches but couldn't find anything.

I am currently trying to go back to 9.2.3 but I am uneasy thinking the current setup is a dead end with no upgradeability. So what I want is to make 9.3 work.

Any ideas or pointers appreciated.

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers