cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1085
Views
0
Helpful
1
Replies
Highlighted
Beginner

Alcatel > Asterisk Call Transfer MOH

Hi Everyone,

Alcatel ---> 2901 (3xxx) <-----------------Fibre IP   LINK---------------> 2901 (in Data Centre) ------->Primary IP PBX

The above is a basic network diagram.

I have been working on linking an Asterisk based system to an Alcatel 4400 for over a year now which has gave me nothing but problems that have all been Cisco related.

I have ironed them all out apart from 1 and I am completly stumped - I would really appreciate some help.

Scanario:

Alcatel handset rings an IP handset - Call established.  Alcatel handset wants to transfer call to another Alcatel handset so they enter number.  At this point the Asterisk MOH kicks in and plays to the IP handset.  Alcatel handset puts call through and hangs up but MOH does not stop on IP handset however there is one way audio.  The Alcatel handset can hear the IP handset but the IP handset is still listning to MOH.

I found that I can fix this by setting session protocol sipv2 against the dialplan but it stops calling/called names passing up the trunk.  I would like to leave it set to session protocol cisco which allows all names/calling names etc to pass.

Config files:

Alcatel Router:

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname C2901_A_ALCATEL

!

boot-start-marker

boot-end-marker

!

card type e1 0 1

logging buffered 51200 warnings

!

no aaa new-model

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

--More--

Oct 19 09:53:48.476: %SYS-5-CONFIG_I: Configured from console by itadmin on vty0 (10.11.0.50)

!

!

isdn switch-type primary-qsig

isdn gateway-max-interworking

!

!

!

voice-card 0

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

qsig decode

fax protocol pass-through g711alaw

h323

  h225 timeout setup 2

  h225 display-ie ccm-compatible

!

voice class codec 1

codec preference 1 g711alaw

!

!

!

!

license udi pid CISCO2901/K9 sn FCZ160990PE

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

controller E1 0/1/0

pri-group timeslots 1-31

!

controller E1 0/1/1

!

!

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.0.0.52 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.11.0.55 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving T302 2000

isdn incoming-voice voice

isdn send-alerting

isdn bchan-number-order ascending

isdn sending-complete

isdn outgoing display-ie

no cdp enable

!

router rip

network 10.0.0.0

!

no ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

no cdp run

!

!

control-plane

!

!

voice-port 0/1/0:15

!

!

!

!

dial-peer voice 1 voip

destination-pattern 3...

session target ipv4:10.0.0.53

session transport udp

voice-class codec 1

fax-relay ecm disable

fax protocol pass-through g711alaw

!

dial-peer voice 5 pots

destination-pattern 9.+

direct-inward-dial

port 0/1/0:15

prefix 9

!

dial-peer voice 6 voip

destination-pattern 2...

session target ipv4:10.0.0.53

session transport udp

voice-class codec 1

!

dial-peer voice 7 pots

destination-pattern 4...

direct-inward-dial

port 0/1/0:15

prefix 4

!

dial-peer voice 8 pots

destination-pattern 5...

direct-inward-dial

port 0/1/0:15

prefix 5

!

dial-peer voice 9 pots

destination-pattern 7...

direct-inward-dial

port 0/1/0:15

prefix 7

!

dial-peer voice 2 voip

preference 1

destination-pattern 3...

session target ipv4:10.11.0.51

session transport udp

voice-class codec 1

fax-relay ecm disable

fax protocol pass-through g711alaw

!

!

sip-ua

retry invite 2

timers trying 150

!

!

!

gatekeeper

shutdown

!

!

line con 0

logging synchronous

login

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

VOIP Router

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 2901_B_DC

!

boot-start-marker

boot-end-marker

!

card type e1 0 1

logging buffered 51200 warnings

!

no aaa new-model

network-clock-participate wic 1

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-qsig

isdn gateway-max-interworking

!

!

voice-card 0

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

qsig decode

fax protocol pass-through g711alaw

h323

  h225 display-ie ccm-compatible

!

voice class codec 1

codec preference 1 g711alaw

!

!

!

!

license udi pid CISCO2901/K9 sn FCZ160990PL

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

controller E1 0/1/0

pri-group timeslots 1-31

!

controller E1 0/1/1

!

!

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.0.0.53 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.11.0.54 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving T302 2000

isdn protocol-emulate network

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

isdn outgoing display-ie

no cdp enable

!

no ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

no cdp run

!

!

control-plane

!

!

voice-port 0/1/0:15

!

!

!

!

dial-peer voice 3 pots

destination-pattern 3...

direct-inward-dial

port 0/1/0:15

prefix 3

!

dial-peer voice 9 voip

destination-pattern 9.+

session protocol sipv2

session target ipv4:10.0.0.52

session transport udp

voice-class codec 1

!

dial-peer voice 4 voip

destination-pattern 4...

session protocol sipv2

session target ipv4:10.0.0.52

--More--

Oct 19 09:54:28.680: %SYS-5-CONFIG_I: Configured from console by itadmin on vty0 (1 session transport udp

voice-class codec 1

!

dial-peer voice 7 voip

destination-pattern 7...

session protocol sipv2

session target ipv4:10.0.0.52

session transport udp

voice-class codec 1

!

dial-peer voice 5 voip

destination-pattern 5...

session protocol sipv2

session target ipv4:10.0.0.52

session transport udp

voice-class codec 1

!

dial-peer voice 2 pots

destination-pattern 2...

direct-inward-dial

port 0/1/0:15

prefix 2

!

dial-peer voice 8 voip

preference 1

destination-pattern 4...

session protocol sipv2

session target ipv4:10.11.0.50

session transport udp

voice-class codec 1

!

dial-peer voice 10 voip

preference 1

destination-pattern 9.+

session protocol sipv2

session target ipv4:10.11.0.50

session transport udp

voice-class codec 1

!

dial-peer voice 11 voip

preference 1

destination-pattern 7...

session protocol sipv2

session target ipv4:10.11.0.50

session transport udp

voice-class codec 1

!

dial-peer voice 12 voip

preference 1

destination-pattern 5...

session protocol sipv2

session target ipv4:10.11.0.50

session transport udp

voice-class codec 1

!

!

sip-ua

retry invite 2

timers trying 150

!

!

!

gatekeeper

shutdown

!

!

line con 0

login local

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

1 REPLY 1
Beginner

Alcatel > Asterisk Call Transfer MOH

anyone?

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards