Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Cannot log into Unified CM Administration 6.1.2 in after replacing hostname

I am running CUCM 6.1.2 (Publisher) in VMWare. There is no Subscriber.

I decided to follow advice in the CIPT1 book and to change the Host Name / IP Address field located in Cisco Unified CM Administration from the host name to the IP address of the Publisher. Now when I am trying to log in to Cisco Unified CM Administration, I get the "Database communication error" message.

In the past, I changed the original host name to a different host name and had the same problem when trying to log in to Cisco Unified CM Administration. However, then I proceeded to change the host name in the CLI by using the "set network hostname" command. After I restarted, I was able to log in.

This time, however, I cannot fix the problem. The CLI would not take the "set network hostname" command with an IP address as the argument.

Additionally, when I try to use the "run sql select name,nodeid from ProcessNode", I get the following message:

"Failed to get Connection.Connector(NOT CONNECTED:Driver=com.informix.jdbc.IfxDriver;)"

Does anyone know how to recover from this problem? I can still use the CLI and I can log to the Disaster Recovery System page as well as to Cisco Unified OS Administration page. I cannot log in to Cisco Unified CM Administration page, Cisco Unified Serviceability page, or Cisco Unified Reporting page. I do not have a Disaster Recovery backup.


I have found some references on how to change IP addresses in the CUCM (there's a PDF document published for versions 5.x 6.x and 7.x). However, I have not been able to find any information on how to change the hostname to the IP address.

Basically, the issue at hand is deploying CUCM clusters with DNS support vs. deploying CUCM clusters without DNS support. I was trying to convert a Publisher that was originally installed with the DNS support to the model without the DNS support.

Cisco recommends in its best practices (even for CUCM 7.x) not to rely on DNS. I am trying to see how the cluster (or the Publisher alone in the beginning) will be able to function without any reliance on DNS resolution. That's the reason I had to change the hostname to the IP address (see my original post above). Also, this action was recommended by the CIPT1 book published by Cisco Press (I am not going to regress on the "value" of that book).

So, what I am looking for at this point is any paper (explanations or directions) published by Cisco on how to use the model without the DNS support. Especially, how to migrate from the model with DNS reliance to the model without DNS reliance.

The only place I was able to find how to instruct the CUCM not to use DNS is during the installation phase when going through the configuration steps with the Platform Installation Wizard.

It appears that you can enable DNS support in CUCM as a DNS client by using the "set network dns primary", "set network dns secondary", and "set network options" commands. I have not been able to find how to disable the DNS client in the CUCM so far.

Also, what exactly does "no reliance on DNS" mean? Does it mean that the CUCM itself does not use DNS resolution (as a client) or does it mean that CUCM does not use host names when communicating with other applications or IP phones? I have not been able to find any explanation on this so far.

If anyone can point me to something of value published by Cisco on this topic, I would really appreciate it.


Hi, I have exactly the same issue after an upgrade from 4.1(3) to 6.1(3). Short after the upgrade I was able to access ccmadmin/serviceability and reporting pages. I even made one change. After a few minutes my web pages timed out on db request. I closed the browser, opened it again and loggin in is not possible anymore: Database Communication Error. CM 4.1(3) was using DSN, 6.1(3) was installed without DNS. I even tried "utils reset_ui_administrator_password, but I get an authentication failure on this command, while I'm logged in as admin in CLI? How did you solve your problem?



I have the exact same error this morning after trying to upgrade from 4.2(3) to 6.1(3). Does anyone have any ideas?




I got the same database errors as described above.

I was able to fix this with DNS. During my install of 6.1.3, I did not specify a DNS server. I can only assume the Informix database uses the hostname... Can anyone else confirm?

To fix it:

1) I enabled DNS with the CLI

'admin:set network dns primary'

2) Add a host entry in your dns server for the call manager's hostname.

I used a router as the dns server.


ip dns server

ip host cucm-pub

ip name-server

ip domain-lookup

Content for Community-Ad