cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
576
Views
0
Helpful
1
Replies

Cisco 3745 as Analogue PABX

tsolution
Beginner
Beginner

Hi friends my task is to setup 3745 router as analogue PABX and i need your help.

The router has 2 NM-2V with 8 Voice Ports where 6 are FXS and 2 are FXO

1 FXO is connected to BT Landline , 1 FXO is free for future uses.

6 FXS are connected to standard analouge phones

this router is already connected through VPN tunnel to another location which also has 6 FXS line and all FXS extentions on both locations can communicate each other perfectly.

The only new thing is we added a FXO card on this location and want that

1.user can dial all external numbers as well including international numbers.

2. when some one call on external line, all extenstion ring same time. (i was told that hunt group can only be done in CME)

3. Call transfer between extensions.

4. improve voice quality / avoid call disconnections

5. implement some basic QoS so that internet trafic works fine

6. basic logging i.e. call history etc.

7. basic security / firewall on the router.

please see sh ver and sh run as follow.

My other question is can i install CME 4.1 on this router? it it competible and if yes and i install CME 4.1 on this router, does it require any licensees as we are not using any ip phones at all?

UK2#sh ver

Cisco IOS Software, 3700 Software (C3745-IPVOICE_IVS-M), Version 12.4(23), RELE

SE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Sun 09-Nov-08 01:48 by prod_rel_team

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

UK2 uptime is 3 weeks, 4 days, 22 hours, 57 minutes

System returned to ROM by reload

System image file is "flash:c3745-ipvoice_ivs-mz.124-23.bin"

Cisco 3745 (R7000) processor (revision 2.0) with 243712K/18432K bytes of memory

Processor board ID JHY0902K2BN

R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache

2 FastEthernet interfaces

2 Voice FXO interfaces

6 Voice FXS interfaces

DRAM configuration is 64 bits wide with parity disabled.

151K bytes of NVRAM.

31360K bytes of ATA System CompactFlash (Read/Write)

253952K bytes of ATA Slot0 CompactFlash (Read/Write)

Configuration register is 0x2102

UK2#sh run

Current configuration : 6465 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname UK2

!

boot-start-marker

boot-end-marker

!

enable secret level 2 5 $1$Fs/Z$T5ZhEpSEEGYOV5564C.0pj1

enable secret 5 $1$7S/G$lBwlBlNgxbcMuHvffFpRd8/

!

no aaa new-model

ip cef

!

!

!

!

ip name-server 217.37.xxx.xxx

ip name-server 217.37.xxx.xxx

vpdn enable

!

!

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

codec preference 4 g723r53

codec preference 5 g723r63

!

!

!

!

!

voice class dualtone-detect-params 100

freq-max-deviation 50

freq-min-power 35

!

!

voice class custom-cptone TEST

dualtone busy

dualtone ringback

  frequency 500 632

dualtone reorder

  frequency 500 631

  cadence 500 500

dualtone disconnect

  frequency 630

  cadence 500 500

!

!

!

!

!

!

!

!

!

!

interface Tunnel40

description UK1-UK2

ip address 16.16.16.2 255.255.255.252

tunnel source FastEthernet0/0

tunnel destination 218.205.xxx.xxx

!

!

!

!

interface FastEthernet0/0

description WAN-LINK

ip address 217.37.xxx.xxx 255.255.255.248

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

description LAN

ip address 192.168.20.254 255.255.255.0

ip nat inside

duplex auto

speed auto

!

!

router ospf 1

log-adjacency-changes

network 16.16.16.0 0.0.0.255 area 0

network 192.168.20.0 0.0.0.255 area 0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 217.37.xxx.xxx

ip dns server

!

ip http server

ip nat inside source list 10 interface FastEthernet0/0 overload

ip nat inside source static 192.168.20.250 217.37.xxx.xxx

!

access-list 10 permit 192.168.20.0 0.0.0.255

!

!

!

control-plane

!

!

!

voice-port 1/0/0

supervisory disconnect dualtone mid-call

no battery-reversal

disc_pi_off

echo-cancel coverage 24

no comfort-noise

cptone GB

timeouts initial 5

timeouts interdigit 5

timeouts call-disconnect 5

timeouts ringing 10

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 100

connection plar 806

!

voice-port 1/0/1

!

voice-port 1/1/0

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

voice-port 1/1/1

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

voice-port 2/0/0

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

voice-port 2/0/1

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

voice-port 2/1/0

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

voice-port 2/1/1

disc_pi_off

cptone GB

timeouts call-disconnect 1

timeouts wait-release 1

!

!

!

!

!

dial-peer voice 11 pots

tone ringback alert-no-PI

destination-pattern 0T

progress_ind setup enable 3

progress_ind progress enable 8

progress_ind disconnect enable 8

no digit-strip

port 1/0/0

forward-digits all

!

!

dial-peer voice 500 voip

destination-pattern 5..

voice-class codec 1

session target ipv4:16.16.16.1

!

!

dial-peer voice 801 pots

answer-address 801

destination-pattern 801

no digit-strip

port 1/1/0

!

dial-peer voice 802 pots

answer-address 802

destination-pattern 802

no digit-strip

port 1/1/1

!

dial-peer voice 803 pots

answer-address 803

destination-pattern 803

no digit-strip

port 2/0/0

!

dial-peer voice 804 pots

answer-address 804

destination-pattern 804

no digit-strip

port 2/0/1

!

dial-peer voice 805 pots

answer-address 805

destination-pattern 805

no digit-strip

port 2/1/0

!

dial-peer voice 806 pots

answer-address 806

destination-pattern 806

no digit-strip

port 2/1/1

!

!

gatekeeper

shutdown

!

privilege voiceport level 2 shutdown

privilege configure level 2 voice-port

privilege exec level 2 traceroute

privilege exec level 2 ping

privilege exec level 2 configure terminal

privilege exec level 2 configure

privilege exec level 2 show call active voice brief

privilege exec level 2 show call active voice

privilege exec level 2 show call active

privilege exec level 2 show call

privilege exec level 2 show

!

line con 0

transport output all

line aux 0

transport output all

line vty 0 4

password xxxxxxxxxxxxxxxx

login

transport input all

transport output all

!

!

end

UK2#

1 Reply 1

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

The answer is yes to in general . However for full features, you will need to upgrade to a new router, because the 3745 is too old to support the all the good CME features especially for FXS phones.

Note: if you have never done CME config before, recommend you hire someone that did, otherwise you will spend a lot of time and not get good results.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers