Showing results for 
Search instead for 
Did you mean: 

Cisco 7942g // SIP.9-3-1SR4-1

Hello My name is Eddie and I work for ArrowS3.

I was given a Cisco 7942g running SIP software with the goal of connecting this phone to a Samsung Communcation Manager VoIP system.

The issue I am having is that we need the phone to register at, and use the outbound proxy via UDP.

I was able to change the XML file to use UDP with some online research, but when I set the callmanagergroup proxy to, the phone tries to register to 701021@66.111.x.x <-- public of real

I need the phone to try and register via outbound proxy first, then use

I attached the XML I am using

Thanks for the help


Hall of Fame Community Legend


That is not the correct information. 

This should be your CUCM IP address.


If you have proxy then how come the details are NOT here?

Where are the details of the phone's username and password?


I am not connecting to a CUCM, my VoIP system requires that you connect @domainname

I added my proxy address, but still did not register (

Username = 701021

Password = 0000

While running wireshark,

I can see the phone trying to register to 701021@

The phone is doing a DNS Lookup on, is it possible to disable this?

I want the phone to try and register via outbound proxy 701021@, then use for auth

I am able to configure this on any polycom SIP phone.

Hall of Fame Community Legend

Ok, so you want the phone to directly register with your voice service provider (VSP).

Can you verify with your VSP if they recommend you ENABLE/DISABLE NAT?  How about ALG?


I am local to the VoIP system. I work in a product LAB for Samsung.

Hall of Fame Community Legend

How are you doing this?  Can you draw your lab network?  I want to see which machine is doing the call server.


I have attached the picture of my lab setupSamsung_Cisco7942g.PNG

Hall of Fame Community Legend

Try sticking the SCM IP address here.  CP phones don't like anything with letters in them.  They want IP address.

Another thing, your SEPmacaddress.cnf.xml file has a lot of stuff missing.  Go here:


Hey Leo,

I do see I was missing some options but still not luck using your config.

I do see when the CP phone talking to my PBX when I use the IP in but I get a 404 error code sent by my PBX, due in part because my PBX expects a phone to resgiters via

Look below, this is how I am able to get a polyom IP6000 to register, at first the device does use 285500@, but then uses without doing a DNS lookup


Hope thats not too smail


Hi Eddie,

have you found a solution for the described problem?

I have an similiar problem: My SIP provider only accepts registrations with "phonenumer@dnsname" but my phone registers with "phonenumber@ipaddress"

The DNS lookup cannot be disabled because it is needed to contact the external SIP server, but the phone should register with @dnsname and not with the IP address.

Is there a command or anything to configure this within the conf file?

||| Please rate helpful posts. Thanks! |||

Hey Tony, No I have not