cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2788
Views
0
Helpful
7
Replies

CISCO CDR ERROR 10021

mandarpai2
Beginner
Beginner

The CDR Load is in Disable Loading. I am not able to change it into default settings or to Loading 24*7.

It will show like your request is processing then the server is not responding.

The callmanager version is 6.1

All the 4 values of MIN_DATE.CDR_MIN_DATE and rest 2 are matching and is avaliable in CLI mode.

Dont know how to proceed.

Please someone help me.

1 Accepted Solution

Accepted Solutions

Aman Soi
Advisor
Advisor

Hi Pai,

Di d u try restarting CAR scheduler service.

Please do the following procedure for error u are getting;

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080933fcf.shtml#Problem2

Error Code 10021

When an attempt is made to access CDR Search and CDR report from CDR Analysis and Reporting (CAR) on Cisco Unified Communications Manager (CallManager) 5.X, this error message appears: Error Code 10021 There is no matching records.

Similarly, when an attempt is made to collect data, CAR is not able to collect data and this error message appears: 30023: Data is not available for the date range selected.

Solution 1

  1. This error can occur when the Disable CDR loader check box is checked in CAR. Choose System > Scheduler > CDR Load, and uncheck the Disable Loader check box in order to resolve the issue.
  2. Choose System > Service Parameters, and click the Advanced button in order to display the list of Service Parameters. Make sure that the CDR EnabledFlag is set to True.

Solution 2

Complete the steps mentioned in the Solution for the Error Code 10012.

If these solutions do not solve the issue, contact the Cisco Technical Assistance Center (TAC).

Complete these steps:

  1. Reset the MAX_CDR_NUMBER to a default of two million. Run this query from CLI:

    admin: run sql update car:tbl_system_preferences set
              param_value='2000000' where param_name='MAX_CDR_NUMBER'.
  2. Choose System > Scheduler > CDR Load. Select Disable Loader, and click the Update button in order to disable the CAR loader.Note: CDR data does not load into CAR until you enable CDR loading. Changes take effect at midnight. In order to force the change to take effect immediately, stop and restart the CAR Scheduler service.
  3. Re-enable it, uncheck the Disable Loader check box. Check the Continuous Loading 24/7 check box, and click the Update button.
  4. In order for the changes to take effect immediately, stop and restart the CAR Scheduler service.

regds,

aman

View solution in original post

7 Replies 7

Aman Soi
Advisor
Advisor

Hi Pai,

Di d u try restarting CAR scheduler service.

Please do the following procedure for error u are getting;

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080933fcf.shtml#Problem2

Error Code 10021

When an attempt is made to access CDR Search and CDR report from CDR Analysis and Reporting (CAR) on Cisco Unified Communications Manager (CallManager) 5.X, this error message appears: Error Code 10021 There is no matching records.

Similarly, when an attempt is made to collect data, CAR is not able to collect data and this error message appears: 30023: Data is not available for the date range selected.

Solution 1

  1. This error can occur when the Disable CDR loader check box is checked in CAR. Choose System > Scheduler > CDR Load, and uncheck the Disable Loader check box in order to resolve the issue.
  2. Choose System > Service Parameters, and click the Advanced button in order to display the list of Service Parameters. Make sure that the CDR EnabledFlag is set to True.

Solution 2

Complete the steps mentioned in the Solution for the Error Code 10012.

If these solutions do not solve the issue, contact the Cisco Technical Assistance Center (TAC).

Complete these steps:

  1. Reset the MAX_CDR_NUMBER to a default of two million. Run this query from CLI:

    admin: run sql update car:tbl_system_preferences set
              param_value='2000000' where param_name='MAX_CDR_NUMBER'.
  2. Choose System > Scheduler > CDR Load. Select Disable Loader, and click the Update button in order to disable the CAR loader.Note: CDR data does not load into CAR until you enable CDR loading. Changes take effect at midnight. In order to force the change to take effect immediately, stop and restart the CAR Scheduler service.
  3. Re-enable it, uncheck the Disable Loader check box. Check the Continuous Loading 24/7 check box, and click the Update button.
  4. In order for the changes to take effect immediately, stop and restart the CAR Scheduler service.

regds,

aman