.3.4. Is there any way to force CME to do this?
Here is my config with the test SIP trunk in place.
GMIT-VOICEROUTER01#sh config
Using 8775 out of 245752 bytes
!
! Last configuration change at 13:10:05 boston Sat Nov 30 2013 by cisco
! NVRAM config last updated at 13:10:06 boston Sat Nov 30 2013 by cisco
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname GMIT-VOICEROUTER01
!
boot-start-marker
boot system flash c2800nm-adventerprisek9_ivs_li-mz.124-24.T6.bin
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone boston -4
clock summer-time boston recurring
!
dot11 syslog
no ip source-route
!
!
ip cef
!
ip dhcp pool Voice
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 8.8.8.8 8.8.4.4
option 150 ip 172.16.2.1
!
!
ip domain name domain
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol cisco
sip
!
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729br8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
username xxxxx privilege 15 password 7 xxxxxxxxxxx
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
description MANAGEMENT
ip address 172.16.254.4 255.255.255.255
!
interface FastEthernet0/0
ip address 66.55.220.166 255.255.255.252
ip nat outside
ip virtual-reassembly
shutdown
duplex full
speed 100
!
interface Service-Engine0/0
ip address 172.16.4.250 255.255.255.0
service-module ip address 172.16.4.251 255.255.255.0
service-module ip default-gateway 172.16.4.251
!
interface FastEthernet0/1
ip address x.x.x.x x.x.x.x
duplex full
speed 100
!
interface FastEthernet0/1.10
encapsulation dot1Q 10 native
ip address 192.168.5.2 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 172.16.3.1 255.255.255.0 secondary
ip address 172.16.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
router eigrp 100
redistribute static
passive-interface default
no passive-interface Service-Engine0/0
no passive-interface FastEthernet0/1
no passive-interface Loopback0
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.5.1
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:gui
!
!
ip nat inside source list 101 interface FastEthernet0/0 overload
!
access-list 101 permit ip 192.168.5.0 0.0.0.255 any
access-list 101 permit ip 172.16.0.0 0.0.255.255 any
nls resp-timeout 1
cpd cr-id 1
!
!
!
!
!
snmp-server community xxxxx RO
tftp-server flash:OS79XX.TXT
tftp-server flash:P00307010200.bin
tftp-server flash:P00307010200.loads
tftp-server flash:P00307010200.sb2
tftp-server flash:P00307010200.sbn
tftp-server flash:TERM41.DEFAULT.loads
tftp-server flash:Jar41.2-9-1-45.sbn
tftp-server flash:cnu41.2-7-5-50.sbn
tftp-server flash:CVM41.2-0-1-45.sbn
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0
ring number 2
connection plar opx 7001
description Connected to 20x-xxx-xxxx
caller-id enable type 1
!
voice-port 0/1/1
ring number 2
connection plar opx 7002
shutdown
caller-id enable type 1
!
!
!
!
!
dial-peer voice 3 voip
description *** Voicemail Extension 7000 - Do not delete! ***
destination-pattern 7000
session protocol sipv2
session target ipv4:172.16.4.251
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 1 pots
description *** 10 Digit Calls On Voice Port 0/1/0 ***
destination-pattern [2-9]..[2-9]......
port 0/1/0
!
dial-peer voice 2 pots
description *** 11 Digit Calls On Voice Port 0/1/1 ***
destination-pattern 1[2-9]..[2-9]......
port 0/1/0
!
dial-peer voice 4 pots
description *** 7 Digit Calls On Voice Port 0/1/0 ***
destination-pattern [2-9]......
port 0/1/0
!
dial-peer voice 2000 voip
destination-pattern 200.
session protocol sipv2
session target ipv4:172.16.4.251
dtmf-relay sip-notify
codec g711ulaw
!
dial-peer voice 10 voip
description Incoming Call from SIP Trunk
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
no vad
!
dial-peer voice 11 voip
description to Cell
destination-pattern 20xxx7[1-9]
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
session transport udp
dtmf-relay rtp-nte
no vad
!
!
sip-ua
credentials username xxxxxxxxxx password 7 xxxxxxxx realm xxx.net
authentication username xxxxxxxxxx password 7 xxxxxxxx
no remote-party-id
retry invite 2
retry register 10
timers connect 100
mwi-server ipv4:172.16.4.251 expires 3600 port 5060 transport udp
registrar dns:sbc2.xxx.net expires 3600
sip-server dns:sbc2.xxx.net
!
!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 42
max-dn 100
ip source-address 172.16.3.1 port 2000
auto assign 1 to 10
system message GMIT
url services
http://phone-xml.berbee.com/menu.xml load 7960-7940 P00307010200
voicemail 7000
mwi relay
max-conferences 8 gain -6
moh music-on-hold.au
web admin system name xxxxx secret 5 $1$UfDD$ffCmnvpfJnT5NpJBgnDfk1
dn-webedit
transfer-system full-blind
transfer-pattern 1001
night-service weekday 17:00 07:30
night-service weekend 23:59 23:59
create cnf-files version-stamp 7960 Oct 13 2012 19:30:35
!
!
ephone-dn 1 dual-line
number 7010
description Eric
name Eric
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 2 dual-line
number 7011
description Jenn
name Jenn
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 3 dual-line
number 7012
description Charly
name Charly
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 4 dual-line
number 7013
description Tim
name Tim
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 5 dual-line
number 7014
description Michelle
name Michelle
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 6 dual-line
number 7015
description Jessica
name Jessica
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
mwi sip
!
!
ephone-dn 7 dual-line
number 7016
description Jonathan
name Jonathan
call-forward busy 7000
call-forward noan 7000 timeout 10
mwi-type both
!
!
ephone-dn 8 dual-line
number 7017
description Tech Bench
mwi-type both
!
!
ephone-dn 9 dual-line
number 7018
description Server Room
mwi-type both
!
!
ephone-dn 10
call-forward busy 7000
call-forward noan 7000 timeout 10
!
!
ephone-dn 11
number 8000
mwi on
!
!
ephone-dn 12
number 8001
mwi off
!
!
ephone-dn 13 dual-line
number 7001
label xxx-xxxx
name xxx-xxxx
huntstop channel
!
!
ephone-dn 14 dual-line
number 7002
label xxx-xxxx
name xxx-xxxx
huntstop channel
!
!
ephone-dn 15
call-forward night-service 2000
night-service bell
!
!
ephone-dn 91
number xxxxxx5122 no-reg primary
label xxx-5122
description SIP Trunk 1
!
!
ephone 1
device-security-mode none
mac-address 0019.E778.4559
type 7960
button 1:1 2m2 3m3 4m4
button 5:13 6:14
!
!
!
ephone 2
device-security-mode none
mac-address 000E.D76D.F67C
type 7960
button 1:2 5:13 6:14
!
!
!
ephone 3
device-security-mode none
mac-address 000E.D72E.46E0
type 7960
button 1:3 5:13 6:14
!
!
!
ephone 4
device-security-mode none
mac-address 000E.D76E.0192
type 7960
button 1:4 5:13 6:14
!
!
!
ephone 5
device-security-mode none
mac-address 000E.8461.296E
type 7960
button 1:5 5:13 6:14
!
!
!
ephone 6
device-security-mode none
mac-address 000E.D76E.019F
type 7960
button 1:6 2:91 5:13 6:14
!
!
!
ephone 7
device-security-mode none
mac-address 000D.BD40.7F37
type 7960
button 1:7
!
!
!
ephone 8
device-security-mode none
mac-address 0013.C472.847D
type 7960
button 1:8
!
!
!
ephone 9
device-security-mode none
mac-address 0007.5012.1B41
type 7960
button 1:9
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 194
password 7 00071A150754
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
password 7 1511021F0725
logging synchronous
login local
transport input telnet ssh
line vty 5 15
password 7 00071A150754
logging synchronous
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server tock.usno.navy.mil prefer
end