cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

224
Views
0
Helpful
8
Replies
Highlighted
Beginner

Cisco phones not pulling files from CCME

Hello, I am setting up some phones with an older router and everything works except for the phones aren't getting the ring list or the list of background images from the router. The router is running as the tftp server and the phones can get firmware and register to it ok but even though the files are in flash the phones cannot find them. The current phones I am using are a 7970g and a 7941, I'll post some config and captures below:

 

Cisco2800#show version
Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 15.1(4)M9, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Fri 12-Sep-14 10:45 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Cisco2800 uptime is 7 hours, 58 minutes
System returned to ROM by reload at 15:08:07 local Sun Dec 1 2019
System restarted at 15:09:55 local Sun Dec 1 2019
System image file is "flash:c2800nm-adventerprisek9-mz.151-4.M9.bin"
Last reload type: Normal Reload


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2851 (revision 1.0) with 509952K/14336K bytes of memory.
Processor board ID FHK1128F0PU
2 Gigabit Ethernet interfaces
2 Serial interfaces
1 Channelized T1/PRI port
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
247280K bytes of USB Flash usbflash1 (Read/Write)
500472K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO2851             FHK1128F0PU



Configuration register is 0x2102
Cisco2800#show running-config
Building configuration...


Current configuration : 13630 bytes
!
! Last configuration change at 23:08:34 local Sun Dec 1 2019
! NVRAM config last updated at 22:25:04 local Sun Dec 1 2019
! NVRAM config last updated at 22:25:04 local Sun Dec 1 2019
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco2800
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 ****
enable password ****
!
no aaa new-model
!
clock timezone local -7 0
clock summer-time time recurring
no network-clock-participate slot 1
!
voice-card 0
!
voice-card 1
 dspfarm
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool LAN
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
 dns-server 8.8.8.8
 option 150 ip 192.168.2.1
!
ip dhcp pool lan
 option 150 ip 192.168.2.1
!
!
ip name-server 8.8.8.8
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
!
stcapp call-control mode feature
!
!
!
!
trunk group test
!
!
capf-server
!
!
voice service pots
!
!
voice mlpp
!
!
!
voice emergency response settings
!
!
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-3592846547
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3592846547
 revocation-check none
 rsakeypair TP-self-signed-3592846547
!
!
crypto pki certificate chain TP-self-signed-3592846547
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33353932 38343635 3437301E 170D3138 30333134 30333135
  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35393238
  34363534 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C59C 86049C1F 0DE81B6C DC148E27 30C29A1E D84FBAB7 DA710385 7ED65466
  245E7389 CEACB00D 54B2BD55 58510B3A 13129EC6 EE9CE11B 7FC28183 C97B451D
  A724C8F4 34EB838A 53F07EDC 421A3FE6 40B5278A E3E27693 E097F97F E553C5D9
  5BA09F9A 8A6298F8 C8CA8D32 9675E72F 1622FFCB 10E077F8 27A0D9B4 F3670A1A
  08AB0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14B5C13A 78C82763 FD38A06A ADC2100C 42AA6E36 0F301D06
  03551D0E 04160414 B5C13A78 C82763FD 38A06AAD C2100C42 AA6E360F 300D0609
  2A864886 F70D0101 05050003 818100B5 C41D077F CA3CB0CF AB0FB635 33580D6F
  76E53E54 C6849DF3 CD920EA2 22098727 B172C6E6 8C7B1A07 A6031D5C 4F9DB3F0
  CF01C0C4 E9EBE3FC EBCE7F41 45729965 26199D6B 016D280F 1BAB11AD EDE1E9A2
  4429A908 7A5B7073 67F726B0 4B4518DC BA40EE20 FAE3E4C5 690C3ACA 77D0053E
  770D0F0F 4C4369C8 60897CE3 0949BB
        quit
!
!
license udi pid CISCO2851 sn FHK1128F0PU
!
redundancy
!
!
controller T1 1/0/0
 ds0-group 0 timeslots 1 type fxs-loop-start
 ds0-group 1 timeslots 2 type fxs-loop-start
 ds0-group 2 timeslots 3 type fxs-loop-start
 ds0-group 3 timeslots 4 type fxs-loop-start
 ds0-group 4 timeslots 5 type fxs-loop-start
 ds0-group 5 timeslots 6 type fxs-loop-start
 ds0-group 6 timeslots 7 type fxs-loop-start
 ds0-group 7 timeslots 8 type fxs-loop-start
 ds0-group 8 timeslots 9 type fxs-loop-start
 ds0-group 9 timeslots 10 type fxs-loop-start
 ds0-group 10 timeslots 11 type fxs-loop-start
 ds0-group 11 timeslots 12 type fxs-loop-start
 ds0-group 12 timeslots 13 type fxs-loop-start
 ds0-group 13 timeslots 14 type fxs-loop-start
 ds0-group 14 timeslots 15 type fxs-loop-start
 ds0-group 15 timeslots 16 type fxs-loop-start
 ds0-group 16 timeslots 17 type fxs-loop-start
 ds0-group 17 timeslots 18 type fxs-loop-start
 ds0-group 18 timeslots 19 type fxs-loop-start
 ds0-group 19 timeslots 20 type fxs-loop-start
 ds0-group 20 timeslots 21 type fxs-loop-start
 ds0-group 21 timeslots 22 type fxs-loop-start
 ds0-group 22 timeslots 23 type fxs-loop-start
 ds0-group 23 timeslots 24 type fxs-loop-start
!
!
!
!
!
!
!
!
!
interface Tunnel1
 no ip address
!
interface GigabitEthernet0/0
 description WAN
 ip address dhcp
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
interface GigabitEthernet0/1
 description inside link
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 address autoconfig
 ipv6 enable
!
interface Serial0/0/0
 no ip address
 service-module t1 clock source internal
 no service-module t1 remote-loopback full
 service-module t1 linecode ami
 service-module t1 timeslots all speed 56
 service-module t1 remote-alarm-enable
 service-module t1 fdl att
!
interface Serial0/1/0
 no ip address
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
!
ip forward-protocol nd
ip http server
ip http secure-server
ip http timeout-policy idle 180 life 1800 requests 3
!
!
ip nat inside source list 10 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 255.255.255.0 GigabitEthernet0/0
!
access-list 1 permit any
access-list 10 deny   34.194.59.113 log
access-list 10 permit 34.194.59.113
access-list 10 deny   31.13.76.174 log
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 101 permit ip 192.168.2.0 0.0.0.255 any
access-list 199 permit ip any any
!
!
!
!
!
tftp-server flash:Desktops/320.212.12
tftp-server flash:Desktops/320x212x12
!
control-plane
!
!
voice-port 1/0/0:0
 ring cadence pattern11
 no pulse-digit-detection
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:1
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:2
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:3
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:4
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:5
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:6
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:7
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:8
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:9
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:10
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:11
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:12
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:13
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:14
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:15
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:16
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:17
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:18
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:19
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:20
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:21
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:22
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
voice-port 1/0/0:23
 ring cadence pattern11
 output attenuation 0
 cptone GB
 timing hookflash-in 250 150
 caller-id enable
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager download-tones
ccm-manager sccp local GigabitEthernet0/1
!
!
mgcp profile default
!
sccp local GigabitEthernet0/1
!
dial-peer voice 1 pots
 destination-pattern 9001
 port 1/0/0:0
!
dial-peer voice 2 pots
 destination-pattern 9002
 port 1/0/0:1
!
dial-peer voice 3 pots
 destination-pattern 9003
 port 1/0/0:2
!
dial-peer voice 4 pots
 destination-pattern 9004
 port 1/0/0:3
!
dial-peer voice 5 pots
 destination-pattern 9005
 port 1/0/0:4
!
dial-peer voice 6 pots
 destination-pattern 9006
 port 1/0/0:5
!
dial-peer voice 7 pots
 destination-pattern 9007
 port 1/0/0:6
!
dial-peer voice 8 pots
 destination-pattern 9008
 port 1/0/0:7
!
dial-peer voice 9 pots
 destination-pattern 9009
 port 1/0/0:8
!
dial-peer voice 10 pots
 destination-pattern 9010
 port 1/0/0:9
!
dial-peer voice 11 pots
 destination-pattern 9011
 port 1/0/0:10
!
dial-peer voice 12 pots
 destination-pattern 9012
 port 1/0/0:11
!
dial-peer voice 13 pots
 destination-pattern 9013
 port 1/0/0:12
!
dial-peer voice 14 pots
 destination-pattern 9014
 port 1/0/0:13
!
dial-peer voice 15 pots
 destination-pattern 9015
 port 1/0/0:14
!
dial-peer voice 16 pots
 destination-pattern 9016
 port 1/0/0:15
!
dial-peer voice 17 pots
 destination-pattern 9017
 port 1/0/0:16
!
dial-peer voice 18 pots
 destination-pattern 9018
 port 1/0/0:17
!
dial-peer voice 19 pots
 destination-pattern 9019
 port 1/0/0:18
!
dial-peer voice 20 pots
 destination-pattern 9020
 port 1/0/0:19
!
dial-peer voice 21 pots
 destination-pattern 9021
 port 1/0/0:20
!
dial-peer voice 22 pots
 destination-pattern 9022
 port 1/0/0:21
!
dial-peer voice 23 pots
 destination-pattern 9023
 port 1/0/0:22
!
dial-peer voice 24 pots
 destination-pattern 9024
 port 1/0/0:23
!
!
!
!
telephony-service
 no privacy
 moh-file-buffer 5000
 pin 3274
 extension-assigner tag-type provision-tag
 max-ephones 3
 max-dn 12
 ip source-address 192.168.2.1 port 2000
 timeouts interdigit 7
 timeouts busy 30
 system message ****
 cnf-file location flash:
 load 7912 CP7912080004SCCP080108A.sbin
 load 7941 SCCP41.8-4-2S.loads
 load 7970 SCCP70.8-4-2S.loads
 time-format 24
 max-conferences 8 gain -6
 web admin system name **** password  ****
 dn-webedit
 time-webedit
 transfer-system full-consult
 after-hours override-code ****
 after-hours login http
 directory entry 1 9001 name Analog Line 01
 directory entry 2 9002 name Analog Line 02
 directory entry 3 9003 name Analog Line 03
 directory entry 4 9004 name Analog Line 04
 directory entry 5 9005 name Analog Line 05
 directory entry 6 9006 name Analog Line 06
 directory entry 7 9007 name Analog Line 07
 directory entry 8 9008 name Analog Line 08
 directory entry 9 9009 name Analog Line 09
 directory entry 10 9010 name Analog Line 10
 directory entry 11 9011 name Analog Line 11
 directory entry 12 9012 name Analog Line 12
 directory entry 13 9013 name Analog Line 13
 directory entry 14 9014 name Analog Line 14
 directory entry 15 9015 name Analog Line 15
 directory entry 16 9016 name Analog Line 16
 directory entry 17 9017 name Analog Line 17
 directory entry 18 9018 name Analog Line 18
 directory entry 19 9019 name Analog Line 19
 directory entry 20 9020 name Analog Line 20
 directory entry 21 9021 name Analog Line 21
 directory entry 22 9022 name Analog Line 22
 directory entry 23 9023 name Analog Line 23
 directory entry 24 9024 name Analog Line 24
 fac standard
 create cnf-files version-stamp 7960 Dec 01 2019 19:31:36
!
!
ephone-dn  1
 number 1221
 label Line 1 (1221):
 name SysAdmin-1
 call-forward busy 1222
 hold-alert 30 originator
!
!
ephone-dn  2
 number 1222
 label Line 2 (1222):
 name SysAdmin-2
 call-forward busy 1223
 hold-alert 30 originator
!
!
ephone-dn  3
 number 1223
 label Line 3 (1223):
 name SysAdmin-3
 call-forward busy 0000
 hold-alert 30 originator
!
!
ephone-dn  4
 number 4175
 label Friend Line (4175):
 name Friend-Line
 call-forward busy 9999
 hold-alert 30 originator
!
!
ephone-dn  5
 number 1225
 label SSS Line (1225):
 name ****
 call-forward busy 9999
 hold-alert 30 originator
!
!
ephone-dn  6
 number 3274
 label Aux Line (3274):
 name Aux-Line
 call-forward busy 4175
 hold-alert 30 originator
!
!
ephone-dn  7
 number 0
 label Operator (0):
 name Operator
 hold-alert 30 originator
!
!
ephone-dn  8
 number 911
 label Emergency (911):
 name Emergency-Line
 call-forward busy 9000
 hold-alert 30 originator
!
!
ephone-dn  9
 number 9000
 label Auto Call (9000):
 name Auto-Call
 call-forward all 1221
 hold-alert 30 originator
!
!
ephone-dn  10
 number 9999
 park-slot timeout 60 limit 5
 name Park-Slot
!
!
ephone-dn  11
 number 9998
 paging
!
!
ephone-dn  12
 number 9997
 park-slot
!
!
ephone  1
 no phone-ui snr
 device-security-mode none
 mac-address 000F.F704.2067
 paging-dn 11
 button  1:1 2:2 3:3 4:4
 button  5:5 6:6 7:7 8:8
!
!
!
ephone  2
 device-security-mode none
 mac-address 0026.0B5D.8333
 paging-dn 11
 button  1:4 2:6
!
!
voice-gateway system  1
 create cnf-files
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password Cisco
 login
 transport input all
!
scheduler allocate 20000 1000
end

here is the tftp debug output when I try to pull the tones:

Dec  2 06:18:55.342: TFTP: Server request for port 49178, socket_id 0x4C87192C for process 396
Dec  2 06:18:55.342: TFTP: read request from host 192.168.2.4(49178) via GigabitEthernet0/1
Dec  2 06:18:55.342: TFTP: Looking for ringlist.xml
Dec  2 06:18:55.342: TFTP: Sending error 1 No such file

 and the images:

Dec  2 06:19:39.758: TFTP: Server request for port 49179, socket_id 0x4C87192C for process 396
Dec  2 06:19:39.758: TFTP: read request from host 192.168.2.4(49179) via GigabitEthernet0/1
Dec  2 06:19:39.758: TFTP: Looking for Desktops/320x212x12/List.xml
Dec  2 06:19:39.758: TFTP: Sending error 1 No such file

and here is the flash contents (including only the related parts for length reasons):

305          0 Jan 7 2015 17:21:52 -07:00 Ringtones
306       8224 Jan 7 2015 17:21:52 -07:00 Ringtones/Analog1.raw
307       8307 Jan 7 2015 17:21:52 -07:00 Ringtones/Analog2.raw
308       5280 Jan 7 2015 17:21:52 -07:00 Ringtones/AreYouThere.raw
309       5040 Jan 7 2015 17:21:54 -07:00 Ringtones/AreYouThereF.raw
310       8206 Jan 7 2015 17:21:54 -07:00 Ringtones/Bass.raw
311      12240 Jan 7 2015 17:21:54 -07:00 Ringtones/CallBack.raw
312      16066 Jan 7 2015 17:21:54 -07:00 Ringtones/Chime.raw
313       8160 Jan 7 2015 17:21:54 -07:00 Ringtones/Classic1.raw
314      16080 Jan 7 2015 17:21:56 -07:00 Ringtones/Classic2.raw
315      10800 Jan 7 2015 17:21:56 -07:00 Ringtones/ClockShop.raw
316       2823 Jan 7 2015 17:21:56 -07:00 Ringtones/DistinctiveRingList.xml
317       9665 Jan 7 2015 17:21:56 -07:00 Ringtones/Drums1.raw
318      13610 Jan 7 2015 17:21:58 -07:00 Ringtones/Drums2.raw
319      15928 Jan 7 2015 17:21:58 -07:00 Ringtones/FilmScore.raw
320      16244 Jan 7 2015 17:21:58 -07:00 Ringtones/HarpSynth.raw
321       8245 Jan 7 2015 17:21:58 -07:00 Ringtones/Jamaica.raw
322      16127 Jan 7 2015 17:21:58 -07:00 Ringtones/KotoEffect.raw
323      12776 Jan 7 2015 17:22:00 -07:00 Ringtones/MusicBox.raw
324       8223 Jan 7 2015 17:22:00 -07:00 Ringtones/Piano1.raw
325      15422 Jan 7 2015 17:22:00 -07:00 Ringtones/Piano2.raw
326       9360 Jan 7 2015 17:22:00 -07:00 Ringtones/Pop.raw
327       7200 Jan 7 2015 17:22:02 -07:00 Ringtones/Pulse1.raw
328       4000 Jan 7 2015 17:22:02 -07:00 Ringtones/Ring1.raw
329       4000 Jan 7 2015 17:22:02 -07:00 Ringtones/Ring2.raw
330       4000 Jan 7 2015 17:22:02 -07:00 Ringtones/Ring3.raw
331       4000 Jan 7 2015 17:22:02 -07:00 Ringtones/Ring4.raw
332       4000 Jan 7 2015 17:22:04 -07:00 Ringtones/Ring5.raw
333       4000 Jan 7 2015 17:22:04 -07:00 Ringtones/Ring6.raw
334       4088 Jan 7 2015 17:22:04 -07:00 Ringtones/Ring7.raw
335        495 Jan 7 2015 17:22:04 -07:00 Ringtones/Ringlist.xml
336      10858 Jan 7 2015 17:22:04 -07:00 Ringtones/Sax1.raw
337      14233 Jan 7 2015 17:22:06 -07:00 Ringtones/Sax2.raw
338      16100 Jan 7 2015 17:22:06 -07:00 Ringtones/Vibe.raw

262          0 Jan 7 2015 17:21:12 -07:00 Desktops
263          0 Jan 7 2015 17:21:12 -07:00 Desktops/320x212x12
264     131470 Jan 7 2015 17:21:12 -07:00 Desktops/320x212x12/CampusNight.png
265      80565 Jan 7 2015 17:21:12 -07:00 Desktops/320x212x12/CiscoFountain.png
266       8156 Jan 7 2015 17:21:14 -07:00 Desktops/320x212x12/CiscoLogo.png
267     138278 Jan 7 2015 17:21:14 -07:00 Desktops/320x212x12/FOUNTAIN.PNG
268        740 Jan 7 2015 17:21:16 -07:00 Desktops/320x212x12/LIST.XML
269     109076 Jan 7 2015 17:21:16 -07:00 Desktops/320x212x12/MorroRock.png
270     108087 Jan 7 2015 17:21:16 -07:00 Desktops/320x212x12/NantucketFlowers.png
271      10820 Jan 7 2015 17:21:18 -07:00 Desktops/320x212x12/TN-CampusNight.png
272       9657 Jan 7 2015 17:21:18 -07:00 Desktops/320x212x12/TN-CiscoFountain.png
273       2089 Jan 7 2015 17:21:18 -07:00 Desktops/320x212x12/TN-CiscoLogo.png
274       7953 Jan 7 2015 17:21:18 -07:00 Desktops/320x212x12/TN-Fountain.png
275       7274 Jan 7 2015 17:21:20 -07:00 Desktops/320x212x12/TN-MorroRock.png
276       9933 Jan 7 2015 17:21:20 -07:00 Desktops/320x212x12/TN-NantucketFlowers.png
277          0 Jan 7 2015 17:21:20 -07:00 Desktops/320x212x16
278        740 Jan 7 2015 17:21:20 -07:00 Desktops/320x212x16/LIST.XML
279          0 Jan 7 2015 17:21:20 -07:00 Desktops/320x216x16
280        740 Jan 7 2015 17:21:20 -07:00 Desktops/320x216x16/LIST.XML

Thanks for your time.

1 ACCEPTED SOLUTION

Accepted Solutions
Enthusiast

Re: Cisco phones not pulling files from CCME

Have you also changed the TFTP entries to match?    For example compare the TFTP entries with the actual files in flash (note your names may differ, this is just an example). 

sh run | i ist.xml
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:RingList.xml
tftp-server flash:DistinctiveRingList.xml

sh flash: | i ist.xml
37         164 Aug 13 2012 14:51:46 +04:00 Desktops/320x212x16/List.xml
41         495 May 30 2013 11:46:36 +04:00 RingList.xml
71        2823 May 30 2013 11:47:00 +04:00 DistinctiveRingList.xml

View solution in original post

8 REPLIES 8
Collaborator

Re: Cisco phones not pulling files from CCME

Hi,

Both these files are case sensitive. The phones are looking for the below but what you have in flash is different.

TFTP: Looking for ringlist.xml

TFTP: Looking for Desktops/320x212x12/List.xml

Could you please upload the files in flash exactly with the below name in the corresponding path:

Ringtones/ringlist.xml
Desktops/320x212x12/List.xml

HTH
Rajan
Please rate all useful posts by clicking the star below and mark solutions as accepted wherever applicable

Beginner

Re: Cisco phones not pulling files from CCME

Hello Rajan, Thanks for the fast reply! I tried changing them as shown but
it didn't fix the problem, when I request the rings from the phone it still
gives the same messages on the console, and the phone says "Ring List
Unavailable!" The phone I tested on was the 7970 if it makes a difference.
Collaborator

Re: Cisco phones not pulling files from CCME

What do you see in TFTP logs. Try to see which file name it is requesting and upload the file in that path. BTW List.xml works now ?
Collaborator

Re: Cisco phones not pulling files from CCME

I think ring list xml file should be uploaded in flash itself not from a specific directory like List.xml (Desktops/320x212x12/). You can confirm this from tftp debugs and upload it accordingly.

HTH
Rajan
Enthusiast

Re: Cisco phones not pulling files from CCME

Have you also changed the TFTP entries to match?    For example compare the TFTP entries with the actual files in flash (note your names may differ, this is just an example). 

sh run | i ist.xml
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:RingList.xml
tftp-server flash:DistinctiveRingList.xml

sh flash: | i ist.xml
37         164 Aug 13 2012 14:51:46 +04:00 Desktops/320x212x16/List.xml
41         495 May 30 2013 11:46:36 +04:00 RingList.xml
71        2823 May 30 2013 11:47:00 +04:00 DistinctiveRingList.xml

View solution in original post

Beginner

Re: Cisco phones not pulling files from CCME

Alright, So I tried chnging the file names and directories multiple times, but the phone still can't get it. It is requesting the file as ringlist.xml, ringlist.xml is in flash and the tftp server as the same case and everything but it keeps saying in the tftp log entries that it isn't finding the file. Would restarting the router and phones help possibly?

 

Keith

Enthusiast

Re: Cisco phones not pulling files from CCME

Are you able to manually retrieve the file, for example from Windows command line something like .. 

"C:\>tftp 192.168.2.1 get ringlist.xml

Could you also post up the file entries from "sh flash:", the relevant tftp server entries from the configuration, and the failing debugs, all taken at the current time.  Just so we can see everything at once, in its current state.

Beginner

Re: Cisco phones not pulling files from CCME

Alright, It turned out that the phones were not looking in the same directory, even though it is there. They are looking for all the files in flash bu not in the Ringtones directory. Same goes for the background files, Solved!

Thanks, Keith

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here