Showing results for 
Search instead for 
Did you mean: 

CUCM 7.0 with CallRec recording issue (codec mismatch)



I was wondering if anybody has encountered the following problem:

  • we have a CallManager 7.0 Cluster with a recording solution (CallRec from Zoom)
  • let's say we have Phone A calling Phone B
  • Phone B has a call recording profile configured; the SIP trunk to the CallRec server has a Device Pool asociated with it (therefore a Region with a codec)
  • The codec between Phone A and Phone B is negotiated depending on the regions configured
  • The streams to the recorder server are sent as soon as Phone B picks up

The PROBLEM is that if the codec negotiated between Phone A and Phone B is different than the codec negotiated between Phone B and the SIP trunk to the recording server, Phone B does not send any audio streams to the recording server.

After continuous testing we found that if the codecs are the same the stream gets sent, otherwise it does not.

After viewing the trace files I saw that CUCM locks the codec negotiated between Phone A and Phone B, and after that it sees that the call between Phone B and the recording server requires a different codec. It tries to allocate transcoding resources but it does not succeed.

I tried allocating the software MTPs as well as hardware ones provided by some DSP modules on local voice gateways.

It did not work.

I found that somebody on the forum posted the same issue but in regard to the Transfer functionality of an IP Phone with call recording configured (the problem was caused by the codec mismatch).

6 Replies 6


No responses to this thread, and we are looking at the same problem.   I am not able to find any changes in the documentation or solutions on-line.   From the Features and Services Guide:

The codecs for recording calls match the codec of  the customer-agent call.

There doesn't seem to be any change from 7.0 to 7.1 to 8.0.

Has anyone found a workaround other than allowing g.711 over teh WAN or forcing every call in the enterprise that could possibly be recorded to g.729?


After seeing that nobody replyed to my post I tried to redo the configuration again, more carefully this time.

I did the following:

1. Configure a Hardware transcoder for each Location/Device Pool using the hardware DSPs located in the local voice gateway from each location

2. Configure a Media Resource Group List and Media Resource Group List for each Location/Device Pool containing the previously configured Hardware Transcoders

2. Attach the MRGL to the respective IP Phones and also to the SIP Trunks pointing to the Recording Server (CallREC in my case)

3. Check the "Media Termination Point Required" checkbox in the SIP Trunk configuration page

4. Tested the recording again with every scenario that I could think of and it worked in every situation:

This is aone situation that did not work before:

  • IP Phone A (Device Pool A - HW Transcoder from Location A - Recording Profile with Recording Server in different Device Pool) --> IP Phone B (Device Pool A - HW Transcoder in Location A) - codec G.711
  • IP Phone A --> SIP Trunk to CallREC Server situated in Location B --> codec G.729
  • Now it works with the help of the MTP Required checkbox

Before it did not work because I forgot to check the "MTP Required" checkbox.

The HW Transcoder is required in order to transcode to G.729. Simply configuring a HW transcoder, attaching it to the devices and not checking "MTP Required" checkbox does not solve the problem (this is where i did the mistake previously).

Hope this helps.

If not, let me know, maybe we can find a solution .

Thanks Dragos for providing this information.

I'd love to know if this has solved the issues and if not I'd be happy to have this one picked up by our ZOOM Support team?

ZOOM International

David Ruzius


Aparently my previously mentioned modifications solved the issue.

I contacted your support team afterwards, but in regard with a totally different problem (CallREC related ).

Great support service by the way (from Zoom i mean).


I set up transcoders using dragos instructions and found that when the MTP required setting is checked that 4 sessions are used when transcoding is needed and 2 if transcoding isn't needed. 2 for the required MTP and 2 for transcoding if needed. I removed the MTP required setting and transcoding still worked and only used 2 sessions for the transcoding and wasn't used at all if transcoding wasn't needed.


Lulzim Islami

Since CUCM 7.0 use g.722 as a default codec, my voce recorder from RedBox was not recording internal calls (calls that were made with g.722 codec).

Here are the steps that I used to solve the issue:

Use steps 1-4 from dragos.frantz and add the following commands to

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

codec g722-64

Hope this will solve the issue.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers