Showing results for 
Search instead for 
Did you mean: 

cucm 8.5 software MTP sessions not released

CUCM=> SIP (MTP checked)=> CUBE=> ITSP call transfer is not working if MTP not checked. The issue is after each week or so call transfer does not work.I checked MTP using RTMT and it shows all session are used. So I always need to reset it. I also tried to reset the ipvms app service but that didn't solve the issue. I know it is a better design to avoid MTP but Is there a way to solve this? I am suspecting a BUG
George Thomas

Yep, there were some issues with MTP in release 8.5. Not sure why you would need MTP for call transfer. If you could paste debugs (debug ccsip messages) here with call transfer issue with MTP enabled/disabled, we could  *maybe* try to fix the root cause.

Please rate useful posts.

Hi George,

When internal phone calls a mobile phone then press on transfer placing the first calling party on hold (mobile1) after that dial another mobile2 number and then transfer the call was faling without MTP.

same thing happen if mobile calls in internal and then transfer the call to another mobile.

call flow:

Internal==>CUCM==>SIP==>CUBE==>ITSP==>Mobile1. after the call connect internal click transfer==>CUCM==>SIP==>CUBE==>ITSP==>Mobile2 after connecting internal click on transfer to connect  mobile 1 with mobile 2

so i cheked use MTP on the SIP trunk which solved the issue. However I need to reset the MTP every few days because it is not releasing the session (even with 0 calls) I am sure it is a BUG behaviouer . what if I used IOS software MTP insted and add it to a separate MRG and put it first on MRGL for the SIP trunk?


There are many bugs in call manager 8.5 related to MTP Leak issue for example CSCtk77040


MTP resources may be intermittently leaked, ultimately resulting in failure of
SIP calls that require MTP resources. From RTMT, available MTP resources reach
0 and MTP allocation failure counts go up for each call requiring an MTP.
The SDP portion of the initial INVITE will incorrectly contain "a=inactive".

This issue can only happen in an outgoing initial SIP call setup where MTP is
required. In this case, the outgoing SIP INVITE message will contain an SDP
offer. The issue may occur in the following scenarios:
- Outgoing SIP trunk calls with "Media Termination Point Required" checked on
the SIP trunk.
- Calls between IPv6-only endpoints and IPv4-only endpoints.

This problem does NOT occur in the following scenarios:
- outgoing delayed-offer SIP trunk calls, even if an MTP is required.
- incoming SIP trunk calls.
- mid-call incoming or outgoing INVITE messages.

1. Uncheck "Media Termination Point Required" on the SIP Trunk configuration if
2. If Early Offer is required, configure Early Offer but leave "Media
Termination Point Required" unchecked.
3. For IPv6 deployment, use dual-stack rather than IPv6-only endpoints.



i would receommend  you to upgrade.

I fixed this issue by using IOS MTP on my GW.

However MoH is not played to the ITSP phone. if IPVMA MTP is used MoH is working.


Do you have MoH servers assigned to the MRG/MRGL that is assigned to the GW?

Please rate useful posts.

Yes ofc to the sip trunk u mean. I have created a separate mrg with ios mtp, then add it 1st on the mrgl so ios mtp will always be assigned. The other 2 mrg's have the ipvm server 1mrg for sub the othet for pub. If I remove the mrg which contain ios mtp, moh work. But the ipvm mtp session stuck. Any help on that will be much appreciated.

Collect logs and attach it here if you need help.

Debug ccsip message from GW and CUCM traces for all three possible scenarios.

First with MTP checked on SIP trunk using IPVMA MTP , second with MTP unchecked and third using IOS MTP.

Recognize Your Peers
Content for Community-Ad