cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2150
Views
0
Helpful
2
Replies
t.vandenheuvel
Beginner

CUCM / CUBE Call rings but calling-side keeps ringing on pick-up

Hello all,

I have a CUCM install connected to a 2801 set up as an H232 gateway connected to 3 voip trunks.  Everything has been working fine untill a while ago.

When I get an inbound call and I pick up, the phone acts as it should but the calling side keeps getting the ringtone as if no one picks up.  When I hang up the calling side also gets disconnected.  I have this problem only on inbound calls on one trunk.  Outbound calls and everything on the other trunks works fine.

I contacted the provider of the trunk but they say nothing has changed but they see a SIP 500 internal server error coming from my end.  I did quite some troubleshooting but I can't seem to find the problem.  Most of the config is similar on all three trunks and it has been working flawlessly for quite a while.

I suspect it could have something to do with the video capabilities or codecs (dynamic vs static payload) on the non-working trunk but I don't understand why it has worked before and now doesn't anymore.

Hope someone can help me out here.

I have attached SIP debugs for a call on a working trunk and one on the non-working one.

Config:

vr1-lnkn#sh run

Building configuration...

Current configuration : 6603 bytes

!

! Last configuration change at 14:44:27 UTC Mon Oct 15 2012 by Admin

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname vr1-lnkn

!

boot-start-marker

boot-end-marker

!

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa authorization network default local

!

!        

!

!

!

aaa session-id common

dot11 syslog

ip source-route

!

!

!

ip dhcp excluded-address 192.168.4.1 192.168.4.50

ip dhcp excluded-address 192.168.4.101 192.168.4.255

!

ip dhcp pool VOICE

   network 192.168.4.0 255.255.255.128

   dns-server 192.168.5.11 192.168.5.12

   default-router 192.168.4.1

   option 150 ip 192.168.4.11

!

ip dhcp pool KTPH01

   host 192.168.4.21 255.255.255.128

   client-identifier 0100.1121.111a.d8

!

!

ip cef   

ip domain name <deleted>

ip name-server 192.168.5.11

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

voice service voip

ip address trusted list

  ipv4 192.168.4.0 255.255.255.128

  ipv4 <deleted> 255.255.255.224

  ipv4 <deleted> 255.255.255.224

  ipv4 <deleted> 255.255.255.255

  ipv4 <deleted> 255.255.255.255

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

h323

  emptycapability

  h225 id-passthru

  h245 passthru tcsnonstd-passthru

sip

  bind control source-interface Loopback1

  bind media source-interface Loopback1

  session transport tcp

  no call service stop

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g729r8

!

!

!

!

voice translation-rule 8787

rule 1 /<deleted>/ /1660/

rule 2 /<deleted>/ /1665/

!

voice translation-rule 3185401

rule 1 /^<deleted>/ //

!

voice translation-rule 99051000

rule 1 /<deleted>/ /1665/

rule 2 /<deleted>/ /1668/

rule 3 /<deleted>/ /1660/

!

!

voice translation-profile 3185401

translate called 3185401

!

voice translation-profile 8787

translate called 8787

!

voice translation-profile 99051000

translate called 99051000

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2801 sn FCZ105020RC

username admin privilege 15 secret 5 <deleted>

!        

!

ip ssh version 2

!

!

!

!

!

interface Loopback0

description ROUTER ID

ip address 192.168.5.217 255.255.255.252

!

interface Loopback1

description VOIP GATEWAY

ip address 192.168.4.1 255.255.255.255

h323-gateway voip bind srcaddr 192.168.4.1

!

interface Loopback99

description MGMT

ip address 192.168.6.245 255.255.255.255

!

interface FastEthernet0/0

description TO CS1-2-23

ip address 192.168.5.221 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

description TO CS1-3-23

ip address 192.168.5.225 255.255.255.252

duplex auto

speed auto!

router ospf 1

router-id 192.168.5.217

network 192.168.4.1 0.0.0.0 area 0

network 192.168.5.216 0.0.0.3 area 0

network 192.168.5.220 0.0.0.3 area 0

network 192.168.5.224 0.0.0.3 area 0

network 192.168.6.245 0.0.0.0 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 192.168.5.205

!

logging esm config

!

snmp-server community <deleted> RO

snmp-server location <deleted>

snmp-server contact <deleted>

!

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

ccm-manager mgcp

!

mgcp

mgcp call-agent 192.168.4.11 service-type mgcp version 0.1

mgcp bind control source-interface Loopback1

mgcp bind media source-interface Loopback1

!

mgcp profile default

!

!        

dial-peer voice 2901 pots

description FXS PORT 1

service mgcpapp

port 0/0/0

!

dial-peer voice 2902 pots

description FXS PORT 2

service mgcpapp

port 0/0/1

!

dial-peer voice 2000 voip

description ANALOG LINES

destination-pattern 2...

session target ipv4:192.168.4.11

dtmf-relay h245-alphanumeric

codec transparent

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 1 voip

description <PROVIDER Y> OUTGOING

destination-pattern .T

session protocol sipv2

session target dns:<deleted>

session transport udp

voice-class codec 1 

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1660 voip

description <PROVIDER Y> INCOMING

translation-profile outgoing 3185401

destination-pattern <deleted>.

session target ipv4:192.168.4.11

incoming called-number <deleted>.

voice-class codec 1 

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

dial-peer voice 1604 voip

description <PROVIDER X> INCOMING

translation-profile outgoing 8787

destination-pattern 08787.....

session target ipv4:192.168.4.11

incoming called-number 08787.....

voice-class codec 1 

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

dial-peer voice 1901 voip

description SKYPE INCOMING <deleted>

translation-profile outgoing <deleted>

destination-pattern <deleted>......

session target ipv4:192.168.4.11

incoming called-number <deleted>......

dtmf-relay h245-alphanumeric

codec transparent

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

!

sip-ua

credentials username <deleted> password 7 <deleted> realm <PROVIDER Y>

credentials username <deleted> password 7 <deleted> realm <PROVIDER X>

credentials username <deleted> password 7 <deleted> realm <PROVIDER X>

credentials username <deleted> password 7 <deleted> realm sip.skype.com

credentials username <deleted> password 7 <deleted> realm sip.skype.com

credentials username <deleted> password 7 <deleted> realm sip.skype.com

authentication username <deleted> password 7 <deleted> realm <PROVIDER Y>

no remote-party-id

retry invite 4

retry response 3

retry bye 2

retry cancel 2

retry register 5

timers register 250

registrar 1 dns:<PROVIDER Y> expires 3600

registrar 2 dns:<PROVIDER X> expires 3600

registrar 3 dns:sip.skype.com expires 3600

!

!

banner motd ^C

**************************************************

! UNAUTHORIZED ACCESS PROHIBITED !

**************************************************

^C       

!

line con 0

exec-timeout 30 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 30 0

privilege level 15

logging synchronous

transport input ssh

line vty 0 4

access-class SSH in

exec-timeout 0 0

privilege level 15

logging synchronous

transport input ssh

!

scheduler allocate 20000 1000

ntp server <deleted>

ntp server <deleted>

ntp server <deleted>

ntp server <deleted>

end

vr1-lnkn#

Thanks!

2 REPLIES 2
Zachariah Stewart
Enthusiast

Hi Tom,

          Did you ever find a resolution for your issue? I seem to be having an identical issue including getting the 500 internal server errors etc.

          Any help or info you may have would be much appreciated.

     regards,

                    Zachariah

I did.

After asking a few times it seemed my provider indeed had some changes done in their system: H263 and H264 video codecs were added. 

After they disabled them again for my trunk everything worked again as usual.

Content for Community-Ad

Spotlight Awards 2021