cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
801
Views
0
Helpful
15
Replies
riderfaiz
Beginner

Display initial calling number on a device being forwarded the call to

HI everyone,

I would like to ask... currently I am using CM v11.5. I turned on the phone forwarding on my desk phone (8851) so all calls calling to my ext will forward to my cell.

Here is what happen. If someone from outside calls my desk phone number, it will forward to my cell certainly. But the calling number is not displayed as the initial calling number. Instead, it displayed as my company number. How do I correct this?


Example: Caller A with number 415-111-1111 calls my desk phone 650-123-4567.  My desk phone will forward to my cell 408-888-8888. Now on my cell, I get call...but it shows as 650-123-4567 instead of the calling number 415-111-1111.

How do I configure or correct this?

 

Thank you for your help.

Takami Chiro

2 ACCEPTED SOLUTIONS

Accepted Solutions
Dalton-Covene
Beginner

Hi Takami,

There are a few possibilities here and it may require a bit more information to give a full answer; nonetheless, please find a few things to check below and let me know what you find.  

  1. In the CUCM Admin page, check under Call Routing > Route/Hunt > Route Pattern for the patterns used for PSTN calls to the cell number (650-123-4567).  If your call forwarding on your extension begins with a 9 or 91, the Route Pattern could look something like 9.[2-9]XX[2-9]XXXXXX or 91.[2-9]XX[2-9]XXXXXX
  2. If your PSTN gateway is a CUBE for example, run a SIP debug (debug ccsip messages) and make a test call to recreate the scenario.  Check to see if the Diversion header is included with the original calling party number.  If so, we can use a SIP profile to copy the Diversion field into the From: field of the SIP INVITE. 
  3. Check to see if the "Redirecting Diversion Header Delivery - Outbound" setting is enabled on the SIP Trunk to your CUBE.

I look forward to helping you resolve this issue! 

Please rate this post if it is helpful. 

-Dalton Woolsey

View solution in original post

Hi Takami,

If we click on the T1 interface, we should be able to set the outbound call information as needed, including the Calling Party Selection.  

Please note that the Apply Config/Reset/Restart may drop calls in progress when the config is pushed to the MGCP gateway, so please test after hours. 

Outbound-Calls.JPG

Regards,

Dalton Woolsey

CCIE Collaboration #65061

*Please rate all posts that are helpful*

View solution in original post

15 REPLIES 15
Dalton-Covene
Beginner

Hi Takami,

There are a few possibilities here and it may require a bit more information to give a full answer; nonetheless, please find a few things to check below and let me know what you find.  

  1. In the CUCM Admin page, check under Call Routing > Route/Hunt > Route Pattern for the patterns used for PSTN calls to the cell number (650-123-4567).  If your call forwarding on your extension begins with a 9 or 91, the Route Pattern could look something like 9.[2-9]XX[2-9]XXXXXX or 91.[2-9]XX[2-9]XXXXXX
  2. If your PSTN gateway is a CUBE for example, run a SIP debug (debug ccsip messages) and make a test call to recreate the scenario.  Check to see if the Diversion header is included with the original calling party number.  If so, we can use a SIP profile to copy the Diversion field into the From: field of the SIP INVITE. 
  3. Check to see if the "Redirecting Diversion Header Delivery - Outbound" setting is enabled on the SIP Trunk to your CUBE.

I look forward to helping you resolve this issue! 

Please rate this post if it is helpful. 

-Dalton Woolsey

View solution in original post

thank you very much for all your responses. I really appreciate it.

We do not use SIP but pstn. I will try to schedule a downtime next week and see if this works.

 

stay in touch. Take Care at home and stay in good health!

Hi Dalton,

Thank you for the info. I just checked... our gateway that connecting to the PSTN (PRI) is unknown. But some other branches are using H323 that I know. In the gateway (with unknown status) I could not see any mgcp commands...so do you think mostly we are using H323?

Takami Chiro

Roger Kallberg
VIP Advisor

If your provider of the PSTN connection allows it you could try with enabling send of redirecting number information. Depending on your setup it would be called different things. On a SIP trunk in CUCM it would be “Redirecting Number IE Delivery - Outbound”, select this option and reset the trunk to activate the change. Please bear in mind that this would drop any ongoing calls, so best to carry this out during off hours.

 

Please rate all useful posts

Hi Roger we do not use SIP... but I will try Dalton and Ayodeji suggested then will tell the result.

Thank you very much again! Have a nice weekend.

What protocol do you use in CUCM for your gateway, H.323, MGCP or SIP?

 

Please rate all useful posts

Hi Roger, and everyone,

 

I just got back to the office today and checked on this. I think I am using mgcp as my gateway does contain any dial plan settings for H323. I am pretty sure we do not use SIP. May I ask how to check for sure? If it is MGCP, what do I need to do to achieve the goal?

 

Thank you for your help!

Takami

 

Hi Takami,

 

We should be able to verify this if we log into the CUCM Administration page and navigate to Device > Gateway.  Once you find the gateway, does it state H.323 or MGCP on the right-hand side? 

 

Regards,

 

Dalton Woolsey 

CCIE #65061

 

Please rate all posts as helpful, if applicable. 

Hi Roger, and Dalton,


My gateway is using MGCP for sure. IF this is the case, where I can change the setting? Thank you!


Takami Chiro

 

 

GW_Screenshot.JPG

 

 

 

Hi Takami,

If we click on the T1 interface, we should be able to set the outbound call information as needed, including the Calling Party Selection.  

Please note that the Apply Config/Reset/Restart may drop calls in progress when the config is pushed to the MGCP gateway, so please test after hours. 

Outbound-Calls.JPG

Regards,

Dalton Woolsey

CCIE Collaboration #65061

*Please rate all posts that are helpful*

View solution in original post

Hi Dalton,

Thank you for your quick response :) Especially in this kind of condition,and I really sincerely saying thank you to you and all.

 

I did click on the T1 in my GW..and got the following (I did not make any changes)... looks like the "originator" is in place already before I make a change for this? Do I miss something else...regardless Telco may be blocking it?

Takami ChiroGW_Screenshots_2.JPG

Hi Takami,

Always happy to help, and I look forward to resolving this problem with you. 

As this is a T1 PRI interface, please verify with the carrier that they will accept the other Calling Party Number before making any changes.  SIP providers typically do not care what the calling party number is; however, carriers typically require a BTN or specific range of DIDs in the Calling Party field, or they will reject the call.  

Regards,

Dalton Woolsey

CCIE Collaboration #65061 

*Please rate all helpful posts*

Hi Dalton,

Thank you for your suggestion. I will check on my Telco before any changes..

 

At the same time...based on the screenshot I posted in my last response... I have not made any changes yet but it seemed the settings that need to be changed to achieve the goal is in place already (set to "originator" already for outbound call. Am I right...and do I need any further changes?

 

I will check with my Telco. Thank you again!

Takami Chiro

Hi Dalton, and Roger, and everyone,


Good morning! I am sorry to keep you posted late on this... I got into another project and been busy with that. The instructions you provided is very helpful! The "originate" box is the place to check. But it seems like our Telco company blocking it...that is why we could only see our trunk number. When a call be forwarded to another device, it skips the ip phone and no call history be found. So another challenge now is to figure who has called. We have BillyBlue but we may have to configure it correctly for individual to sign in and get what they need.

 

Thank you again for all your help. I really appreciate it. Take care at home, and hope our normal living be resumed soon.

Takami Chiro

Content for Community-Ad

Spotlight Awards 2021