Showing results for 
Search instead for 
Did you mean: 

downgrade 7841 ip phone

I am new to voip and am struggling.

I am trying to downgrade the firmware on my iphone from 12.5 to 11.0 because it is not compatible with my routers. Before I continue keep in mind I will not be connecting to the internet at any point in time during this process and I am using a single pacstar router which has 2 routable ports and 4 switch ports and the 7841s only use sip. 

I copied the firmware from a usb to my routers flash: I can see they are in there when I do dir | inc 78 (all the file names have 78 in them). I config vlan 40 for voice, and configured a sw as voice and a trunk port that allows all vlans. I configured dhcp, sip, tftp, domain name and hostname. The phone is able to pull an ip from my dhcp and I can ping the phone. When I restart the phone or reset it to default it shows it has an ip, it shows the routers hostname and domain name but then when I look at its status it says no dns. So even though i didn't think I needed a dns i configured one on the router and it's not getting the ip I set as the dns (I used the routers ip which the phone shows it has for the routers ip).

I tried doing the upgrade and create profile command but they say error file  deleted flash:/ (then some file that doesnt exist). My supervisor said that error message isn't really important though. But the phone is still not taking the new firmware and downgrading.

3 Replies 3

Leo Laohoo
Hall of Fame Community Legend Hall of Fame Community Legend
Hall of Fame Community Legend

Not all 78xx phones can support 11.0 firmware.  This will depend entirely on the HW revision of the phone.  

How can I check if the hardware does not support it. The specific file my 7841 has on it is sip78xx.12-8-1-0001-455.loads

And I need to downgrade it to sip78xx.12-0-1-11.loads

I also have all the related .sbn files


I fat fingered an ip, I put the vlan as .226 and on dhcp I put for router to be .225

The phone took the firmware but it's not registering a phone number. Any must have commands I could be missing?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers