cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6885
Views
9
Helpful
6
Replies

H.323 Voice Gateway and SCCP Transcoder

stewart699700
Level 1
Level 1

I have a 2851 configured and working as an H.323 Voice Gateway, I also need this to provide some Transcoding!

So I've configured the router and CUCM for Transcoding however I am concerned I don't have enough DSP's available.

The Transcoder is configured and registered to CUCM but I cannot see any DSP channels:

Trowbridge_2851#show dspFarm ALL
Dspfarm Profile Configuration

Profile ID = 1, Service = TRANSCODING, Resource ID = 1
Profile Description :
Profile Admin State : DOWN
Profile Operation State : DOWN IN PROGRESS
Application : SCCP   Status : NOT ASSOCIATED
Resource Provider : FLEX_DSPRM   Status : UP
Number of Resource Configured : 10
Number of Resource Available : 10
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30
Codec : g711alaw, Maximum Packetization Period : 30
Codec : g729ar8, Maximum Packetization Period : 60
Codec : g729abr8, Maximum Packetization Period : 60
Codec : g729br8, Maximum Packetization Period : 60
Codec : g729r8, Maximum Packetization Period : 60

Total number of DSPFARM DSP channel(s) 0

Trowbridge_2851#

Is this because all my DSP's have been allocated to the E1 Controller or is it because I have not configured my DSP Farm correctly?

The Router has a PVDM card already installed and I'm about to install a PVDM2-16 in addition to this.

Current configuration : 5827 bytes
!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname Trowbridge_2851
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging buffered 4096
enable secret 5 $1$7qf8$AadXwIm.t90qRRJIoz6Mz0
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
ip domain name shaw-trust.org.uk
multilink bundle-name authenticated
!
isdn switch-type primary-net5
!
voice-card 0
no dspfarm
dsp services dspfarm
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
h323
  no h225 timeout keepalive
  call preserve
modem passthrough nse codec g711ulaw
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g722-48
!
!
!
voice class h323 1
h225 timeout tcp establish 4
!
!
!
voice translation-rule 1
!
!
!
username oni privilege 15 secret 5 $1$ltME$.LIKxzAaSWreKEm5lRfJT.
username admin secret 5 $1$Wu8e$YpWJbNv4pE8h3BzwpZaPa0
archive
log config
  hidekeys
!
!
controller E1 0/0/0
pri-group timeslots 1-31
!
ip ssh version 1
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.102.10 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.102.10
!
interface GigabitEthernet0/1
description $ES_LAN$
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.102.1
!
!
no ip http server
ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
cptone GB
!
!
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.2.117 identifier 3 version 5.0.1
sccp ccm 192.168.1.13 identifier 2 version 5.0.1
sccp ccm 192.168.2.118 identifier 1 version 5.0.1
sccp
!
sccp ccm group 1
description 2851 Transcoding
bind interface GigabitEthernet0/0
associate ccm 1 priority 1
associate ccm 2 priority 2
associate ccm 3 priority 3
associate profile 1 register 2851Transcoder1
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729br8
codec g729r8
maximum sessions 10
associate application SCCP
shutdown
!
!
dial-peer voice 9 pots
preference 1
destination-pattern 9T
progress_ind alert enable 8
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 4 voip
description *** DDI Dial peer 71xxxx to 800xxxx ***
preference 2
destination-pattern 800....
progress_ind setup enable 3
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.2.117
dtmf-relay h245-alphanumeric
fax-relay ecm disable
fax nsf 000000
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 5 voip
description *** DDI Dial peer 71xxxx to 800xxxx ***
preference 1
destination-pattern 800....
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.2.118
dtmf-relay h245-alphanumeric
fax-relay ecm disable
fax nsf 000000
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 6 voip
description *** DDI Dial peer 71xxxx to 800xxxx ***
preference 3
destination-pattern 800....
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.1.13
dtmf-relay h245-alphanumeric
fax-relay ecm disable
fax nsf 000000
ip qos dscp cs3 signaling
no vad
!
!
num-exp 999 9999
num-exp 775218 1300
num-exp 716300 8006300
num-exp 716354 8006300
num-exp 716301 901249709068
num-exp 7163.. 80013..
num-exp 7794.. 80014..
alias interface sr do show run
alias configure sr do show run
alias exec sr show run
alias exec sis show isdn status
alias exec sia show isdn active
!
line con 0
exec-timeout 100 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 100 0
logging synchronous
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 192.168.2.134
!
end

1 Accepted Solution

Accepted Solutions

kstyczynski
Level 1
Level 1

Hi,

First: you need to enable dspfarm on your voice-card:

voice-card 0

dspfarm

and then you need to open a transcoder:

dspfarm profile 1 transcode

no shut

What PVDM module do you currently have installed in this router? It is easy to calculate available DSP resources.

Regards,

Chris

View solution in original post

6 Replies 6

Logan Gaffney
Level 1
Level 1

Your transcoding profile on the gateway is in a shutdown state.

conf t

dspfarm profile 1 transcode

no shut

kstyczynski
Level 1
Level 1

Hi,

First: you need to enable dspfarm on your voice-card:

voice-card 0

dspfarm

and then you need to open a transcoder:

dspfarm profile 1 transcode

no shut

What PVDM module do you currently have installed in this router? It is easy to calculate available DSP resources.

Regards,

Chris

Sorry yes I did shutdown the DSPFarm Profile to alter the Maximum Sessions.

It was Active and Registered but it did not show any DSP channels:

Total number of DSPFARM DSP channel(s) 0

You can do a 'sh diag' to check out the DSP resources you have.

Here's a link to calculate DSP resources : http://www.cisco.com/cgi-bin/Support/DSP/cisco_dsp_calc.pl

- Sriram

Please rate helpful posts !

This is looking better, I installed tyhe new DSP and run the "dspfarm", command under the Voicecard.

I now get this:


Trowbridge_2851#
Trowbridge_2851#show dspfarm all
Dspfarm Profile Configuration

Profile ID = 1, Service = TRANSCODING, Resource ID = 1
Profile Description :
Profile Admin State : UP
Profile Operation State : ACTIVE
Application : SCCP   Status : ASSOCIATED
Resource Provider : FLEX_DSPRM   Status : UP
Number of Resource Configured : 10
Number of Resource Available : 10
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30
Codec : g711alaw, Maximum Packetization Period : 30
Codec : g729ar8, Maximum Packetization Period : 60
Codec : g729abr8, Maximum Packetization Period : 60
Codec : g729br8, Maximum Packetization Period : 60
Codec : g729r8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    3   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    5   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    5   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    5   9.4.811  UP     N/A  FREE  xcode  1      -         -         -
0    5   9.4.811  UP     N/A  FREE  xcode  1      -         -         -

Total number of DSPFARM DSP channel(s) 10

Trowbridge_2851#

If I needed to debug the IOS Transcoder is there any useful debugs I should run, "debug voice ccapi" is giving me some output but is there anything more specific?

sh sccp connection, to see the endpoints to which the transcoder is connected

debug sccp packets, to see the skinny message exachange between CCM and the transcoder

- Sriram

Please rate helpful posts !