cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2250
Views
0
Helpful
6
Replies

h323 configuration

ev1205
Level 2
Level 2

Our client is running a CUCM ver 7.1 and they have an already operative MGCP gateway ( cisco 2911 router) at its environment.

Our client is requiring to configure the same router as a H323 gateway too, in order to establish connection with a new  SIP trunk that this router has.

When we try to configure any interface as H323 component we get the following error:

router(config-if)#h323-gateway voip interface

Duplicate multimedia interface with Loopback1.

What can be missing on our configuration that generates this output???

1 Accepted Solution

Accepted Solutions

Hi Enrique,

Found this intresting as generally you receive this error if you already have h323 configured on other interface so I labbed it up for you (weekend fun) and found a work around and some intresting information on this error:

In short you just need to do below:

R1(config-if)#int l1   << re-add loopback1

R1(config-if)#no h323-gateway voip interface   << add this command

R1(config-if)#int loop0
R1(config-if)#h323
R1(config-if)#h323-gateway voip int  <<< now you will be able to add
R1(config-if)#

R1(config)#no int l1 << remove this loopback1

Detailed Explanation is below:

1) Initially I had a Loopback 1 configured with h323.
R1#sh run int l1
Building configuration...

Current configuration : 134 bytes
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.0.0.1
end
2)
Then I tried to configure H323 on the Loopback 0. Received the same error as you were receiving but you did not had Loopback1. I thought, may be you had a loopback1 interface and somebody might have removed from your router. So I replicated the same, removed Loopback1 see below:

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int l0
R1(config-if)#h323-gate voip int
Duplicate multimedia interface with Loopback1.


R1(config-if)#no int loopback 1

3) Now I am exactly replicating the same error and in same position as you are. I have no interface loopback1, but I am still getting this error, see below output:

R1(config)#do sh run int l1
sh run int l1
^
% Invalid input detected at '^' marker.

R1(config)#do sh run int Loopback1
sh run int Loopback1
^
% Invalid input detected at '^' marker.

4) Also see below I dont have H323 configured on any interface, Then I tried again, but still was getting same error as you are getting, see below output:

R1(config)#do sh run | s h323

R1(config)#int loopback0
R1(config-if)#h323-g voip int
Duplicate multimedia interface with Loopback1.

5) Now the main part, the Work around, easiest way, redefine Loopback 1 interface, and issue the no h323-g voip int. Now loopback 0 accepts all the commands, Please see below:


R1(config-if)#int l1
R1(config-if)#no h323-gateway voip interface

R1(config-if)#int loop0
R1(config-if)#h323
R1(config-if)#h323-gateway voip int
R1(config-if)#

R1(config)#no int l1 << remove this loopback1

To summarize:

I think someone had defined Loopback 1 on the router and removed it before removing the commands. If you remove the loopback without removing the h323-gateway voip interface command, the router somehow keeps on holding this command all other commands are removed. So the work around is recreate loopback 1 and issue no h323-gateway voip interface. Please see the below test results:

R1#sh run int l1
Building configuration...

Current configuration : 134 bytes
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.0.0.1
end

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no int l1
R1(config)#end
R1#sh run int l1
^
% Invalid input detected at '^' marker.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int l1
R1(config-if)#do sh run int l1
Building configuration...

Current configuration : 71 bytes
!
interface Loopback1
no ip address
h323-gateway voip interface
end

R1(config-if)#


I hope this is helpful to you. If this resolves your queries please mark this question as answered and rate all helpful posts.

Terry

View solution in original post

6 Replies 6

Terry Cheema
VIP Alumni
VIP Alumni

Hi - From the error it appears you already have h323 configured on Loopback1.

Can you post the sh run or if you dont want to please post the below:

sh run int lo1

sh run int X -   X is the interface you are trying to cnfigure in the above post

sh ip int brief

sh run | s h323-gateway

Terry

Terry, thaks for your fast answer.

Sorry I forgot to say that this router does not have loopback1 configured, as you can see on running-configuration:


Router#sh run
Building configuration...


Current configuration : 9707 bytes
!
! Last configuration change at 19:19:35 AST Thu Jan 17 2013 by admin
!
version 15.0
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Router
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
enable secret 5 $1$T05j$vJkR0V2l2/Iu1mIIeVPcu1
!
no aaa new-model
clock timezone AST -4
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
ip domain name domain.local
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
redirect ip2ip
fax protocol t38 nse force ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
h323
sip
  min-se 90
  header-passing
   outbound-proxy ipv4:10.29.1.10
  midcall-signaling passthru
!
voice class codec 333
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
voice class sip-profiles 1
request CANCEL sip-header Max-Forwards modify ".*" "User-Agent: CUBE"
request CANCEL sip-header Max-Forwards modify ".*" "User-Agent: CUBE"
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1402AKAY
!
!
username netxar privilege 15 secret 5 $1$jQN/$lcnh3q/dHKR.o82qmZ2Q..
username admin secret 5 $1$Wy7X$JoGvQMBRSR7935fOiCylH/
!
redundancy
!
!
controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
description SF 137-6042 primary (redundante GWY-A 137-6041)
!
!
!
!
!
interface Loopback0
description ** USED FOR IPT, ROUTING, MANAGEMENT ETC... **
ip address 192.168.100.11 255.255.255.255
no ip redirects
no ip proxy-arp
!
interface GigabitEthernet0/0
description ISP SIP trunk
ip address 10.29.11.135 255.255.255.128
duplex auto
speed auto
!
interface GigabitEthernet0/1
description *** P2P to 4506 Core A ***
ip address 192.168.101.6 255.255.255.252
no ip redirects
no ip proxy-arp
duplex auto
speed auto
!
interface GigabitEthernet0/2
description *** P2P to 4506 Core B ***
ip address 192.168.101.14 255.255.255.252
no ip redirects
no ip proxy-arp
duplex auto
speed auto
!
interface Serial0/0/0:23
description ** D Channel PRT **
no ip address
encapsulation hdlc
isdn switch-type primary-dms100
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
!
router eigrp 100
network 192.168.100.11 0.0.0.0
network 192.168.101.6 0.0.0.0
network 192.168.101.14 0.0.0.0
passive-interface default
no passive-interface GigabitEthernet0/1
no passive-interface GigabitEthernet0/2
eigrp stub connected summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip http path flash:/GUI
!
ip route 10.29.0.0 255.255.0.0 10.29.11.129
!
logging 10.2.173.5
!
!
!
!
!
!
!
!
!
!

!
control-plane
!
!
voice-port 0/0/0:23
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/0/4
!
voice-port 1/0/5
!
voice-port 1/0/6
!
voice-port 1/0/7
!
ccm-manager redundant-host 192.168.4.11
ccm-manager mgcp
ccm-manager music-on-hold
!
mgcp
mgcp call-agent 192.168.4.12 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp ip qos dscp cs3 signaling
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
dial-peer voice 10 pots
service mgcpapp
port 1/0/0
!
dial-peer voice 11 pots
service mgcpapp
port 1/0/1
!
dial-peer voice 12 pots
service mgcpapp
port 1/0/2
!
dial-peer voice 13 pots
service mgcpapp
port 1/0/3
!
dial-peer voice 14 pots
service mgcpapp
port 1/0/4
!
dial-peer voice 15 pots
service mgcpapp
port 1/0/6
!
dial-peer voice 17 pots
service mgcpapp
port 1/0/7
!
dial-peer voice 16 pots
service mgcpapp
port 1/0/5
!
dial-peer voice 3001 voip
tone ringback alert-no-PI
description *** Testint ISP OUTGOING FOR LOCAL CALLS ***
translation-profile outgoing DN-to-E164-srst
preference 10
destination-pattern 12127062020
session protocol sipv2
session target sip-server
voice-class codec 2
voice-class sip profiles 1
dtmf-relay rtp-nte digit-drop
no vad
!
dial-peer voice 999 voip
description SIP INCOMING DIALPEER
session protocol sipv2
session target sip-server
incoming called-number .
voice-class codec 1
dtmf-relay rtp-nte digit-drop
ip qos dscp cs3 signaling
!
dial-peer voice 9004 voip
description ** TO CM PRIMARY FOR DID piloto **
preference 1
destination-pattern 12126061234
session target ipv4:192.168.4.11
voice-class codec 1
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 9005 voip
description ** TO CM Secondary FOR DID piloto **
preference 2
destination-pattern 12126061234
session target ipv4:192.168.4.12
voice-class codec 1
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
!
gateway
timer receive-rtp 1200
!
sip-ua
set pstn-cause 47 sip-status 486
retry invite 2
retry response 3
retry bye 3
retry prack 6
retry register 3
timers trying 200
timers expires 300000
timers connect 100
sip-server ipv4:10.29.1.10
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 15 0
password 7 014308570A0742
login local
transport preferred none
line aux 0
line vty 0 4
exec-timeout 60 0
password 7 00541D5555574F
login local
line vty 5 15
login local
transport input none
!
scheduler allocate 20000 1000
end
============
============
Router#
Router#sh run int lo1
% Incomplete command.


Router#sh run interface loopback 1
                                           ^
% Invalid input detected at '^' marker.

============
============

Router#sh run interface loopback 0
Building configuration...

Current configuration : 164 bytes
!
interface Loopback0
description ** USED FOR IPT, ROUTING, MANAGEMENT ETC... **
ip address 192.168.100.11 255.255.255.255
no ip redirects
no ip proxy-arp
end


============
============

Router#sh ip int brie
Router#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         10.29.11.135   YES manual up                    up     
GigabitEthernet0/1         192.168.101.6   YES NVRAM  up                    up     
GigabitEthernet0/2         192.168.101.14  YES NVRAM  up                    up     
Serial0/0/0:0              unassigned      YES unset  down                  down   
Serial0/0/0:1              unassigned      YES unset  down                  down   
Serial0/0/0:2              unassigned      YES unset  down                  down   
Serial0/0/0:3              unassigned      YES unset  down                  down   
Serial0/0/0:4              unassigned      YES unset  down                  down   
Serial0/0/0:5              unassigned      YES unset  down                  down   
Serial0/0/0:6              unassigned      YES unset  down                  down   
Serial0/0/0:7              unassigned      YES unset  down                  down   
Serial0/0/0:8              unassigned      YES unset  down                  down   
Serial0/0/0:9              unassigned      YES unset  down                  down   
Serial0/0/0:10             unassigned      YES unset  down                  down   
Serial0/0/0:11             unassigned      YES unset  down                  down   
Serial0/0/0:12             unassigned      YES unset  down                  down   
Serial0/0/0:13             unassigned      YES unset  down                  down   
Serial0/0/0:14             unassigned      YES unset  down                  down   
Serial0/0/0:15             unassigned      YES unset  down                  down   
Serial0/0/0:16             unassigned      YES unset  down                  down   
Serial0/0/0:17             unassigned      YES unset  down                  down   
Serial0/0/0:18             unassigned      YES unset  down                  down   
Serial0/0/0:19             unassigned      YES unset  down                  down   
Serial0/0/0:20             unassigned      YES unset  down                  down   
Serial0/0/0:21             unassigned      YES unset  down                  down   
Serial0/0/0:22             unassigned      YES unset  down                  down   
Serial0/0/0:23             unassigned      YES NVRAM  up                    up     
Loopback0                  192.168.100.11  YES NVRAM  up                    up     
Router#sh run
Router#sh running-config | s h323-gateway
Router#lo     
Router#

=====================================================================

I hope this can help to solve the problem.

Thanks in advanced

Enrique Villasana

Enriquw,

Since you want to connect to a sip trunk, why dont you configure your gateway as a sip gateway rather than use h323. Configure sip trunk from cucm to your gateway. With SIP trunks, you dont necessarily need to configure any bind commands.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

Hi Enrique,

Found this intresting as generally you receive this error if you already have h323 configured on other interface so I labbed it up for you (weekend fun) and found a work around and some intresting information on this error:

In short you just need to do below:

R1(config-if)#int l1   << re-add loopback1

R1(config-if)#no h323-gateway voip interface   << add this command

R1(config-if)#int loop0
R1(config-if)#h323
R1(config-if)#h323-gateway voip int  <<< now you will be able to add
R1(config-if)#

R1(config)#no int l1 << remove this loopback1

Detailed Explanation is below:

1) Initially I had a Loopback 1 configured with h323.
R1#sh run int l1
Building configuration...

Current configuration : 134 bytes
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.0.0.1
end
2)
Then I tried to configure H323 on the Loopback 0. Received the same error as you were receiving but you did not had Loopback1. I thought, may be you had a loopback1 interface and somebody might have removed from your router. So I replicated the same, removed Loopback1 see below:

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int l0
R1(config-if)#h323-gate voip int
Duplicate multimedia interface with Loopback1.


R1(config-if)#no int loopback 1

3) Now I am exactly replicating the same error and in same position as you are. I have no interface loopback1, but I am still getting this error, see below output:

R1(config)#do sh run int l1
sh run int l1
^
% Invalid input detected at '^' marker.

R1(config)#do sh run int Loopback1
sh run int Loopback1
^
% Invalid input detected at '^' marker.

4) Also see below I dont have H323 configured on any interface, Then I tried again, but still was getting same error as you are getting, see below output:

R1(config)#do sh run | s h323

R1(config)#int loopback0
R1(config-if)#h323-g voip int
Duplicate multimedia interface with Loopback1.

5) Now the main part, the Work around, easiest way, redefine Loopback 1 interface, and issue the no h323-g voip int. Now loopback 0 accepts all the commands, Please see below:


R1(config-if)#int l1
R1(config-if)#no h323-gateway voip interface

R1(config-if)#int loop0
R1(config-if)#h323
R1(config-if)#h323-gateway voip int
R1(config-if)#

R1(config)#no int l1 << remove this loopback1

To summarize:

I think someone had defined Loopback 1 on the router and removed it before removing the commands. If you remove the loopback without removing the h323-gateway voip interface command, the router somehow keeps on holding this command all other commands are removed. So the work around is recreate loopback 1 and issue no h323-gateway voip interface. Please see the below test results:

R1#sh run int l1
Building configuration...

Current configuration : 134 bytes
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.0.0.1
end

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no int l1
R1(config)#end
R1#sh run int l1
^
% Invalid input detected at '^' marker.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int l1
R1(config-if)#do sh run int l1
Building configuration...

Current configuration : 71 bytes
!
interface Loopback1
no ip address
h323-gateway voip interface
end

R1(config-if)#


I hope this is helpful to you. If this resolves your queries please mark this question as answered and rate all helpful posts.

Terry

Terry Thanks a lot.

You were so right.

Very helpful your support !

Enrique Villasana

No Probs Enrique, glad I was able to help!

Terry