cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
677
Views
4
Helpful
2
Replies

H323 Gateway configuration

Imran Ul Haq
Level 1
Level 1

Evening all

I have a task in hand to do to perform for the requesting party and I have come up with a configuration that I would love if it could be looked at by my fellow voice engineers - and at the same time perhaps it will benefit some future viewers.....

Considerations:

1) We are in the UK - therefore the dial plan pertains to UK dialling code.

2) We want to configure this 2800 series router running IOS 12.2 or 12.4 with an associated ISDN 30 interface configuration..

3) We are operating with cucm 8.6.2 and unity connection 8.x and have a 6 digit extension schema operating at our sites.

4) Questions

- This is to go out onto a branch office site - therefore is it wise to assign local dhcp configuration on the gateway or should the configuration reside at a central (cross-wan) server....we want to configure unified srst with this configuration....????

- This is currently being moved from MGCP so can you guys see any legacy configuration that is now not required as we are moving to h323?

- I am inheriting this gateway from previous engineers, so please try to highlight errors that you engineers notice, as well as bad practices.

- Lastly, I have tried todo some cucm configuration with the srst reference, and the defenition of the gateway in cucm but I am more than open to any suggestions.....

Big Big thanks in advance guys! much appreciated!:)

The configuration is as follows:

Current configuration : 5235 bytes

!

! Last configuration change at 09:38:26 GMT Fri Oct 12 2012 by lastresort

! NVRAM config last updated at 09:18:38 GMT Tue Oct 16 2012 by lastresort

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname <Hostname>

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

logging message-counter syslog

logging buffered 10000

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXX

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authentication ppp default group tacacs+ local

aaa authorization exec default group tacacs+ local

aaa authorization network default group tacacs+ local

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

!

aaa session-id common

clock timezone GMT 0 0

clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

!

no ipv6 cef

no ip source-route

!

ip multicast-routing

!

no ip bootp server

no ip domain lookup

ip domain name <domain name>

ip name-server <ip address>

ip name-server <ip address>

ip name-server <ip address>

ntp server <ip address> prefer

ntp server <ip address>

ntp server <ip address>

ntp server <ip address>

no ip cef

multilink bundle-name authenticated

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address <ip address>

!

ip dhcp pool Voice

   network <ip address> 255.255.255.192

   default-router <ip address>

   dns-server <ip address>

   option 150 <ip address>

!

ip dhcp pool W-Voice

   dns-server <ip address>

   option 150 ip <ip address>

!

ip dhcp pool New-Voice

   network <ip address> 255.255.255.128

   default-router <ip address>

   dns-server <ip address>

   option 150 ip <ip address>

!

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

voice-card 0

dsp services dspfarm

!

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

!

voice service pots

fax rate disable

!

voice service voip

allow-connection h323 to h323

allow-connections h323 to sip

allow-connection sip to h323

fax protocol cisco

h323

call preserve

h245 caps mode restricted

modem passthrough nse codec g711alaw redundancy maximum-sessions 100

sip

!

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

voice class h323 1

  h225 timeout tcp establish 3

  no call preserve

!

!

voice translation-rule 100

rule 1 /^019129311/ /611/

rule 2 /^29311/ /611/

!

voice translation-rule 200

rule 1 /^611/ /019129311/

rule 2 /^611/ /29311/

!

!

voice translation-profile PSTN-IN

translate called 100

!

voice translation-profile PSTN-OUT

translate calling 200

!

!

application

global

  service alternate default

!

!

!

!

username lynxpsgc privilege 15 password 7 04700A120C291E1C5B

username ntnhsadmin privilege 15 password 7 141442050F54792F0A6E07

username lastresort privilege 15 password 7 030B490A0808245F5E1F1C574742

!

archive

log config

hidekeys

!

!

controller E1 0/0/0

pri-group timeslots 1-31

!

!

!

!

!

!

interface GigabitEthernet0/0

description **voice interface**

ip address <ip address> <subnet mask>

ip pim dense-mode

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr <ip address of interface>

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 <ip address>

!

!

ip http server

!

!

!

snmp-server community pctpublic RO

snmp-server community pctragga RW

snmp-server contact IT Helpdesk 01912172777

snmp-server host <ip address> pctpublic

snmp-server host <ip address> pctpublic

snmp-server host <ip address> pctpublic

!

control-plane

!

!

!

voice-port 0/0/0:15

translation-profile incoming PSTN-IN

translation-profile outgoing PSTN-OUT

echo-cancel coverage 64

cptone GB

!

!

!

dial-peer voice 10 voip

tone ringback alert-no-PI

description *** Sending calls to Bevan House-Subscriber ***

preference 1

destination-pattern 611...

progress_ind setup enable 3

progress_ind alert enable 8

voice-class codec 1

voice-class h323 1

session target ipv4:<ip address>

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 20 voip

tone ringback alert-no-PI

description *** Sending calls to HQ-Subscriber ***

preference 2

destination-pattern 611...

progress_ind setup enable 3

progress_ind alert enable 8

voice-class codec 1

voice-class h323 1

session target ipv4:<ip address>

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 9 pots

preference 3

destination-pattern 9T

incoming called-number .

fax rate disable

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 999 pots

tone ringback alert-no-PI

description *** Dialling 999 ***

destination-pattern 999

progress_ind alert enable 8

port 0/0/0:15

forward-digits 3

!

dial-peer voice 9999 pots

tone ringback alert-no-PI

description *** Dialling 999 with trunk access code ***

destination-pattern 9999

progress_ind alert enable 8

port 0/0/0:15

forward-digits 4

!

gatekeeper

shutdown

!        

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

limit-dn 7940 1

limit-dn 7960 2

ip source-address <ip address> port 2000

max-ephones 40

max-dn 80

dialplan-pattern 1 93.... extension-length 5 extension-pattern 6....

default-destination 61140

no huntstop

translation-profile incoming IMCOMING

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 route <ip address>

time-format 24

date-format dd-mm-yy

!

!

scheduler allocate 20000 1000

end

1 Accepted Solution

Accepted Solutions

Terry Cheema
VIP Alumni
VIP Alumni

1) DHCP on this gateway should be fine. In case of WAN failure it would still be functional during SRST.
2) Your config looks ok, you just need to remove isdn-bind from your serial interface, as this is only required for MGCP, for Call manager to control the line:

interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager <<<<<<<<<<< Remove this
no cdp enable
!

Conf t
Int s0/0/0:15
Shut
No isdn bind-l3 ccm-manager
No shut

3) Add ccm-manager music-on-hold for MoH

Terry




Sent from Cisco Technical Support iPad App

View solution in original post

2 Replies 2

Terry Cheema
VIP Alumni
VIP Alumni

1) DHCP on this gateway should be fine. In case of WAN failure it would still be functional during SRST.
2) Your config looks ok, you just need to remove isdn-bind from your serial interface, as this is only required for MGCP, for Call manager to control the line:

interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager <<<<<<<<<<< Remove this
no cdp enable
!

Conf t
Int s0/0/0:15
Shut
No isdn bind-l3 ccm-manager
No shut

3) Add ccm-manager music-on-hold for MoH

Terry




Sent from Cisco Technical Support iPad App

Ayodeji Okanlawon
VIP Alumni
VIP Alumni

Hi,

A few things I see in your config

1. Your outbound pots dial-peer will create an inter digit time out issues for your callers. A pattern with 9T will not be dialled immediately and every call except for the emergency 999 will not be routed immediately.
I suggest you define dial peers specifically. I can help you with the dial-peers if you want, as I am also based in the UK.

2. You have CUBE configuration on the gateway. Is this gateway used as a cube gateway? If it is not I suggest you remove it.

3. You also have remnants of the old mgcp gw config for SRST; the application service alternate default command. You should remove it.

4. Finally you are using dial plan pattern for digit manipulation. You should consider replacing them with voice translation rules. If you are not familiar with how to configure them, you can read up and we can also help. They are much more granular and therefore better.



Sent from Cisco Technical Support Android App

Please rate all useful posts