cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
655
Views
5
Helpful
10
Replies

LLQ for VoIP

Vivien Martin
Level 1
Level 1

Hi,

I'm currently trying to apply some QoS with LLQ in order to stop VoIP chopping. I tried to prioritise the VoIP vlans, but when I stressed the network with packets wich match the class-default the VoIP is still chopping. So I was thinking to drop the entirely class-default during congestion (and only during congestion), but it seems it's impossible with this class, is there something I missed?

Here is my actual configuration:

//networks 192.168.10.0/24 and 192.168.20.0/24 are my voice vlans.

access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
access-list 100 permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
!
access-list 101 permit tcp any any eq 80
!
access-list 102 permit tcp any any eq 3389
!
access-list 103 permit tcp any any eq 445
!
class-map match-any voip
match access-group 100
match precedence 5
class-map web
match access-group 101
class-map rdp
match access-group 102
class-map smb
match access-group 103
!
policy-map llq
class voip
priority 500
set precedence 5
class web
bandwidth 1000
class rdp
bandwidth 800
class smb
bandwidth 500
class class-default
fair-queue
!
interface fastEthernet 4
bandwidth 3800
service-policy output llq

Tanks for your time!

10 Replies 10

chrihussey
VIP Alumni
VIP Alumni

Hello,

1- On what Cisco platform is this configuration applied and could you provide a complete config?

2- Why does the F4 interface have a "bandwidth 3800" statement?

3- Where are the VoIP networks (192.168.10 & 20) located in relation to this router?

4- Any idea of the maximum number of VoIP calls occurring simultaneously and what compression schema is being applied?

5- Is QoS being applied on the L2 switched infrastructure?

Please answer as best you can and we can take it form there.

Regards

Hi,

1) I'm trying to apply this configuration on router c871 :

Current configuration : 1977 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT_POC1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
no spanning-tree vlan 1
no spanning-tree vlan 2
!
!
archive
log config
hidekeys
!
!
!
class-map match-any voip
match access-group 100
match precedence 5
class-map match-all rdp
match access-group 102
class-map match-all web
match access-group 101
class-map match-all smb
match access-group 103
!
!
policy-map llq
class voip
priority 500
set precedence 5
class web
bandwidth 1000
class rdp
bandwidth 800
class smb
bandwidth 500
class class-default
fair-queue
!
!
!
!
interface FastEthernet0
switchport mode trunk
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
bandwidth 3800
ip address 10.1.1.1 255.255.255.0
speed auto
full-duplex
service-policy output llq
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip helper-address 10.1.1.3
!
interface Vlan2
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.20.254
!
router ospf 1
log-adjacency-changes
passive-interface Vlan1
passive-interface Vlan2
network 10.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.1.3
!
!
no ip http server
no ip http secure-server
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
access-list 100 permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 101 permit tcp any any eq www
access-list 102 permit tcp any any eq 3389
access-list 103 permit tcp any any eq 445
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
scheduler max-task-time 5000
end

2) Cause the link connected to the F4 interface is a 4Mbps and I red it's a bad idea to allowed the total the bandwidth 

3) Please take a look at the attachment, the routers I would like to apply QoS are RTPOC1 and RTPOC2.

4) It's a test architecture so there is only 2 IP phones, the codec is G.711.

5) QoS is not applied on the L2 infrastructure.

Thanks to look at my problem.

Regards.

On the surface there does not appear to be anything wrong with your config. It is entirely possible that it is not the router but more of the fact that you don't have QoS enabled on the switches. Without it the VoIP traffic is sharing the same queues and buffers as all the other traffic and would cause the issue you are having. If you are using Cisco switches "auto qos" would be a good option. Until you are correctly prioritizing traffic at the switch you may be wasting your time focusing on the router.

What type switches are you using and if Cisco I may be able to help you with that.

Also, although it's not causing your problem, I'm not sure why you have spanning tree disabled on the router and if you don't have a reason it may be a good idea to enable it. 

Regards

I understand that the switchs can issues my problem, but unfortunately I'm not allowed to apply qos on them. Beside that fact I have tested to drop all the trafic from the two vlan data, and with this configuration even with stressed network the VoIP is great and not chopping, so that 's why I'm asking if there is a possibility to drop the default class (or an other class) during congestion (only during congestion, because with the configuration below the class data is always droped, even if there is no congestion).

access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
access-list 100 permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255

!

access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 permit ip 192.168.200.0 0.0.0.255 any
!
class-map match-any voip
match access-group 100
match precedence 5
class-map data
match access-group 101

!

policy-map llq
class voip
priority 500
set precedence 5
bandwidth 500
class data
drop
class class-default
fair-queue
!
interface fastEthernet 4
bandwidth 3800
service-policy output llq

Concerning the no spanning-three option it's wanted.

Regards

What is the actual connection between the two routers? Is it from a provider that is rate-limiting you to 4Mbs? Are they honoring the packet markings, or are they indiscriminately dropping packets when traffic is exceeded? If this is the case, limiting the traffic you send to 4Mbps or less may provide better quality.

1- The bandwidth command in the policy-map does not police and allows traffic to exceed that rate if it is available. Policing the other traffic classes or in the class-default may provide some benefit. You can limit to a certain amount and drop anything that is in excess. This may give some better control.

2- You could possibly implement CAR (rate-limit) on the inbound VLAN interface to the router to limit the amount of traffic from the data VLANs to be more inline with would have to go out the F4 4Mbs interface.

3- Of course the question comes to mind is the provider network (if there is one) also providing some form of QoS and prioritizing the packets accordingly.

Not sure if this helps, hope it does.

This network is for test, so currently the two routers are connected through a simple switch which limit the bandwith to 4Mbps.

1- What command line should I use in order to police or limit the traffic?

2- I will try to implement CAR on the VLAN data. I keep you in touch.

Understand that this is a test environment, but is the switch that is limiting the traffic limiting ALL traffic of just the default traffic? Or is VoIP traffic excluded?

There are several ways to tweak this, but here is an example of how to limit the traffic in the policy-map:

!
policy-map LLQ
 class VOIP
  priority 500
 class class-default
   police cir 3000000
     conform-action transmit
     exceed-action drop
!

Sorry I didn't understand well. It's limiting all the traffic, VoIP isn't excluded.

Then that is why you are experiencing what you are getting. The VoIP traffic is prioritized leaving the router, but the switch will indiscriminately drop the traffic exceeding 4mbs. If it is meant to simulate the provider, then that may happen unless your intended provider will prioritize the VoIP traffic.

Trying to limit the data traffic as discussed may be best.

It seems that this configuration solve my problem!

!
policy-map LLQ
 class VOIP
  priority 500
 class class-default
   police cir 3000000
     conform-action transmit
     exceed-action drop
!

Thanks a lot!

Regards