cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1769
Views
0
Helpful
4
Replies

Lync with CUCM 8.5

huntlee
Level 1
Level 1
Dear all,

My customer wants to do direct SIP Trunk with their Lync server 2010.  And on the Lync side have setup CUCM 8.5 as a PSTN Gateway ut they have tried
everything and still couldn't get the call through.  Neither from Cisco desk phone to Lync clients, nor Lync clients to Cisco desk phone.

CUCM version - 8.5.1.11900-21
Lync version - Lync 2010

Any instructions on how i can troubleshoot this for my client?
Would appreciated your help. Cheers, Hunt
4 Replies 4

Joseph Martini
Cisco Employee
Cisco Employee

The first thing I would do is take a packet capture from CUCM when placing a call to/from Lync (

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080b36101.shtml).  The capture will show you if the SIP INVITE is being sent out, if it is then the next step would be to look at the application logs (CallManager traces on the CUCM side)

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080094e89.shtml.

Jeff Bankston
Level 1
Level 1

I recently did one of these to our 8.5.1 UC, and the problem was that the Lync server didn't have _ALL_ IP addresses of the Pub and all Subs listed as possible connection points. My SIP trunk to Lync was set to require mtp and RFC-2833, the trick was having Lync know about all UC servers.

-Jeff

Hi Joe & Jeff,

I got the Lync calls to work, so now it can call either from Cisco phone to Lync client, and Lync client to Cisco phone.

One thing though, the speed of the call setup is very poor, despite the CPU of both the Lync server and the CallManager are very low.  Both the CPU of Lync Server and the publisher are running around 10% CPU all the time.  But it can take between 7 to 10 seconds after I press the 'Dial' before the other side would start ringing.  The same goes when I 'hang up' the call on one side, it takes 7 to 10 seconds for the call to be disconnected on the other side.

From the Publisher, I ping the Lync Server under OSAdmin and it is always 1ms.  I also tried to ping both Publisher and the Lync Server from the tested Lync Client PC, it is always 1ms to both servers too.

Would appreciated your help.  Cheers,

Cheers,

Hunt

Hunt,

I'm still trying to get my Lync to CM trunk working.  What did you do to make yours work?  Did you have to put a translation pattern on the Lync trunk?  If so, do you have a resource on how to configure the pattern?

Thanks,

Mitch