cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

129
Views
0
Helpful
0
Replies
Highlighted
Beginner

Problems with calls when second DSP module is active

Hello Community,


Hardware: Cisco 2951
Modules: 2 x PVDM3-16 and 1 x VWIC2-2MFT-T1/E1

Following questions to the DSP topic:
1. Do you know how the voicegateway determs which DSP module will be used and if there is a "loadbalancing" between both DSP modules?
2. How does the voicegateway detect, whether both DSPs are full and is it automatically tell the other voicegateway (it is a cluster) or the call manager that the following calls have to go the the second voicegateway?
3. I recognized that calls, that are handled by the first DSP module are alright. But when the first module is "full" the next call is handled by the second DSP and these calls have voice problems (no voice or sough). This is also the reason for this article.
4. Is it needed to configure the size of the DSP in the voicegateway configuration (before it was only one DSP-64 in the voicegateway, which had also problems). I guess that maybe the maximum-sessions or DSP configuration could be wrong:

version 15.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname XXXXX
!
boot-start-marker
boot system flash:c2951-universalk9-mz.SPA.154-3.M5.bin
boot-end-marker
!
!
card type e1 0 0
logging buffered 1000000
logging persistent url flash:/log size 12562432 filesize 1000000
no logging console
!
no aaa new-model
clock timezone MEZ 1 0
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type primary-net5
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-XXXXX
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-XXXXX
revocation-check none
rsakeypair TP-self-signed-XXXXX
!
!
crypto pki certificate chain TP-self-signed-1723421328
certificate self-signed 01
XXXXX
quit
voice-card 0
!
!
voice rtp send-recv
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h225-notify cid-update
fax protocol pass-through g711alaw
modem passthrough nse codec g711alaw
h323
h225 timeout t302 5
h225 signal overlap
call start slow
!
!
!
!
!
!
voice translation-rule 1
XXXXX
!
voice translation-rule 2
XXXXX
!
voice translation-rule 3
XXXXX
!
voice translation-rule 4
XXXXX
!
voice translation-rule 5
XXXXX
!
voice translation-rule 6
XXXXX
!
!
voice translation-profile Test
translate calling 4
!
voice translation-profile pstn-in
translate called 6
!
voice translation-profile pstn-out
translate calling 4
!
voice translation-profile srst-inflate
translate called 5
!
voice translation-profile srst-inflate-out
translate calling 1
!
!
!
license udi pid CISCO2951/K9 sn XXXXX
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
archive
log config
hidekeys
!
redundancy
!
!
controller E1 0/0/0
clock source line primary
pri-group timeslots 1-31
!
controller E1 0/0/1
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address XXXXX 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr XXXXX
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 4000
isdn incoming-voice voice
no cdp enable
!
ip default-gateway XXXXX
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 XXXXX
!
!
logging trap debugging
logging host XXXXX
!
nls resp-timeout 1
cpd cr-id 1
!
snmp-server community LetMeSee RO
snmp-server community GetAccess RW
access-list 23 permit XXXXX
!
control-plane
!
!
voice-port 0/0/0:15
translation-profile incoming pstn-in
cptone DE
timeouts interdigit 4
bearer-cap 3100Hz
!
!
!
!
!
mgcp fax t38 ecm
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0.100
sccp ccm XXXXX identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register VG1_MTP
keepalive retries 1
keepalive timeout 10
switchover method immediate
switchback method immediate
!
!
no ccm-manager fax protocol cisco
!
dspfarm profile 1 mtp
codec g711ulaw
codec pass-through
maximum sessions software 50
associate application SCCP
!
dial-peer voice 110 voip
destination-pattern XXXXX[13456789].T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 200 pots
translation-profile outgoing pstn-out
destination-pattern 0.T
progress_ind alert enable 8
progress_ind progress enable 2
progress_ind connect enable 8
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 210 pots
translation-profile outgoing pstn-out
destination-pattern 0.T
progress_ind alert enable 8
progress_ind progress enable 2
progress_ind connect enable 8
incoming called-number .
direct-inward-dial
!
dial-peer voice 130 voip
preference 1
destination-pattern XXXXX[13456789].T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711alaw
no vad
!
dial-peer voice 879 pots
service ccm
shutdown
incoming called-number XXXXX
no digit-strip
!
dial-peer voice 876 voip
destination-pattern 879
session target ipv4:XXXXX
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 140 voip
preference 1
destination-pattern 0T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711alaw
no vad
!
dial-peer voice 150 voip
destination-pattern [13456789].T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 160 voip
preference 1
destination-pattern 0T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711alaw
no vad
!
dial-peer voice 170 voip
destination-pattern [13456789].T
session target ipv4:XXXXX
incoming called-number 0T
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
no dial-peer outbound status-check pots
sip-ua
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
max-conferences 64 gain -6
transfer-system full-consult
timeouts interdigit 5
ip source-address XXXXX port 2000
max-ephones 250
max-dn 250
system message primary "Emergency"
transfer-pattern .T
keepalive 10
default-destination XXXXX
translation-profile incoming srst-inflate
translation-profile outgoing srst-inflate-out
moh enable-g711 "SampleAudioSource.ulaw.wav"
multicast moh XXXXX port 16384 route XXXXX
time-zone 23
time-format 24
date-format dd-mm-yy
!
!
no vstack
banner motd ^CC


XXXX


^C
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
login local
length 0
transport input ssh
line vty 5 15
privilege level 15
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

 

 

 

Thank you very much




CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards