03-12-2015 06:45 AM - edited 03-17-2019 02:18 AM
Hi All,
I am working with a client to implement QoS for their Lync environment. Lync 2013 has this feature to mark dscp values based on packets tagged with logical ports. As an example, packets on port 20000 til 20039 will be marked to dscp 46(ef) and packets on port 20040- 20079 will be marked to dscp 34(af41)
I am connecting our office PC to cisco 2960s(access) switches and 4506e(access) chassis switches then to 4510 core switch from there to 2811 router
Please share a configuration example to achieve QOS in access switches and core switches.
Please not all the access port with default configuration and connected to polycom IP Phones then to PC(we are not created any QoS policy for this IP Phones, so new QoS configuration should not affect the IP Phone’s working).
Thanks
Sujish
03-12-2015 10:52 AM
Hello Sujish,
Are you trying to configure QoS for both LAN and WAN or just the LAN switches?
For the switches if the Lync is already marking the packets as DSCP as you say, you only need to trust that marking on the ports. For example:
interface GigabitEthernet1/0/2 description **** Access Port **** switchport access vlan 10 switchport mode access mls qos trust dscp
The same goes for trunk and layer 3 ports.
If you need QoS for the WAN on the router you'll need to configure the class-map to match the DSCP markings and the policy map to prioritize that traffic as you wish.
03-12-2015 07:59 PM
Hi Eric,
as of now we are only concentrating on LAN Switches ,
please verify this...
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos
ip access-list extended lync-voip-qos
remark acl to mark and prioritize lync voip-app traffic to other devices with dscp ef
permit udp any any range 20000 20039
permit tcp any any range 20000 20039
ip access-list extended lync-video-qos
remark acl to mark and prioritize lync video-app traffic to other devices with dscp AF41
permit udp any any range 20040 20079
permit tcp any any range 20040 20079
class-map match-all lync-voip-qos
match access-group name lync-voip-qos
class-map match-all lync-video-qos
match access-group name lync-video-qos
!
!
policy-map lync-qos
class lync-voip-qos
set dscp ef
class lync-video-qos
set dscp af41
interface GigabitEthernet1/0/2
description **** Access Port ****
switchport access vlan 10
switchport mode access
switchport voice vlan 160
mls qos trust dscp
service-policy input lync-qos
1, what would be the trunk port configuration?
2, how the packets from polycom IP Phones treated (as of now no qos enabled for this), so mls qos trust dscp will make any difference
3, what are the srr-queue command i have to use in this interface?
4, srr-queue bandwidth share 1 30 35 5
priority-queue out
what is this commands do? do have to include this in to my interface configuration
thanks
Sujish
03-12-2015 09:00 PM
1) The trunk port config will be: mls qos trust dscp
2) If the Polycom IP phones send the traffic marked, it will be trusted according to the port config.
3) SRR controls the rate at which packets are sent
4) Normally LAN is not congested part, so you can do without these commands, but if you need to prioritise your Lync traffic then you will need these commands to enable the priority queue.
At this stage what you are doing is just classifying and marking the priority traffic - you are not prioritizing it any way. Alternative and easy way here is use auto qos trust on your access ports and mls qos trust dscp on trunks. This will then automatically create priority queues etc., thats how most people deal with catalyst QoS.
Refer to here for further understanding/examples:
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/91862-cat3750-qos-config.html#concept12
http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSCampus_40.html#pgfId-998207
-Terry
03-12-2015 09:42 PM
Thanks Terry,
you said as per my configuration we are just classifying and marking the traffic, so kindly send the commands i have to apply to prioritizing this traffic in both access port and trunk port.
we do not want to apply auto QoS.
thanks
Sujish
03-13-2015 12:59 AM
Enable priority queues and set the srr shaping and sharing bandwidth on your access ports:
Switch(config)# interface gigabitethernet2/0/1
Switch(config-if)# srr-queue bandwidth shape 25 0 0 0
Switch(config-if)# srr-queue bandwidth share 30 20 25 25
Switch(config-if)# priority-queue out
Switch(config-if)# end
Additionally, you can also configure policing, if you want to, so that voice traffic doesn't starve other traffic:
So go under your Lync policy, go to class lync, after you set dscp ef
then configure policing (change bandwidth according to your needs if you need to)
Switch(config-pmap-c)# police 320000 8000 exceed-action policed-dscp-transmit
then in global mode:
mls qos map policed-dscp 24 26 46 to 0
you can additionally change default input output srr thresholds in global mode, I don't have a console in front of me right now, just look in the doc I referenced. Leave trunks links with the trust only.
I would again say use auto qos to generate the commands. In circumstances where I need to modify the catalyst qos, I generate the auto qos and then modify the commands according to needs.
The commands I provided you above should enable a egress priority queue, police it at the configured bandwidth.
-Terry
03-13-2015 01:44 AM
Switch(config-if)# srr-queue bandwidth shape 25 0 0 0
Switch(config-if)# srr-queue bandwidth share 30 20 25 25
can u explain these commands...
in this command mls qos map cos-dscp 0 8 16 24 32 46 48 56 , what about dscp34??
thanks
Sujish
03-13-2015 03:13 AM
3750 has 4 egress queues. These two commands are mixing both SRR shaping and sharing on the queues:
srr-queue bandwidth shape 25 0 0 0 (shaping enabled on q1)
srr-queue bandwidth share 25 25 25 25 << change this to default to make it less confusing, this is sharing remaining bandwidth
This will shape the Q1 which is priorty queue to 4 Mbps bw if this is Fastethernet (100Mbps) port. All other queues are not policed and will divide and share the remaining bandwidth with each other.
If you read the catalyst qos docs I provided you will have better understanding.
For the cos-dscp maps you will not be using those, since you are trusting dscp and passing it as it is without the need for cos to dscp conversion, which would have come to play if you were trusting cos and converting to dscp, but still you can go ahead and modify the map and change the value from 32 to 34 as well.
-Terry
03-13-2015 03:52 AM
now, how to enable this on Cisco 4506E SUP 7L-E(access switch) and 4510E SUP7 switches.
mls qos trust dscp
srr-queue bandwidth shape 25 0 0 0
srr-queue bandwidth share 30 20 25 25
priority-queue out
these commands are not working.....
also how about trunk configuration in this switch
thanks
Sujish
03-13-2015 04:15 AM
I am trying to provide you with best of my knowledge within just 10-15 mins, do tally this with doc: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/18ew/configuration/guide/config/qos.html#wp1273408
enable qos:
conf t
qos
sh qos - to verify
On acces-ports
qos trust dscp
tx-queue 3
priority high
shape 30
On Trunks:
qos trust dscp
sh qos int x to verify
MAP COS TO DSCP
Switch(config)#qos map cos 0 to dscp 0
Switch(config)#qos map cos 1 to dscp 8
Switch(config)#qos map cos 2 to dscp 16
Switch(config)#qos map cos 3 to dscp 24
Switch(config)#qos map cos 4 to dscp 34
Switch(config)#qos map cos 5 to dscp 46
Switch(config)#qos map cos 6 to dscp 48
Switch(config)#qos map cos 7 to dscp 56
ENABLE DYNAMIC BUFFER LIMIT
Switch(config)#qos dbl
Switch(config)#qos dbl exceed-action ecn
MAP DSCP TO QUEUES
Switch(config)#qos map dscp 0 to tx-queue 2
Switch(config)#qos map dscp 8 10 12 14 to tx-queue 1
Switch(config)#qos map dscp 16 18 20 22 to tx-queue 4
Switch(config)#qos map dscp 24 25 26 to tx-queue 4
Switch(config)#qos map dscp 32 34 36 38 to tx-queue 4
Switch(config)#qos map dscp 46 to tx-queue 3
Switch(config)#qos map dscp 48 56 to tx-queue 4
-Terry
03-13-2015 04:37 AM
qos trust dscp
this command is not there in 4506
qos trust extend/ device---- which one i should apply
03-13-2015 05:50 AM
Can you post a sh version from your 4506?
-Terry
03-13-2015 06:58 AM
Cisco IOS Software, IOS-XE Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSAL-M), Version 03.03.02.SG RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Wed 24-Oct-12 00:32 by prod_rel_team
ROM: 15.0(1r)SG10
S11 uptime is 18 weeks, 4 days, 4 hours, 10 minutes
System returned to ROM by power-on
System restarted at 18:25:15 IST Sat Nov 1 2014
Running default software
Jawa Revision 7, Winter Revision 0x0.0x40
License Information for 'WS-X45-SUP7L-E'
License Level: lanbase Type: Permanent
Next reboot license Level: lanbase
cisco WS-C4506-E (MPC8572) processor (revision 6) with 2097152K/20480K bytes of memory.
Processor board ID SPE174400AW
MPC8572 CPU at 1.5GHz, Supervisor 7L-E
Last reset from PowerUp
1 Virtual Ethernet interface
244 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.
Configuration register is 0x2101
03-13-2015 05:58 PM
You have SUP7L-E, ignore the above on this model, you will need to configure MQC style qos config on this or router type QoS config in other words.
Refer to this guide, configure classes (match dscp in your case), and set a priority queue for voice traffic, refer to below document:
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/3-1-1SG/configuration/guide/config/qos.html#wp1437305
Its Cisco way of confusing you :-), different model, different config. (I hate to say this though as I love almost all of the Cisco stuff)
-Terry
03-13-2015 11:07 PM
Can u help me to find out equivalent commands of this in 4506 sup7L E switch
int gi 1/0/1(Access Port)
mls qos trust dscp
srr-queue bandwidth shape 25 0 0 0
srr-queue bandwidth share 30 20 25 25
priority-queue out
int gi 1/0/48(Trunk Port)
mls qos trust dscp
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide