cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2082
Views
10
Helpful
4
Replies
Deval Tetar
Beginner

SIP Gateway with PRI Failover

Hi,

I am facing issue with PRI failover,

This is first time I am configuring combination of PRI and SIP Gateway for CUCM

 

I have two VG for redundancy purpose

Both are connected to CUCM with respective SIP Trunk

Inbound and Outbound Calling working fine from each VG (Caller ID Display, DTMF everything is working very fine)

 

However problem is faced when VG1 is up and running; and ALL 4 PRIs goes down ( I was performing PRI failover testing)…

Still CUCM sends call to VG1 which gives 404 Not found message and plays annunciator message “ your call can not be completed please contact system administrator”

As I am using “Distribution Algorithm = Circular” in route group every alternate call which id sent to VG1 gets fail.

 

One of the possible way I look as a solution for this is creating few more voip dial-peer with higher preference and forward call to VG2 in cas all PRIs are down and viceverse in case of VG2 

 

Is there is a way to monitor PRI from CUCM when using it as SIP gateway

Or is there is way I can control PRI using SIP, so I get 503 service not available and then call will be routed to VG2… 

Or I am running into some kind of limitation; if YES, can some one please provide some Cisco document for reference.

Or there is any other possible solution which I can use...

 

Call flow with configuration:

7821 (SIP IP Phone) --- CUCM (10.5.1) --- \+.!  (Route Pattern) --- PSTN-RL (Route List) --- PSTN-RG (Route Group), Distribution Algorithm = Circular ---

SIP Trunk to VG 1 (With 4 PRIs) (c2900-universalk9-mz.SPA.154-3.M1.bin)

SIP Trunk to VG 2 (With 2 PRIs) (c2900-universalk9-mz.SPA.154-3.M1.bin)

 

Please find VG1 Configuration below:  (VG2 config is same with only 2 PRIs instead of 4 PRIs)


card type e1 0 0
card type e1 0 1


network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
network-clock-select 3 E1 0/1/0
network-clock-select 4 E1 0/1/1


isdn switch-type primary-net5


voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface BVI136
  bind media source-interface BVI136
  registrar server expires max 3600 min 120


controller E1 0/0/0
 pri-group timeslots 1-31
 description "XXX PRI - Pilot number YYYY,range ABC to XYZ"
!
controller E1 0/0/1
 pri-group timeslots 1-31
 description "XXX PRI - Pilot number YYYY,range ABC to XYZ"
!
controller E1 0/1/0
 pri-group timeslots 1-31
 description "XXX PRI - Pilot number YYYY,range ABC to XYZ"
!
controller E1 0/1/1
 pri-group timeslots 1-31
 description "XXX PRI - Pilot number YYYY,range ABC to XYZ"


bridge irb


interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 136
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 bridge-group 136


interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing display-ie
 isdn outgoing ie redirecting-number
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing display-ie
 isdn outgoing ie redirecting-number
 no cdp enable
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing display-ie
 isdn outgoing ie redirecting-number
 no cdp enable
!
interface Serial0/1/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing display-ie
 isdn outgoing ie redirecting-number
 no cdp enable


interface BVI136
 ip address X.X.X.X Y.Y.Y.Y


bridge 136 priority 65535
bridge 136 protocol ieee
bridge 136 route ip


voice-port 0/0/0:15
!
voice-port 0/1/0:15
!
voice-port 0/0/1:15
!
voice-port 0/1/1:15


dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 3 pots
 description LCAL MOBILE
 destination-pattern [7-9].........
 port 0/0/0:15
!
dial-peer voice 147 voip
 description CUCM PUB
 destination-pattern 2...
 session protocol sipv2
 session target ipv4:W.W.W.147
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 148 voip
 description CUCM SUB
 destination-pattern 2...
 session protocol sipv2
 session target ipv4:W.W.W.148
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 2 pots
 description LOCAL LANDLINE
 destination-pattern [2-6].......
 port 0/0/0:15
!
dial-peer voice 4 pots
 description NATIONAL
 destination-pattern 0[1-9].........
 port 0/0/0:15
 prefix 0
!
dial-peer voice 5 pots
 description INTL
 destination-pattern 00T
 port 0/0/0:15
 prefix 00
!
dial-peer voice 6 pots
 description TOLLFREE
 destination-pattern 1800T
 port 0/0/0:15
 prefix 1800
!
dial-peer voice 7 pots
 description TOLLFREE
 destination-pattern 1860T
 port 0/0/0:15
 prefix 1860


dial-peer voice 22 pots
 description LOCAL LANDLINE
 preference 1
 destination-pattern [2-6].......
 port 0/0/1:15
!
dial-peer voice 44 pots
 description NATIONAL
 preference 1
 destination-pattern 0[1-9].........
 port 0/0/1:15
 prefix 0
!
dial-peer voice 33 pots
 description LCAL MOBILE
 preference 1
 destination-pattern [7-9].........
 port 0/0/1:15
!
dial-peer voice 55 pots
 description INTL
 preference 1
 destination-pattern 00T
 port 0/0/1:15
 prefix 00
!
dial-peer voice 66 pots
 description TOLLFREE
 preference 1
 destination-pattern 1800T
 port 0/0/1:15
 prefix 1800
!
dial-peer voice 77 pots
 description TOLLFREE
 preference 1
 destination-pattern 1860T
 port 0/0/1:15
 prefix 1860


dial-peer voice 222 pots
 description LOCAL LANDLINE
 preference 2
 destination-pattern [2-6].......
 port 0/1/0:15
!
dial-peer voice 444 pots
 description NATIONAL
 preference 2
 destination-pattern 0[1-9].........
 port 0/1/0:15
 prefix 0
!
dial-peer voice 333 pots
 description LCAL MOBILE
 preference 2
 destination-pattern [7-9].........
 port 0/1/0:15
!
dial-peer voice 555 pots
 description INTL
 preference 2
 destination-pattern 00T
 port 0/1/0:15
 prefix 00
!
dial-peer voice 666 pots
 description TOLLFREE
 preference 2
 destination-pattern 1800T
 port 0/1/0:15
 prefix 1800
!
dial-peer voice 777 pots
 description TOLLFREE
 preference 2
 destination-pattern 1860T
 port 0/1/0:15
 prefix 1860


dial-peer voice 2222 pots
 description LOCAL LANDLINE
 preference 3
 destination-pattern [2-6].......
 port 0/1/1:15
!
dial-peer voice 4444 pots
 description NATIONAL
 preference 3
 destination-pattern 0[1-9].........
 port 0/1/1:15
 prefix 0
!
dial-peer voice 3333 pots
 description LCAL MOBILE
 preference 3
 destination-pattern [7-9].........
 port 0/1/1:15
!
dial-peer voice 5555 pots
 description INTL
 preference 3
 destination-pattern 00T
 port 0/1/1:15
 prefix 00
!
dial-peer voice 6666 pots
 description TOLLFREE
 preference 3
 destination-pattern 1800T
 port 0/1/1:15
 prefix 1800
!
dial-peer voice 7777 pots
 description TOLLFREE
 preference 3
 destination-pattern 1860T
 port 0/1/1:15
 prefix 1860


sip-ua
!
!
!
gatekeeper
 shutdown
!
!
!
!
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login local
 transport input all

 

 

Thanks Regards,

Deval Tetar

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Aditya Gupta
Cisco Employee

Hi Deval

 

Is it possible for you to change the design, so that both the sip trunks are under different Route Groups, which are then called under the same Route List ?

Also ensure that following 3 Service Parameter on CUCM are set to false:

Stop Routing on Out of Bandwidth Flag  Required Field
Stop Routing on Unallocated Number Flag  Required Field
Stop Routing on User Busy Flag  Required Field
 
If you cannot change the design , please paste the output of "debug ccsip message" from the voice gateway 1 when fail over is initiated. 
 
Regards
Aditya Gupta
 

 

View solution in original post

4 REPLIES 4
Aditya Gupta
Cisco Employee

Hi Deval

 

Is it possible for you to change the design, so that both the sip trunks are under different Route Groups, which are then called under the same Route List ?

Also ensure that following 3 Service Parameter on CUCM are set to false:

Stop Routing on Out of Bandwidth Flag  Required Field
Stop Routing on Unallocated Number Flag  Required Field
Stop Routing on User Busy Flag  Required Field
 
If you cannot change the design , please paste the output of "debug ccsip message" from the voice gateway 1 when fail over is initiated. 
 
Regards
Aditya Gupta
 

 

View solution in original post

Hi Aditya,

 

Thanks for reply.

 

I was looking of this Flags only, it has worked for me in past when I was working with H323.

I will change the design do testing and share details...

It will take some time to visit client place.

 

 

Thanks and Regards,

Deval Tetar

it is working now after changing route group configuration and service parameters

Great !!!!

 

Content for Community-Ad

Spotlight Awards 2021