07-12-2012 09:58 AM - edited 03-16-2019 12:10 PM
Hi fellow community members,
I have a very specific problem that I'd appreciate some help with if anyone else has experienced this or anything similar.
We have a VG224 that provides analogue lines to mainly fax machines on our campus. Recently we have had our finance department want to use chip and pin machines over these connections. Previoulsy we have used streamline machines, and these connect fine.
The specific case I have is a Verifone vx810 machine that is connected to a VG224. The Verifone unitis able to dial out and successfully authorise a transaction, but it cannot complete a batch upload process or a TMS. I've spoken to the support company who we lease the machines from and they have identified that the machine uses the following baud rate, parity and stop bits for the 2 different transactions:
For the transactions: 2400 baud, parity/stop 7e1 (this works)
For the batch upload/TMS : 19200 baud, parity/top 8n1 (this doesn't work).
In the case of the batch upload/TMS, the machine dials out, obtains a connection to the remote end over the PSTN for about 10-20 seconds, then tears it down because the modem negotiation fails. I've read various articles on here and other forums saying that high speed data rates may be an issue for the VG224, but nothing that suggests a problem with 19200. I also tried the setup on an ATA186 and the ATA showed the same symptoms, so I'm inclined to think this isn't just a firmware or bug issue with the VG224. I've tried 3 different chip and pin machines of the vx810 model and all of them show the same symptoms.
Here is a copy of my current VG224 config. The VG224 is registered to the CUCM via SCCP.
version 12.4
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname vg224
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
aaa new-model
!
!
aaa authentication login default group radius local
aaa authentication enable default enable
aaa authorization exec default group radius local
aaa accounting exec default
action-type start-stop
group radius
!
!
!
aaa session-id common
clock timezone GMT 0
clock summer-time BST recurring 4 Sun Mar 1:00 4 Sun Oct 2:00
ip source-route
ip cef
no ip domain lookup
!
!
no ipv6 cef
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
stcapp feature speed-dial
!
!
voice service voip
modem passthrough nse codec g711ulaw
!
!
voice-card 0
!
username <username> password <password>
archive
log config
hidekeys
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.644
encapsulation dot1Q 644
ip address 10.1.160.4 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.1.160.1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.160.1
no ip http server
!
logging facility local6
logging source-interface FastEthernet0/0.644
logging <server ip>
snmp-server community <community> RO
snmp-server location <location>
!
radius-server host <server> auth-port 1812 acct-port 1813
radius-server host <server> auth-port 1812 acct-port 1813
radius-server timeout 3
radius-server key <key>
!
control-plane
!
!
!
voice-port 2/0
cptone GB
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
voice-port 2/1
cptone GB
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
voice-port 2/2
cptone GB
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
voice-port 2/3
cptone GB
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
voice-port 2/4
no echo-cancel enable
cptone GB
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
!
ccm-manager fax protocol cisco
ccm-manager config server <publisher>
ccm-manager config
ccm-manager sccp local FastEthernet0/0.644
ccm-manager sccp
!
!
sccp local FastEthernet0/0.644
sccp ccm <pub>identifier 1 version 6.0
sccp ccm <sub1> identifier 2 version 6.0
sccp ccm <sub2> identifier 3 version 6.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate ccm 3 priority 3
!
dspfarm profile 1 transcode
associate application SCCP
!
!
dial-peer voice 999200 pots
service stcapp
port 2/0
!
dial-peer voice 999201 pots
service stcapp
port 2/1
!
dial-peer voice 999202 pots
service stcapp
port 2/2
!
dial-peer voice 999203 pots
service stcapp
port 2/3
!
dial-peer voice 999204 pots
service stcapp
port 2/4
!
!
!
line con 0
line aux 0
line vty 0 4
!
ntp server <ntp1>
ntp server <ntp2>
end
And a show version from the vg224:
System returned to ROM by power-on
System restarted at 14:30:34 BST Wed May 9 2012
System image file is "slot0:vg224-i6s-mz.124-22.T5.bin"
Cisco VG224 (R527x) processor (revision 4.1) with 119808K/11264K bytes of memory.
Processor board ID FHK1432F2CC
R527x CPU at 225MHz, Implementation 40, Rev 3.1
1 On-Board Twenty-Four FXS Analog Voice Module V2.1
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
63K bytes of non-volatile configuration memory.
System fpga version is 250027
System readonly fpga version is 250027
Option for system fpga is 'system'.
62496K bytes of ATA Slot0 CompactFlash (Read/Write)
Configuration register is 0x2102
This problem is really driving me mad, if anyone can shed any light on what the root cause may be I'd be very grateful.
I should probably add that yes, PCIDSS compliant devices running over the IP network would be the way forward, and that is something we are working towards, but currently we have units that can only communicate using analogue telephone lines.
Solved! Go to Solution.
07-12-2012 10:22 AM
Correct, PRI is clean so you have to setup modem relay for the high speed modem connection to work.
I wouldn't waste time with SCCP and move right away to SIP or H.323.
07-12-2012 10:01 AM
Can you check "show controllers E1" on your PRI gateway.
If no slips, you will have to configure a direct H.323 or SIp trunk between VG224 and PRI gateway, and modem relay as well. That is because SCCP controlled ports are not good for fax or modems.
07-12-2012 10:08 AM
pri_gw#sh controllers e1
E1 0/0/0 is up.
Applique type is Channelized E1 - balanced
Cablelength is Unknown
Description: PSTN
No alarms detected.
alarm-trigger is not set
Version info Firmware: 20090408, FPGA: 13, spm_count = 0
Framing is CRC4, Line Code is HDB3, Clock Source is Line.
Data in current interval (730 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Thanks Paolo, I was considering setting up modem relay but it always seems to look more complicated that it needs to be. That will be my next thing to try.
Have you had bad experience with modems working over SCCP connections then? No slips on the E1 interface so looks like the SIP trunk is the next thing to do.
07-12-2012 10:22 AM
Correct, PRI is clean so you have to setup modem relay for the high speed modem connection to work.
I wouldn't waste time with SCCP and move right away to SIP or H.323.
07-13-2012 08:37 AM
Thanks Paolo.
I've managed to get modem passthrough to work. Modem passthrough is not actually supported with SCCP at all. I had to set modem passthrough globally at the voice service voip level on the VG224, and also on a new voip dial peer which points to my PRI gateway. On the PRI gateway I also had to configure modem passthrough at the voice service voip level globally.
on the VG224:
voice service voip
modem passthrough nse codec g711alaw redundancy
dial-peer voice 1 voip
preference 1
destination-pattern 8T
modem passthrough nse codec g711alaw redundancy
session target ipv4:10.1.1.1
codec g711ulaw
and on the PRI gateway:
voice service voip
modem passthrough nse codec g711alaw redundancy
Obviously this doesn't have any class of restriction on the lines, but it is sufficient for us to perform a workaround in the short-term.
Thanks for the initial pointer RE SCCP :-)
Matt
07-13-2012 09:46 AM
Thank you for the nice rating and good luck!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide