cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
548
Views
0
Helpful
13
Replies

Voice vlan issue

donald.barnes
Beginner
Beginner

Hello all,

I recently took over a cisco network that is using an old NBX v3000 phone system with 3 com voip phones.  They just purchased another NBX for our other site (we have a direct connection between the sites).  The last network admin was able to get the first NBX phone system set working using the voice vlan connection. 

The current system uses vlan 15 for voice and a port set up like this works fine:

switchport access vlan 13

switchport mode access

switchport nonegotiate

switchport voice vlan 15

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree portfast

I have a phone hooked to the port, it boots, hits the nbx on vlan 15 and downloards an image and gets an extension. 

For the new system I set up Vlan 116 to be its voice vlan.

If I change the config:

switchport access vlan 13

switchport mode access

switchport nonegotiate

switchport voice vlan 116

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree portfast

The phone boots but just sets there waiting "waiting for NCP"

Anywhere on either site, if I use voice vlan 15 the phone will connect, but if I use 116 it will not. 

Both vlans 15, and 116 are set up the same way one the same switch.  they both have an ip address, 10.15.1.1 255.255.0.0 and 10.116.1.1 255.255.0.0.  Both vlans are trunked, and I can ping their address from other switches across both sites.  Neither vlan has an access list applied to it. 

Both NBX's are configured with IPs (10.15.1.190 and 10.116.1.190), and vlan tagging. 

One thing I have noticed, if I issue the "show mac address-table interface" command to a port using the voice vlan 15 the phones mac is on vlan 15.  If I issue the same command with the voice vlan set to 116 the phones mac will be on the access vlan.  If I remove the access vlan and only include the voice vlan 116 the mac will show up on Vlan 1...  

I feel like the issue is with my vlan 116, though after looking through config after config I cant see a difference between my set up and the last network admin's set up.

Does anyone have any ideas of  any other config options that I may need to get this working? 

Thanks at ton!

13 Replies 13

yahsiel2004
Rising star
Rising star

What about you dhcp pool? Can you post the full switch and router config?

Regards,

Yosh

HTH Regards, Yosh

Hi Donald Barnes

kindly post the below command output from switch on that port where vlan 116 is assigned

show interfaces switchport

show running-config interface

GigabitEthernet1/0/22 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 000e.3885.da96 (bia 000e.3885.da96)

  Description: Port E4 - D117

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 3d22h, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 4000 bits/sec, 5 packets/sec

     1282916 packets input, 170417156 bytes, 0 no buffer

     Received 24165 broadcasts (13551 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 13551 multicast, 0 pause input

     0 input packets with dribble condition detected

     2713213 packets output, 2844013678 bytes, 0 underruns

     0 output errors, 0 collisions, 17 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

interface GigabitEthernet1/0/22

description Port E4 - D117

switchport mode access

switchport voice vlan 116

spanning-tree portfast

end

There are the show commands, as I said, if I change the 116 to 15 the phone connects to the vlan 15 nbx right away.

we are not using DHCP for the phones, they connect back to the NBX with their mac address. 

post these command output bro

show interfaces switchport

show running-config interface

These are she show commands using vlan 15

Dcore#sh int gi1/0/22

GigabitEthernet1/0/22 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 000e.3885.da96 (bia 000e.3885.da96)

  Description: Port E4 - D117

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 3d22h, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 7000 bits/sec, 6 packets/sec

     1283527 packets input, 170803954 bytes, 0 no buffer

     Received 24383 broadcasts (13551 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 13551 multicast, 0 pause input

     0 input packets with dribble condition detected

interface GigabitEthernet1/0/22

description Port E4 - D117

switchport mode access

switchport voice vlan 15

spanning-tree portfast

end

run this command

Dcore#sh int gi1/0/22 switchport

and

Dcore#sh running-config int gi1/0/22

Sorry, I missed the switchport on the end of sh interface

Dcore#sh int gi1/0/22 switchport

Name: Gi1/0/22

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: native

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: 116 (VLAN0116)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Dcore#sh running-config

Dcore#sh running-config int gi1/0/22

Building configuration...

Current configuration : 142 bytes

!

interface GigabitEthernet1/0/22

description Port E4 - D117

switchport mode access

switchport voice vlan 116

spanning-tree portfast

end

everything is in order.

just one more command

Dcore#sh spanning-tree int gi1/0/22

sh spanning-tree int gi1/0/22

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0001            Desg FWD 19        128.22   P2p Edge

VLAN0116            Desg FWD 19        128.22   P2p Edge

Dcore#

got the issue run below command on that switch port and it will work.

Dcore#config t

Dcore(config)#int gi1/0/22

Dcore(config-if)#switchport mode access

Dcore(config-if)#switchport access vlan 13

Dcore(config-if)#switchport trunk native vlan 13

Dcore(config-if)#switchport trunk allowed vlan 13,116

Do this & check now

Dcore#sh int gi1/0/22 switchport

Name: Gi1/0/22

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: native

Negotiation of Trunking: Off

Access Mode VLAN: 13 (VLAN0013)

Trunking Native Mode VLAN: 13 (VLAN0013)

Administrative Native VLAN tagging: enabled

Voice VLAN: 116 (VLAN0116)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: 13,116

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Dcore#sh spanning-tree int gi1/0/22

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0013            Desg FWD 19        128.22   P2p Edge

VLAN0116            Desg FWD 19        128.22   P2p Edge

interface GigabitEthernet1/0/22

description Port E4 - D117

switchport access vlan 13

switchport trunk native vlan 13

switchport trunk allowed vlan 13,116

switchport mode access

switchport voice vlan 116

spanning-tree portfast

end

This is the current config using the commands you suggested.  Still no connection.  There has to be something with Vlan 116 that is keeping the tagged vlan data from making it to the nbx. 

I can ping from the swith to the NBX

Dcore#ping 10.116.1.190

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.116.1.190, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Dcore#

can you post full topology snapshot along with full config of devices?

Hi Donald.
On the interface G1/0/22
put this command
switchport mode trunk
switchport trunk allowed vlan 116

Hope this helps

Regards
Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers