cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco C1111 -IPv6 NHRP command doesnt exist

bozo.bogd
Beginner
Beginner

Hey guys,

 

I am currently trying to setup IPv6 DMVPN alongside IPV4 DMVPN, in order to pass both address families.

 

However there is no IPv6 NHRP command under tunnel interface.

 

 

I am able to create BGP peering in both address families just using IPV4, however data center side is complain for received IPV6 route that is inaccessible due to next hop being ipv4

 

dmvpn01#show ip bgp vpnv6 unicast vrf GLENN 2AB3:3900:F0::/64
BGP routing table entry for [7777:10001]2AB3:3900:F0::/64, version 0
BGP Bestpath: deterministic-med
Paths: (1 available, no best path)
Not advertised to any peer
Refresh Epoch 1
65001
::FFFF:10.179.177.67 (inaccessible) (via vrf GLENN) from 10.179.177.67 (10.179.28.208)
Origin IGP, metric 50, localpref 100, valid, external
Community: 65000:100
Extended Community: RT:7777:10001
rx pathid: 0, tx pathid: 0

 

 

 

 

Image : c1100-universalk9.17.03.03.SPA.bin

 

I am trying to search why this  command / options would be excluded but I cant find a reason for now.

 

Any help is appreciated.

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Dear Harold,

 

interface Tunnel100060
description DMVPN TUNNEL TO DATACENTER
bandwidth 100000
ip address 10.179.169.110 255.255.255.240
no ip redirects
ip mtu 1400
ip nat outside
ip nhrp authentication ohj8aPh4
ip nhrp map multicast 1.1.1.1
ip nhrp map multicast 8.8.8.8
ip nhrp map 10.179.169.97 1.1.1.1
ip nhrp map 10.179.169.98 8.8.8.8
ip nhrp network-id 100060
ip nhrp holdtime 900
ip nhrp nhs 10.179.169.97
ip nhrp nhs 10.179.169.98
ip tcp adjust-mss 1360
qos pre-classify
tunnel source Dialer9
tunnel mode gre multipoint
tunnel key 100060
tunnel path-mtu-discovery
tunnel vrf INTERNET
end

 

Command under tunnel ipv6 doesn't offer nhrp, even if new tunnel would be created without ip nhrp.

 

Nevertheless system image c1100-universalk9.17.03.04a.SPA.bin resolved this for me.

 

Now I can do both nhrp's

 

Regards

View solution in original post

2 REPLIES 2

Harold Ritter
Cisco Employee
Cisco Employee

Hi @bozo.bogd ,

 

This command should definitely be available. Can you provide the tunnel interface configuration?

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Dear Harold,

 

interface Tunnel100060
description DMVPN TUNNEL TO DATACENTER
bandwidth 100000
ip address 10.179.169.110 255.255.255.240
no ip redirects
ip mtu 1400
ip nat outside
ip nhrp authentication ohj8aPh4
ip nhrp map multicast 1.1.1.1
ip nhrp map multicast 8.8.8.8
ip nhrp map 10.179.169.97 1.1.1.1
ip nhrp map 10.179.169.98 8.8.8.8
ip nhrp network-id 100060
ip nhrp holdtime 900
ip nhrp nhs 10.179.169.97
ip nhrp nhs 10.179.169.98
ip tcp adjust-mss 1360
qos pre-classify
tunnel source Dialer9
tunnel mode gre multipoint
tunnel key 100060
tunnel path-mtu-discovery
tunnel vrf INTERNET
end

 

Command under tunnel ipv6 doesn't offer nhrp, even if new tunnel would be created without ip nhrp.

 

Nevertheless system image c1100-universalk9.17.03.04a.SPA.bin resolved this for me.

 

Now I can do both nhrp's

 

Regards

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: