04-15-2011 09:23 PM - edited 03-01-2019 05:26 PM
Hi, I am running a test scenario as described below to bring up 6PE, connecting 2 IPV6 islands over a MPLS core.
All routers run the same IOS (Dynamips)
PE1#sh ver
Cisco IOS Software, 7200 Software (C7200-SPSERVICESK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
The essential configuration as below:
PE1:
ipv6 unicast-routing
ipv6 cef
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 33.33.33.33 remote-as 1
neighbor 33.33.33.33 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 33.33.33.33 activate
no auto-summary
exit-address-family
!
address-family ipv6
redistribute connected
no synchronization
neighbor 33.33.33.33 activate
neighbor 33.33.33.33 send-label
exit-address-family
PE3:
ipv6 unicast-routing
ipv6 cef
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 11.11.11.11 remote-as 1
neighbor 11.11.11.11 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 11.11.11.11 activate
no auto-summary
exit-address-family
!
address-family ipv6
redistribute connected
no synchronization
neighbor 11.11.11.11 activate
neighbor 11.11.11.11 send-label
exit-address-family
I can see the prefixes being sent from the peer:
PE1#sh bgp ipv6 uni sum
BGP router identifier 11.11.11.11, local AS number 1
BGP table version is 5, main routing table version 5
4 network entries using 576 bytes of memory
4 path entries using 304 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1128 total bytes of memory
BGP activity 12/8 prefixes, 12/8 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
33.33.33.33 4 1 76 74 5 0 0 01:03:33 2
Now here is the problem:
PE1#show bgp ipv6 unicast tag
Network Next Hop In tag/Out tag
2001:2001:AAAA::/64
:: notag/notag
2001:2001:CCCC::/64
::FFFF:33.33.33.33
notag/notag
2001:AAAA::/32 :: notag/notag
2001:CCCC::/32 ::FFFF:33.33.33.33
notag/notag
PE1#sh bgp ipv6 uni
PE1#sh bgp ipv6 unicast 2001:CCCC::/32
BGP routing table entry for 2001:CCCC::/32, version 3
Paths: (1 available, no best path)
Not advertised to any peer
Local
::FFFF:33.33.33.33 (inaccessible) from 33.33.33.33 (33.33.33.33)
Origin incomplete, metric 0, localpref 100, valid, internal
The problem here is, I have some connected interfaces which was redistributed from the 6pe and advertised to the peer. The prefixes were received but locally they were untagged.
This results from the next-hop being inaccessible and not installed into the routing table as well. So far I've tested the mpls path as shown in the diagram which is working fine and also turned on ipv6 cef, however the ipv6 prefixes aren't getting tagged.
From the 6pe example on Cisco website it says to configure another essential command which is:
mpls ipv6 source-interface Loopback0
However, I don't have this command in this IOS version, even in the Advanced Enterprise version.
Is the IOS version lacking this required feature or I am doing something wrong?
Solved! Go to Solution.
04-16-2011 09:12 PM
Hi,
From feature navigator, 6PE is not supported on 15.0M. Could you try 12.4T ?
Thanks,
Laurent.
04-16-2011 12:29 AM
Hi,
It appears to are receiving those IPv6 UPDATE without any label intact. Normally when you receive IPv6 prefix with v4-mapped-v6 address but without label, the NH will be marked as inaccessible.
Do you see the label locally assigned in PE3?. Can you get the full config from both PE1 and PE3 with BGP output showing the capabilities negotiated?.
Regards,
Nagendra
04-16-2011 12:47 AM
Hi,
As I've discovered below, none of the ipv6 prefixes are getting tagged locally nor received prefixes. The BGP peering also reflect that the ipv6 mpls capability has been advertised and received accordingly. I've attached the running-config of both PEs as well.
PE3#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 16 1.1.1.1/32 0 Et1/0 33.33.33.1
17 17 2.2.2.2/32 0 Et1/0 33.33.33.1
18 Pop Label 3.3.3.3/32 0 Et1/0 33.33.33.1
19 18 4.4.4.4/32 0 Et1/0 33.33.33.1
20 19 11.11.11.0/30 0 Et1/0 33.33.33.1
21 20 11.11.11.11/32 0 Et1/0 33.33.33.1
22 21 12.12.12.0/30 0 Et1/0 33.33.33.1
23 Pop Label 23.23.23.0/30 0 Et1/0 33.33.33.1
24 Pop Label 34.34.34.0/30 0 Et1/0 33.33.33.1
25 23 41.41.41.0/30 0 Et1/0 33.33.33.1
PE3#show bgp ipv6 unicas
BGP table version is 3, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incompleteNetwork Next Hop Metric LocPrf Weight Path
* i2001:2001:AAAA::/64
::FFFF:11.11.11.11
0 100 0 ?
*> 2001:2001:CCCC::/64
:: 0 32768 ?
* i2001:AAAA::/32 ::FFFF:11.11.11.11
0 100 0 ?
*> 2001:CCCC::/32 :: 0 32768 ?
PE3#sh mpls ldp binding all
lib entry: 1.1.1.1/32, rev 37
local binding: label: 16
remote binding: lsr: 3.3.3.3:0, label: 16
lib entry: 2.2.2.2/32, rev 38
local binding: label: 17
remote binding: lsr: 3.3.3.3:0, label: 17
lib entry: 3.3.3.3/32, rev 39
local binding: label: 18
remote binding: lsr: 3.3.3.3:0, label: imp-null
lib entry: 4.4.4.4/32, rev 40
local binding: label: 19
remote binding: lsr: 3.3.3.3:0, label: 18
lib entry: 11.11.11.0/30, rev 41
local binding: label: 20
remote binding: lsr: 3.3.3.3:0, label: 19
lib entry: 11.11.11.11/32, rev 42
local binding: label: 21
remote binding: lsr: 3.3.3.3:0, label: 20
lib entry: 12.12.12.0/30, rev 43
local binding: label: 22
remote binding: lsr: 3.3.3.3:0, label: 21
lib entry: 23.23.23.0/30, rev 44
local binding: label: 23
remote binding: lsr: 3.3.3.3:0, label: imp-null
lib entry: 33.33.33.0/30, rev 45
local binding: label: imp-null
remote binding: lsr: 3.3.3.3:0, label: imp-null
lib entry: 33.33.33.33/32, rev 46
local binding: label: imp-null
remote binding: lsr: 3.3.3.3:0, label: 22
lib entry: 34.34.34.0/30, rev 47
local binding: label: 24
remote binding: lsr: 3.3.3.3:0, label: imp-null
lib entry: 41.41.41.0/30, rev 48
local binding: label: 25
remote binding: lsr: 3.3.3.3:0, label: 23
PE3#sh ip bgp neigh 11.11.11.11
BGP neighbor is 11.11.11.11, remote AS 1, internal link
BGP version 4, remote router ID 11.11.11.11
BGP state = Established, up for 04:24:31
Last read 00:00:20, last write 00:00:21, hold time is 180, keepalive interval is 60 seconds
Neighbor sessions:
1 active, is multisession capable
Neighbor capabilities:
Route refresh: advertised and received(new)
Four-octets ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
ipv6 MPLS Label capability: advertised and received
Multisession Capability: advertised and received
Message statistics, state Established:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 3 3
Keepalives: 294 292
Route Refresh: 0 0
Total: 298 296
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast
Session: 11.11.11.11 session 1
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 3
3 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
For address family: IPv6 Unicast
Session: 11.11.11.11 session 1
BGP table version 3, neighbor version 3/0
Output queue size : 0
Index 3
3 update-group member
Sending Prefix & Label
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 2 2 (Consumes 152 bytes)
Prefixes Total: 2 2
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 2, min 0
Address tracking is enabled, the RIB does have a route to 11.11.11.11
Connections established 4; dropped 3
Last reset 04:24:38, due to Peer closed the session of session 1
Transport(tcp) path-mtu-discovery is enabled
Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 33.33.33.33, Local port: 179
Foreign host: 11.11.11.11, Foreign port: 29723
Connection tableid (VRF): 0
Maximum output segment queue size: 50
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x2E3AD74):
Timer Starts Wakeups Next
Retrans 325 30 0x0
TimeWait 0 0 0x0
AckHold 294 287 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 1572273040 snduna: 1572278835 sndnxt: 1572278835 sndwnd: 16365
irs: 992597181 rcvnxt: 992602938 rcvwnd: 14959 delrcvwnd: 1425
SRTT: 319 ms, RTTO: 406 ms, RTV: 87 ms, KRTT: 0 ms
minRTT: 96 ms, maxRTT: 380 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1436 bytes):
Rcvd: 648 (out of order: 0), with data: 296, total data bytes: 5756
Sent: 621 (retransmit: 30, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 297, total data bytes: 5794
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
04-16-2011 09:12 PM
Hi,
From feature navigator, 6PE is not supported on 15.0M. Could you try 12.4T ?
Thanks,
Laurent.
04-18-2011 08:40 PM
Hi,
Thank you very much. I tried the technology train and now 6PE works fine.
Next hop is no longer inaccessible.
BGP routing table entry for 2001:2001:DEA1::/64, version 3
Paths: (1 available, best #1, table Default)
Not advertised to any peer
Local
::FFFF:1.1.1.1 (metric 20) from 1.1.1.1 (1.1.1.1)
Origin incomplete, metric 0, localpref 100, valid, internal, best
mpls labels in/out nolabel/23
ping ipv6 2001:2001:DEA1::1 source 2001:2001:DEA3::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2001:DEA1::1, timeout is 2 seconds:
Packet sent with a source address of 2001:2001:DEA3::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide