cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
18389
Views
45
Helpful
31
Replies
mchance
Beginner

IPv6 on vlans

I finally figured out how to get IPv6 on my outside and inside interfaces of my router (Cisco 2821) and on the uplink port on my switch (Cisco 3750).  All three IPv6 addresses are pingable from the outside world. The switch and router are connected with OSPF. I am not able to add the eui-64 prefix to my VLAN. What do I need to do to add IPv6 to my VLANs?

 

 

Router interfaces:

interface GigabitEthernet0/0
description OUTSIDE
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
ipv6 nd dad attempts 0
ipv6 nd autoconfig default-route
ipv6 dhcp client pd hint ::/64
ipv6 dhcp client pd COX
!
interface GigabitEthernet0/1
description INSIDE
ip address 10.0.0.9 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7 0702364F1F514A51
ip ospf 10 area 0
duplex auto
speed auto
ipv6 address 2600:8807:8500:419::/64 eui-64
ipv6 address autoconfig
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 ospf 10 area 0

 

Switch interfaces:

interface GigabitEthernet1/0/4
description LINK TO MIKEROUTER
no switchport
ip address 10.0.0.10 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7 10431E1A544F415F
ip ospf 10 area 0
ipv6 address autoconfig
ipv6 ospf 10 area 0

 

 

interface Vlan10
description MIKERO
ip address 10.10.17.1 255.255.255.0
ip ospf 10 area 0
ipv6 address autoconfig default
ipv6 enable
ipv6 ospf 10 area 0

31 REPLIES 31

So I just got a /56. Now what?

 

GigabitEthernet0/0 is in client mode
Prefix State is SOLICIT (1)
Information refresh timer expires in 23:59:34
Address State is OPEN
Renew for address will be sent in 11:59:34
List of known servers:
Reachable via address: FE80::A64C:11FF:FE8A:DADA
DUID: 000100015567324DF8BC123EDDA4
Preference: 0
Configuration parameters:
IA PD: IA ID 0x00030001, T1 43200, T2 69120
Prefix: 2600:8807:8502:ED00::/56
preferred lifetime 86400, valid lifetime 86400, expired
IA NA: IA ID 0x00030001, T1 43200, T2 69120
Address: 2600:8807:9F02:1:B943:EACC:9C61:BC25/128
preferred lifetime 86400, valid lifetime 86400
expires at Mar 07 2018 10:37 AM (86375 seconds)
DNS server: 2001:578:3F::30
DNS server: 2001:578:3F:1::30
Information refresh time: 0
Prefix name: COX
Prefix Rapid-Commit: disabled
Address Rapid-Commit: enabled
Prefixes sent as hint:
::/56

So now you want to be running firmware new enough that it copes well with DHCPv6 prefix delegation. Upstream (cox.net?) will be sending you ICMPv6 router advertisements (RA), which will probably have the "managed configuration" flag on, meaning you should do DHCPv6 to find out more. The router will be using its link-local scope address as sender for the RA, starting fe80::/64; that's your v6 gateway address. Basically all IPv6 subnets are /64 at the vlan, so with a /56, you have 8 bits to do subnetting with. The DHCP prefix delegation will tell you which one is used on the outside interface, perhaps the one with 00 as the subnet. The rest you can use on inside subnets, be they LAN, WIFI, guest WIFI, DMZ or whatever. -- Jim Leinweber