Showing results for 
Search instead for 
Did you mean: 

RV340 and Comcast Xfinity IPv6 Config


I am using Comcast's residential service with an RV340 and a NETGEAR Nighthawk Cable Modem with Voice CM1150V.  I have configured IPv6 to be enabled.  I seem to be able to get a DHCP IPv6 address at the router (WAN port 1 reports an IPv6 address up in WAN1 config).  I also see an IPv6 address in the range reported by the VLAN config for IPv6 on my windows 10 computer.  I am using DHCP-PD to get the prefix from the ISP.


I am able to ping my loopback IP on my PC.  I'm also able to ping another computer with an IPv6 address on the LAN.  I am unable to resolve addresses IPv6 nor am I able to ping IPv6 addresses on the internet.  I went to a few IPv6 test sites including Comcast's and they indicate I have no IPv6 connectivity.


I'm at a loss as to what to do next.  And I don't think contacting comcast would be useful at all.


There are indications that this model of router provides 1 year of cisco support but I don't see any way of reaching them without a contract.


Attached is the config of my router (with password data deleted, even though it appears encrypted)

4 Replies 4

Tyson Joachims
Rising star
Rising star

1) When you say that you're getting an IPv6 address, is it a link-local address or global address?

2) Are you getting a DNS address and if so, are you able to ping it?

3) Have you tried using trace route to the Internet and see where your trace stops? You can try pinging Google's IPv6 DNS server at 2001:4860:4860::8888 or 2001:4860:4860::8844. If you can ping either one, you may even try statically assigning your computer's DNS settings to one of those servers and see if you can open web pages.

I'm editing this post. I rebooted my router and cable modem and was able to get my IPv6 back up on the WAN1 port.  I have added screenshots of my vlan and wan1 configs.  If I manually enter IPv6 information in windows 10 I am able to get what I believe is a global IPv6 address.  I am able to ping IPv6 addresses and I'm now able to pass those "test your IPv6 status" websites.


So for whatever reason, I'm not able to automatically get an IPv6 address.  That's where I'm getting stuck.  Because my router is properly getting what it needs from the WAN1 connection with my ISP, but fails to assign addresses to devices on my local VLAN.


I have no idea why this fixed it and I'm not even 100% sure it did, but I searched some other forums and thought it had something to do with route advertisements.  I couldn't modify the routing table in the GUI and I was about to see what CLI stuff might exist, when I went to LAN settings once more and found a section for "router advertisement."  I'm reasonably sure those weren't the same thing but I decided to enable it anyway.  As soon as I did, all devices on my LAN received IPv6 addresses.  So now my PCs, Android, and iOS devices all have IPv6 addresses and can access the internet using IPv6 (tested using google's IPv6 readiness page).

Nope i was wrong.  Shortly after posting i lost all ipv6 connectivity without making any changes.  I give up.  I'll live without it until I need it..

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers