cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4353
Views
5
Helpful
7
Replies

Telnet resolving names via IPv6 instead of ipv4

jaredkelsey
Beginner
Beginner

If I ping tools.cisco.com it is successful via ipv4:

ROUTER# ping tools.cisco.com
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 173.37.145.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms

 

But if I try to telnet to tools.cisco.com port 443 I get an ipv6 name lookup! I'm not running ipv6 anywhere on this router:

ROUTER#telnet tools.cisco.com 443
Trying 2001:420:1101:5::A, 443 ...
% Destination unreachable; gateway or host down

ROUTER#

 

What the heck is going on?

 

--<snip> --
ip name-server <my internal dns ipv4 address>
ip domain lookup source-interface Loopback0
ip domain name <my internal domain name>

http client source interface Loopback0

interface Loopback0
ip address 10.255.0.136 255.255.255.255
end

7 Replies 7

michel.prevost
Beginner
Beginner

Got anygthing on this anyone?

Hello,

 

I looked at some other posts, somebody suggests to configure:

 

call-home/http resolve-hostname ipv4-first

 

and explicitly disable (no ipv6 enable) on the interfaces.

Hi Georg, 

 

I've already did all that. I also tried to change the server in the http url for the IP address of the server, but still stuck with the same error (205)

 

Thanks for your answer. Have a nice day. 

 

Hello,

 

sorry for the late reply. I cannot TELNET to the site at all. What if you configure a host entry in your router:

 

ip host tools.cisco.com 173.37.145.8

 

I wonder if the site is up at all...

please use below command to check 

telnet tools.cisco.com 443 /ipv4

you wll get correct result

also try below command

no service call-home

no call-home

service call-home

call-home

http resolve-hostname ipv4-first

HI

telnet tools.cisco.com 23 /ipv4

Work on an old CSR 1000V.

jamesbos96602
Beginner
Beginner

note ipv6 should never be used in homes or small busness it is huge security probem. as for most part it cant be control. i did say for most part. in fack rasomware depends on ipv6 but can fall back to ipv4 if coded to do it. ipv6 was set up to hide who was behind the address as it dose not use dns, throw it can i had set up 1000s of domains and helping microsoft microsoft allways removed ipv6 out the dns for the domain ask why?  as makes no sence, ipv6 should only be used by them who can contain it and them who dont understand it turn it off, i done computers 30 years i never used ipv6 i trun off where can be trun off . by turning it off everything defaults back to ipv4 note if u on swich name the router in host file with ipv4 address it should only use that address

throw i got quistion why is call-home unconfig useing any protocall ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers