cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1862
Views
0
Helpful
2
Replies

Using an ISATAP tunnel

shanjoanne931
Level 1
Level 1

Hi, 

I'm currently a 4th year student doing her Honours project and I seem to have run into a little issue. 

Firstly, let me describe my network: 

I'm using Pagent IOS for my Traffic Generator (TrafGen) so it is the beginning and the end of my network. It is firstly connected to a Dual Stack router (R1), which is connected to an IPv4 router (R2), back to a Dual Stack (R3) and then back to the Traffic Generator (TrafGen). I am implementing different tunneling methods from R1 to R3 to send IPv6 traffic across the IPv4 network (R2). However, I'm struggling to configure ISATAP from R1 to R3 and I was wondering if anyone could help me. 

 

ipv6 unicast-routing

ipv6 cef

!

interface tunnel0

no ip address

no ip redirects

ipv6 address 2002:1: a00:101::/64 eui-64

no ipv6 nd suppress-ra

tunnel source fastethernet0/0

tunnel mode ipv6ip isatap

!

interface f0/0

ip address 10.0.1.1 255.255.255.0

!

router rip

network 10.0.0.0

!

interface fa0/1

ipv6 address 2001:db8:0:1::1/64

ipv6 rip RIP1 enable

!

ipv6 router rip RIP1

 

My first question, I have been following many examples and not one of them states that I should have a static ipv6 route to direct my traffic into the tunnel, is this necessary? My second, is how do configure a router as the "client" which allows my IPv6 traffic to continue on back to TrafGen? 

 

Any help would be appreciated, and I'm available for any questions about my network.

Many Thanks,

Shannon

 

UPDATE:

I should mention, this is my current configuration for my R3:

ipv6 unicast-routing

ipv6 cef

!

interface f0/1

ip address 10.0.2.2 255.255.255.0

!

router rip

network 10.0.0.0

!

interface fa0/0

ipv6 address 2001:db8:0:2::2/64

ipv6 rip RIP1 enable

!

ipv6 router rip RIP1

2 Replies 2

Seb Rupik
VIP Alumni
VIP Alumni

Hi Shannon,

Regarding the distribution of routes, you need to added the RIP process comand to each tunnel inteface.

For the tunnel to complete you need a tunnel interface on R3. Add the following:

 

!

interface Tunnel1

  no ip address

  ipv6 address autoconfig

  ipv6 enable

  tunnel source fa0/1

  tunnel mode ipv6ip

  tunnel destination 10.0.1.1

!

 

cheers,

Seb.

Thank you for your quick reply! I will test this ASAP and hopefully won't have any more issues. 

Shannon

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: