03-21-2011 03:36 AM
Hi,
Please help, I try to configure IPv6 on MPLS (MP-BGP) with command address-family ipv6 vrf <Vrf Name> but failed to capture the following results
#address-family ipv6 vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6
#address-family ipv6 unicast vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6
I have activated the configuration as ipv6 unicast-routing, ipv6 cef, etc
ip vrf Test_IPv6
description **** Test BGP IPv6 ****
rd 776:776
route-target export 776:776
route-target import 776:776
whether there is a lack of configuration?
03-21-2011 03:43 AM
Hi Revai,
For 6VPE, you need to use vrf definition. See below for exampla,
vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv6
exit-address-family
!
!
end
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv6 vrf TEST2
R2(config-router-af)#
HTH,
Nagendra
03-21-2011 03:45 AM
Hello Nagendra,
Thank you for responding. By the way, if you define a VRF using the vrf definition command, is that VRF usable both for IPv4 and IPv6 interfaces, or do I have to configure a VRF separately for IPv4 and IPv6 address families?
Best regards,
Peter
03-21-2011 03:52 AM
Hi Peter,
"vrf definition" is generic way of configuring VRF. By enabling required address-family, you can use it for both IPv4 and IPv6 as below,
vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
!
end
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
% Topology TEST2::VPNv4 Unicast::base is currently being deconfigured.
R2(config-router)#vrf definition TEST2
R2(config-vrf)#address-family ipv4
R2(config-vrf-af)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
R2(config-router-af)#end
R2#
R2#
03-21-2011 03:55 AM
Hi,
Sorry about the error message. Please see below for example,
Current configuration : 145 bytes
vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv6
exit-address-family
!
!
end
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
% Invalid address family ipv4 unicast vrf TEST2
R2(config-router)#vrf definition TEST2
R2(config-vrf)#address-family ipv4
R2(config-vrf-af)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
R2(config-router-af)#end
R2#
HTH,
Nagendra
03-21-2011 07:19 AM
Hi Nagendra,
Thank you very much for the explanation. Regarding the error message, no problem, I found that actually quite instructive.
Best regards,
Peter
03-21-2011 04:10 AM
Hi Nagendra,
Thanks for your respond, I've try again using configuration vrf definition .. but still failed and still the same result. may I know the IOS and router type are you using? may be for your information, I use a router Cisco 7600 series with IOS c7600s72033-advipservicesk9-mz.122-33.SRD5.bin.
vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776
#address-family ipv6 vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6
#address-family ipv6 unicast vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6
03-21-2011 04:13 AM
Have you enabled "address-family ipv6" under vrf definition?.
Please paste "show run vrf
Regards,
Nagendra
03-21-2011 04:22 AM
Hi Nagendra,
Please see below..
#sh run vrf IPv6_Test
Building configuration...
Current configuration : 108 bytes
vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776
!
end
03-21-2011 04:25 AM
Hi Gilang,
Can you try the below configuration,
R2(config)#vrf definition IPv6_Test
R2(config-vrf)#rd 776:776
R2(config-vrf)#route-target both 776:776
R2(config-vrf)#address-family ipv6 ==> This appears to be missing in your configuration.
R2(config-vrf-af)#end
R2#show run vrf IPv6_Test
Building configuration...
Current configuration : 149 bytes
vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776
!
address-family ipv6
exit-address-family
!
!
end
R2#
HTH,
Nagendra
03-22-2011 04:26 AM
Hi
You have to use the command "mls ipv6 vrf" before configuring ipv6 address-family.
mls ipv6 vrf
vrf definition Test_IPv6
rd xxx
route-target both xxx
address-family ipv4
address-family ipv6
You can also have different route-targets for ipv4 and ipv6 like this
mls ipv6 vrf
vrf definition Test_IPv6
rd xxx
address-family ipv4
route-target bo 1:1
address-family ipv6
route-target bo 2:2
or running multicast like this
mls ipv6 vrf
vrf definition Test_IPv6
rd xxx
route-target xxx
address-family ipv4
mdt default 239.1.2.3
address-family ipv6
/Mikael
03-30-2011 10:01 PM
Problem has been solved, thanks for all respond
Regards,
Gilang RIvai
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide