06-27-2023 12:28 PM - edited 07-09-2023 05:24 AM
Hello everyone
Im facing an issue with mpls label swithing on bridge-domain interfaces on both ASR and CSR 1000 series.
looks like they cant send Mpls traffic on the bd interface and then i enter "show int bdi10" i can verify it with "Total output drops: 91"
this is the configuration:
CSR#show run int BD10
Building configuration...
Current configuration : 112 bytes
!
interface BDI10
ip address 172.16.10.2 255.255.255.0
ip ospf 1 area 0
encapsulation dot1Q 10
mpls ip
end
CSR#show run int BD10
description XRV.GI0/0/0/1
no ip address
no negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
end
CSR#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label 1.1.1.1/32 0 BD10 172.16.10.1
17 Pop Label 172.16.30.0/24 0 BD10 172.16.10.1
18 24001 3.3.3.3/32 0 BD10 172.16.10.1
21 Pop Label 172.16.20.0/24 0 BD10 172.16.10.1
this is the output of pinging 3.3.3.3 which uses the outgoing label of "24001" and the source of Lo0 "1.1.1.1
":
CSR#ping 3.3.3.3 so lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
*Jun 27 14:09:31.588: %IOSXE-3-PLATFORM: F0: cpp_cp: QFP:0.0 Thread:000 TS:00000000230257499004 %QOS-3-INVALID_QID: Queuing error for interface BDI10 qid 0 wred 0 -Traceback=1#bb74f0e7d32e4c64c235965c6edef45d 809db6c7 809d6dc7 809cf1f7 809cf886 809dfa62 8060c3ce 8060bc5c e75039b8 .....
Success rate is 0 percent (0/5)
this is the topology: CSR1000V(Source) ---- XRV ---- CSR1000V (Destination)
when i replace the BDI with a subinterface like Gi1.10 eveything works perfect.
i'd be glad if anyone can help me resolve this issue.
Thanks
Amir
Solved! Go to Solution.
06-29-2023 11:49 AM - edited 06-29-2023 12:43 PM
Hi @Amirmahdi.M ,
As I mentioned in my previous post, it works perfectly in 17.3.4a. The image you run is rather old. I would recommend you upgrade and try again.
interface GigabitEthernet1
no ip address
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface BDI10
ip address 192.168.12.1 255.255.255.0
ip ospf network point-to-point
ip ospf 109 area 0
encapsulation dot1Q 10
mpls ip
PE1#sh ip cef 192.168.100.3
192.168.100.3/32
nexthop 192.168.12.2 BDI10 label 24001-(local:19)
PE1#sh mpls for labels 19
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
19 24001 192.168.100.3/32 0 BD10 192.168.12.2
PE1#trace mpls ipv4 192.168.100.3/32 source 192.168.100.1
Tracing MPLS Label Switched Path to 192.168.100.3/32, timeout is 2 seconds
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
'X' - unknown return code, 'x' - return code 0
Type escape sequence to abort.
0 192.168.12.1 MRU 1500 [Labels: 24001 Exp: 0]
L 1 192.168.12.2 MRU 1500 [Labels: implicit-null Exp: 0] 22 ms
! 2 192.168.23.3 44 ms
PE1#
Regards,
06-29-2023 02:48 AM
Can I know more about your topology ?
thanks
MHM
06-29-2023 04:13 AM
sure
by the way im simulating the scenario in eve-ng.
the real topology:
The ASR1002-HX is using BDI for its connectivity with the ASR9006 but seems like mpls label switching is not working on it.(we got VPLS from another isp for layer 2 connectivity)
the image that ASR1002-HX uses is : asr1000-universalk9.16.06.07.SPA.bin
for simulation i used 2 CSR1000V and an xrv image:
i looked at some other devices like ASR900 and ASR920 series which are using MPLS on BDI but they had no problem with it.
i looked up cisco's asr1000 configuration guide but there wasnt anything about this problem.
Thanks
Amir
06-29-2023 04:45 AM
I think you need to remove the vlag tag under the service instance before it is processed by the BDI interface
!
interface BDI10
ip address 172.16.10.2 255.255.255.0
ip ospf 1 area 0
no encapsulation dot1Q 10
mpls ip
end
CSR#show run int BD10
description XRV.GI0/0/0/1
no ip address
no negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
bridge-domain 10
06-29-2023 06:24 AM
Hi @Amirmahdi.M ,
What IOS-XE are you running. I quickly tried your configuration with 17.3.4a and it works like a charm.
I am curious about this entry in the MPLS forwarding table:
No Label 3.3.3.3/32 0 BD20 172.16.20.1
Can you provide the "show ip ro 3.3.3.3 255.255.255.255"
Regards,
06-29-2023 11:16 AM
Hi @Harold Ritter ,
at first i used 2 BDIs to simulate the real problem then i shutdown one of them to use wireshark on the other interface and then i realised the there is no outgoing mpls traffic from the interface.
These are the current configuraion on the csr1000v:
CSR#show run int gi1
Building configuration...
Current configuration : 209 bytes
!
interface GigabitEthernet1
description XRV.GI0/0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
bridge-domain 10
!
end
CSR#show run int BDI10
Building configuration...
Current configuration : 88 bytes
!
interface BDI10
ip address 172.16.10.2 255.255.255.0
ip ospf 1 area 0
mpls ip
end
CSR#show mpls fo
CSR#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label 1.1.1.1/32 0 BD10 172.16.10.1
17 24001 3.3.3.3/32 0 BD10 172.16.10.1
18 Pop Label 172.16.20.0/24 0 BD10 172.16.10.1
19 Pop Label 172.16.30.0/24 0 BD10 172.16.10.1
CSR#show ip route 3.3.3.3 255.255.255.255
Routing entry for 3.3.3.3/32
Known via "ospf 1", distance 110, metric 3, type intra area
Last update from 172.16.10.1 on BDI10, 00:03:45 ago
Routing Descriptor Blocks:
* 172.16.10.1, from 3.3.3.3, 00:03:45 ago, via BDI10
Route metric is 3, traffic share count is 1
CSR#ping 3.3.3.3 so Lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
*Jun 29 18:07:08.281: %IOSXE-3-PLATFORM: F0: cpp_cp: QFP:0.0 Thread:000 TS:00000000324189653261 %QOS-3-INVALID_QID: Queuing error for interface BDI10 qid 0 wred 0 -Traceback=1#bb74f0e7d32e4c64c235965c6edef45d 809db6c7 809d6dc7 809cf1f7 809cf886 809dfa62 8060c3ce 8060bc5c e7553238 .....
Success rate is 0 percent (0/5)
CSR#show version
Cisco IOS XE Software, Version 03.13.00.S - Extended Support Release
Cisco IOS Software, CSR1000V Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.4(3)S, RELEASE SOFTWARE (fc11)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Mon 28-Jul-14 00:46 by mcpre
Cisco IOS-XE software, Copyright (c) 2005-2014 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0. The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0. For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.
ROM: IOS-XE ROMMON
CSR uptime is 7 minutes
Uptime for this control processor is 8 minutes
System returned to ROM by reload
System image file is "bootflash:packages.conf"
Last reload reason: <NULL>
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
License Level: ax
License Type: Default. No valid license found.
Next reload license Level: ax
cisco CSR1000V (VXE) processor (revision VXE) with 1195119K/6147K bytes of memory.
Processor board ID 91L9FDGTJHF
4 Gigabit Ethernet interfaces
32768K bytes of non-volatile configuration memory.
3022420K bytes of physical memory.
7774207K bytes of virtual hard disk at bootflash:.
Configuration register is 0x2102
CSR#
I also changed the configuration to what @filopeter suggested but the problem still consists.
Thanks
Amir
06-29-2023 11:49 AM - edited 06-29-2023 12:43 PM
Hi @Amirmahdi.M ,
As I mentioned in my previous post, it works perfectly in 17.3.4a. The image you run is rather old. I would recommend you upgrade and try again.
interface GigabitEthernet1
no ip address
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface BDI10
ip address 192.168.12.1 255.255.255.0
ip ospf network point-to-point
ip ospf 109 area 0
encapsulation dot1Q 10
mpls ip
PE1#sh ip cef 192.168.100.3
192.168.100.3/32
nexthop 192.168.12.2 BDI10 label 24001-(local:19)
PE1#sh mpls for labels 19
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
19 24001 192.168.100.3/32 0 BD10 192.168.12.2
PE1#trace mpls ipv4 192.168.100.3/32 source 192.168.100.1
Tracing MPLS Label Switched Path to 192.168.100.3/32, timeout is 2 seconds
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
'X' - unknown return code, 'x' - return code 0
Type escape sequence to abort.
0 192.168.12.1 MRU 1500 [Labels: 24001 Exp: 0]
L 1 192.168.12.2 MRU 1500 [Labels: implicit-null Exp: 0] 22 ms
! 2 192.168.23.3 44 ms
PE1#
Regards,
06-29-2023 12:11 PM - edited 06-29-2023 12:29 PM
Hi @Harold Ritter ,
i'm also facing this problem on the ASR1002HX with "Cisco IOS XE Software, Version 16.06.07"
System image file is "bootflash:/asr1000-universalk9.16.06.07.SPA.bin"
edge1#show ip cef 172.19.106.2
172.19.106.2/32
nexthop 172.19.54.45 BDI190 label 24094-(local:64)
nexthop 172.23.123.141 BDI191 label 24094-(local:64)
nexthop 172.23.123.145 BDI192 label 24094-(local:64)
nexthop 172.23.123.149 BDI193 label 24094-(local:64)
nexthop 172.23.123.153 BDI194 label 24094-(local:64)
nexthop 172.23.123.157 BDI195 label 24094-(local:64)
nexthop 172.23.123.161 BDI196 label 24094-(local:64)
nexthop 172.23.123.165 BDI197 label 24094-(local:64)
nexthop 172.23.123.169 BDI198 label 24094-(local:64)
edge1#traceroute mpls ipv4 172.19.106.2 255.255.255.255 source 172.19.73.13
Tracing MPLS Label Switched Path to 172.19.106.2/32, timeout is 2 seconds
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
'X' - unknown return code, 'x' - return code 0
Type escape sequence to abort.
0 172.19.54.46 MRU 1600 [Labels: 24094 Exp: 0]
. 1 *
. 2 *
. 3 *
. 4 *
. 5 *
edge1#show run int Po1
Building configuration...
Current configuration : 1261 bytes
!
interface Port-channel1
description UPLINK.VPLS
mtu 1600
no ip address
service instance 190 ethernet
description VPLS.BLS.L9
encapsulation dot1q 190
!
service instance 191 ethernet
description VPLS.BLS.L1
encapsulation dot1q 191
!
service instance 192 ethernet
description VPLS.BLS.L2
encapsulation dot1q 192
!
service instance 193 ethernet
description VPLS.BLS.L3
encapsulation dot1q 193
!
service instance 194 ethernet
description VPLS.BLS.L4
encapsulation dot1q 194
!
service instance 195 ethernet
description VPLS.BLS.L5
encapsulation dot1q 195
!
service instance 196 ethernet
description VPLS.BLS.L6
encapsulation dot1q 196
!
service instance 197 ethernet
description VPLS.BLS.L7
encapsulation dot1q 197
!
service instance 198 ethernet
description VPLS.BLS.L8
encapsulation dot1q 198
!
end
edge1#show run int BDi190
Building configuration...
Current configuration : 248 bytes
!
interface BDI190
description VPLS.LINK9
mtu 1600
ip address 172.19.54.46 255.255.255.252
ip router isis ISIS
encapsulation dot1Q 190
mpls ip
clns mtu 1583
isis circuit-type level-2-only
isis network point-to-point
isis metric 1
end
edge1#
by the way im installing csr1000v-universalk9.17.03.02.iso on eve-ng to test with newer ios.
any suggestions?
Thanks
Amir
06-29-2023 12:29 PM
VPLS... I stop here'
Did you use BD for vpls
Did you config vfi or l2vpn ?
06-29-2023 12:50 PM
we are not providing the VPLS. we are the customer getting the service becuase our devices are in 2 different citys
06-29-2023 01:15 PM
Ok get you'
For ios xe there are two way bridge two interface' what you config and using local connect l2vpn.
Try using l2vpn locol connect and check result.
06-29-2023 12:50 PM
Hi @Amirmahdi.M ,
I would suggest you validate that upgrading to version 17 in your virtual lab fixes the issue and you could probably plan the upgrade for the physical network as well.
Regards,
06-29-2023 01:26 PM
Hi @Harold Ritter ,
Upgrading the csr1000v to 17.03.02 did fix the issue.
but im still wondering why isnt there any documentation about this problem in cisco's configuration guide or ios release notes?
Thanks
Amir
06-29-2023 02:14 PM
It is a good question @Amirmahdi.M . It is sometimes difficult to cover all the possible scenarios. In doubts, you can always contact the TAC for official feature support information.
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide