There is an RSVP-TE tunnel(FRR link protected) from R1 to R4(R1-R2-R3-R4).
I have configured a backup tunnel between R2 and R3 through R5. If I execute 'show mpls traffic-eng fast-reroute database' on R2 I see tunnel1 with the status 'ready'.
As I shutdown gi2 on R2, backup tunnel status becomes 'Active' for a few seconds, but after a few seconds if I execute 'show mpls traffic-eng fast-reroute database' command again I do not see any output. I am not sure if it is a bug or expected behavior.
Following is the configuration.
R1
----------------------------
mpls traffic-eng tunnels
hostname r1
int gi1
ip address 100.10.20.1 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int lo0
ip address 1.1.1.1 255.255.255.255
router isis 1
net 49.0001.1111.1111.1111.00
is-type level-2
metric-style wide
mpls traffic-eng router-id lo0
mpls traffic-eng level-2
passive-interface lo0
advertise passive-only
interface tunnel1
ip unnumbered lo0
tunnel destination 4.4.4.4
tunnel mode mpls traffic-eng
tunnel mpl traffic-eng path-option 1 dynamic
tunnel mpls traffic-eng fast-reroute
R2
----------------------------
mpls traffic-eng tunnels
hostname R2
int gi3
ip address 100.20.50.2 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int gi1
ip address 100.10.20.2 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int gi2
ip address 100.20.30.2 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
mpls traffic-eng backup
int lo0
ip address 2.2.2.2 255.255.255.255
router isis 1
net 49.0002.2222.2222.2222.00
is-type level-2
metric-style wide
mpls traffic-eng router-id lo0
mpls traffic-eng level-2
passive-interface lo0
advertise passive-only
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 3.3.3.3
tunnel mpls traffic-eng path-option 1 explicit name path1
end
ip explicit-path name path1
index 1 next-address 5.5.5.5
index 2 next-address 3.3.3.3
R3
----------------------------
mpls traffic-eng tunnels
hostname R3
int gi4
ip address 100.30.50.3 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int gi2
ip address 100.20.30.3 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int gi1
ip address 100.30.40.3 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int lo0
ip address 3.3.3.3 255.255.255.255
router isis 1
net 49.0003.3333.3333.3333.00
is-type level-2
metric-style wide
mpls traffic-eng router-id lo0
mpls traffic-eng level-2
passive-interface lo0
advertise passive-only
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 2.2.2.2
tunnel mpls traffic-eng path-option 1 explicit name path1
end
ip explicit-path name path1
index 1 next-address 5.5.5.5
index 2 next-address 2.2.2.2
R4
----------------------------
mpls traffic-eng tunnels
hostname r4
int gi1
ip address 100.30.40.4 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int lo0
ip address 4.4.4.4 255.255.255.255
router isis 1
net 49.0004.4444.4444.4444.00
is-type level-2
metric-style wide
mpls traffic-eng router-id lo0
mpls traffic-eng level-2
passive-interface lo0
advertise passive-only
R5
----------------------------
mpls traffic-eng tunnels
hostname r5
int gi3
ip address 100.20.50.5 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int gi4
ip address 100.30.50.5 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
int lo0
ip address 5.5.5.5 255.255.255.255
router isis 1
net 49.0005.5555.5555.5555.00
is-type level-2
metric-style wide
mpls traffic-eng router-id lo0
mpls traffic-eng level-2
passive-interface lo0
advertise passive-only