cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
337
Views
0
Helpful
1
Replies

interworking of segment-routing and mpls ldp

sachin30720041
Beginner
Beginner

Hello All,

I have a following set up. Segment-routing is enabled on XRV1, XRV2 and XRV3. And ldp is enabled on csr4 and csr5.

I have configured mapping server for CSR4's and CSR5's loopback addresses. BGP VPNV4 is enabled between XRV1 and XRV3.

vrf1 is configured on XRV1 and XRV3. I am not able to ping from vrf1's loopback1 on XRV1 to loopback1 of VRF1 on XRV3.

XRV1#ping vrf vrf1 33.33.33.33 source 11.11.11.11
Wed Sep 7 22:24:18.726 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

XRV1-----CSR4-----CSR5---------XRV2----XRV3

 

XRv1
---------------
vrf vrf1
address-family ipv4 unicast
export route-target 1:1
import route-target 3:3
exit

segment-routing
mapping-server
prefix-sid-map
address-family ipv4
4.4.4.4/32 4
5.5.5.5/32 5


int lo1
vrf vrf1
ip address 11.11.11.11 255.255.255.255
exit

router bgp 13
address-family ipv4 unicast
exit
address-family vpnv4 unicast
exit
neighbor-group group1
remote-as 13
update-source lo0
address-family vpnv4 unicast
exit
neighbor 3.3.3.3
use neighbor-group group1
vrf vrf1
rd 1:1
address-family ipv4 unicast
network 11.11.11.11/32
exit

int gi0/0/0/1
ipv4 address 100.10.40.1 255.255.255.0
no sh

int lo0
ipv4 address 1.1.1.1 255.255.255.255

mpls ldp
exit

router isis 1
net 49.0001.1111.1111.1111.00
is-type level-2
distribute link-state
address-family ipv4 unicast
mpls ldp auto-config
metric-style wide
segment-routing mpls
segment-routing prefix-sid-map advertise-local
router-id lo0
exit
int gi0/0/0/1
point-to-point
address-family ipv4 unicast
exit
int lo0
address-family ipv4 unicast
prefix-sid index 1
exit


CSR4
-------------------
int gi1
ip address 100.10.40.4 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int gi2
ip address 100.40.50.4 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 4.4.4.4 255.255.255.255
ip router isis 1


router isis 1
net 49.0004.4444.4444.4444.00
is-type level-2
address-family ipv4 unicast
mpls ldp autoconfig
metric-style wide
exit

CSR5
-------------------
int gi1
ip address 100.20.50.5 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int gi2
ip address 100.40.50.5 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 5.5.5.5 255.255.255.255
ip router isis 1


router isis 1
net 49.0005.5555.5555.5555.00
is-type level-2
address-family ipv4 unicast
mpls ldp autoconfig
metric-style wide
exit


XRV2
--------------------
int gi0/0/0/0
ipv4 address 100.20.30.2 255.255.255.0
no sh

int gi0/0/0/1
ipv4 address 100.20.50.2 255.255.255.0
no sh

int lo0
ipv4 address 2.2.2.2 255.255.255.255

router isis 1
net 49.0002.2222.2222.2222.00
is-type level-2
distribute link-state
address-family ipv4 unicast
metric-style wide
segment-routing mpls
router-id lo0
exit
int gi0/0/0/1
point-to-point
address-family ipv4 unicast
exit
int gi0/0/0/0
point-to-point
address-family ipv4 unicast
exit
int lo0
address-family ipv4 unicast
prefix-sid index 2
exit

XRV3
--------------------
segment-routing
mapping-server
prefix-sid-map
address-family ipv4
4.4.4.4/32 4
5.5.5.5/32 5


vrf vrf1
address-family ipv4 unicast
export route-target 3:3
import route-target 1:1
exit

int lo1
vrf vrf1
ip address 33.33.33.33 255.255.255.255
exit

router bgp 13
address-family ipv4 unicast
exit
address-family vpnv4 unicast
exit
neighbor-group group1
remote-as 13
update-source lo0
address-family vpnv4 unicast
exit
neighbor 1.1.1.1
use neighbor-group group1
vrf vrf1
rd 3:3
address-family ipv4 unicast
network 33.33.33.33/32
exit

int gi0/0/0/0
ipv4 address 100.20.30.3 255.255.255.0
no sh

int lo0
ipv4 address 3.3.3.3 255.255.255.255

router isis 1
net 49.0003.3333.3333.3333.00
is-type level-2
distribute link-state
address-family ipv4 unicast
metric-style wide
segment-routing mpls
segment-routing prefix-sid-map advertise-local
router-id lo0
exit
int gi0/0/0/0
point-to-point
address-family ipv4 unicast
exit
int lo0
address-family ipv4 unicast
prefix-sid index 3
exit

Thanks,

Sachin

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

You need to enable LDP on the interface towards CSR5 on XRV2.

mpls ldp

interface gi0/0/0/1

BTW, You do not need a mapping server in this scenario, since the PEs are both SR enabled. You only need a mapping server when a PE in the SR domain needs to talk to a PE in the LDP domain. Remove the mapping servers on XRV1 and XRV3 and do the VRF connectivity test between XRV1 and XRV3. It should work after doing the change recommended above.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

1 Reply 1

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

You need to enable LDP on the interface towards CSR5 on XRV2.

mpls ldp

interface gi0/0/0/1

BTW, You do not need a mapping server in this scenario, since the PEs are both SR enabled. You only need a mapping server when a PE in the SR domain needs to talk to a PE in the LDP domain. Remove the mapping servers on XRV1 and XRV3 and do the VRF connectivity test between XRV1 and XRV3. It should work after doing the change recommended above.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers