cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1447
Views
5
Helpful
3
Replies
lvpin Lv
Beginner

MPLS CSC Sham-link Problem

Hello everyone I am a for students from China, here is my problem, my English is not good, this is done by google translate.

Lab Topology

拓扑.jpg

Narrative

Blue link ,Is the backdoor link

R3-RR and R8-RR   backdoor link,Everything is normal

R1-CE and R10-CE  backdoor link ,Problem occurs

Among ,R2-PE of F0/0,R4-PE of F0/0,R6-PE of F0/1 ,R9-PE of F0/1,is VRF Interface,As shown。

Experimental phenomena

R1-CE 《——》 R10-CE     backdoor link

————————————————————————————————

FULL  OR  DOWN

R2#

*Oct 14 17:34:49.675: %SYS-5-CONFIG_I: Configured from console by console

R2#

*Oct 14 17:34:52.063: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from LOADING to FULL, Loading Done

R2#

*Oct 14 17:34:56.147: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from FULL to DOWN, Neighbor Down: Interface down or detached

R2#

*Oct 14 17:35:02.063: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from LOADING to FULL, Loading Done

R2#

*Oct 14 17:35:06.183: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from FULL to DOWN, Neighbor Down: Interface down or detached

R2#

*Oct 14 17:35:12.219: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from LOADING to FULL, Loading Done

R2#

*Oct 14 17:35:16.203: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL3 from FULL to DOWN, Neighbor Down: Interface down or detached

R2#

*Oct 14 17:35:19.219: %OSPF-4-ERRRCV: Received invalid packet: Bad LLS Checksum from 12.1.1.1, FastEthernet0/0

.

.

.

.

_______________________________________________________________________

OR .......

Without any Experimental phenomena

Neighbors will not FULL,Will not DOWN

How to solve this situation?

However, I did not

R2(config)#route ospf 12 vrf a   

network 【Loopback  VRF interface address】

Experimental configuration  summary

——————————————————————————————————————————————————————————————

R1-CE

router ospf 12

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 1

router-id 10.1.1.1

network 10.1.1.1 0.0.0.0 area 0

network 12.1.1.0 0.0.0.255 area 0

network 110.1.1.0 0.0.0.255 area 0

——————————————————————————————————————————————————————————————

R2-PE

R2#show run | s ospf

router ospf 12 vrf a

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng area 1

router-id 22.22.22.22

area 0 sham-link 22.22.22.22 99.99.99.99 ttl-security hops 254

redistribute bgp 1 metric 10 subnets

network 12.1.1.0 0.0.0.255 area 0

R2#show run | b r b

router bgp 1

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 30.1.1.1 remote-as 1

neighbor 30.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 30.1.1.1 activate

exit-address-family

!

address-family vpnv4

  neighbor 30.1.1.1 activate

  neighbor 30.1.1.1 send-community extended

exit-address-family

!

address-family ipv4 vrf a

  network 22.22.22.22 mask 255.255.255.255

  redistribute ospf 12 metric 10

exit-address-family

interface Loopback10

ip vrf forwarding a

ip address 22.22.22.22 255.255.255.255

——————————————————————————————————————————————————————————————

R3 -RR

R3#show run | b r b

router bgp 1

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 20.1.1.1 remote-as 1

neighbor 20.1.1.1 update-source Loopback0

neighbor 80.1.1.1 remote-as 3

neighbor 80.1.1.1 ebgp-multihop 255

neighbor 80.1.1.1 update-source Loopback0

!

address-family ipv4

exit-address-family

!

address-family vpnv4

  neighbor 20.1.1.1 activate

  neighbor 20.1.1.1 send-community extended

  neighbor 20.1.1.1 route-reflector-client

  neighbor 80.1.1.1 activate

  neighbor 80.1.1.1 send-community extended

exit-address-family

R3#show run | s ospf

router ospf 234

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

redistribute bgp 1

network 23.1.1.0 0.0.0.255 area 0

network 30.1.1.1 0.0.0.0 area 0

network 34.1.1.0 0.0.0.255 area 0

——————————————————————————————————————————————————————————————

R4-PE

R4#show run | s ospf

router ospf 234 vrf a

mpls traffic-eng router-id FastEthernet0/0

mpls traffic-eng area 0

area 0 sham-link 44.44.44.44 66.66.66.66 ttl-security hops 254

redistribute bgp 2 metric 10 subnets

network 34.1.1.0 0.0.0.255 area 0

router bgp 2

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 60.1.1.1 remote-as 2

neighbor 60.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 60.1.1.1 activate

exit-address-family

!

address-family vpnv4

  neighbor 60.1.1.1 activate

  neighbor 60.1.1.1 send-community extended

exit-address-family

!

address-family ipv4 vrf a

  network 22.22.22.22 mask 255.255.255.255     ——》【What is necessary?】

  network 44.44.44.44 mask 255.255.255.255

  redistribute ospf 234 metric 10

exit-address-family

——————————————————————————————————————————————————————————————

R6-PE

router ospf 689 vrf a

area 0 sham-link 66.66.66.66 44.44.44.44 ttl-security hops 254

redistribute bgp 2 metric 5 subnets

network 68.1.1.0 0.0.0.255 area 0

R6#show run | b r b

router bgp 2

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 40.1.1.1 remote-as 2

neighbor 40.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 40.1.1.1 activate

exit-address-family

!

address-family vpnv4

  neighbor 40.1.1.1 activate

  neighbor 40.1.1.1 send-community extended

exit-address-family

!

address-family ipv4 vrf a

  network 66.66.66.66 mask 255.255.255.255

  network 99.99.99.99 mask 255.255.255.255

  redistribute ospf 689 metric 5

exit-address-family

——————————————————————————————————————————————————————————————

R8-RR

router bgp 3

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 30.1.1.1 remote-as 1

neighbor 30.1.1.1 ebgp-multihop 255

neighbor 30.1.1.1 update-source Loopback0

neighbor 90.1.1.1 remote-as 3

neighbor 90.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 90.1.1.1 activate

exit-address-family

!

address-family vpnv4

  neighbor 30.1.1.1 activate

  neighbor 30.1.1.1 send-community extended

  neighbor 90.1.1.1 activate

  neighbor 90.1.1.1 send-community extended

  neighbor 90.1.1.1 route-reflector-client

exit-address-family

——————————————————————————————————————————————————————————————

R9-PE

R9#show run | s ospf

router ospf 109 vrf a

router-id 99.99.99.99

area 0 sham-link 99.99.99.99 22.22.22.22 ttl-security hops 254

redistribute bgp 3 metric 5 subnets

network 109.1.1.0 0.0.0.255 area 0

router ospf 689

router-id 90.1.1.1

network 89.1.1.0 0.0.0.255 area 0

network 90.1.1.1 0.0.0.0 area 0

  redistribute ospf 109 metric 10

R9#SHOW RUN | b r b

router bgp 3

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 80.1.1.1 remote-as 3

neighbor 80.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 80.1.1.1 activate

exit-address-family

!

address-family vpnv4

  neighbor 80.1.1.1 activate

  neighbor 80.1.1.1 send-community extended

exit-address-family

!

address-family ipv4 vrf a

  network 99.99.99.99 mask 255.255.255.255

  redistribute ospf 109 metric 10

exit-address-family

interface Loopback10

ip vrf forwarding a

ip address 99.99.99.99 255.255.255.255

——————————————————————————————————————————————————————————————

R10-CE

router ospf 109

router-id 100.1.1.1

network 100.1.1.1 0.0.0.0 area 0

network 109.1.1.0 0.0.0.255 area 0

network 110.1.1.0 0.0.0.255 area 0

Configuration file download

Bye.

Thank Your.

1 ACCEPTED SOLUTION

Accepted Solutions
Peter Paluch
Hall of Fame Cisco Employee

Hello,

You are redistributing BGP to OSPF. I believe that is a possible cause of your problem. The IP address of the loopback that is used as the endpoint of the sham link must be advertised only in BGP and not in OSPF. Otherwise, the OSPF will try to compute a route to the sham link endpoint and possibly create an unresolvable route.

Therefore, on all PE routers, remove the redistribute bgp command from the OSPF processes run in VRF a.

Best regards,

Peter

View solution in original post

3 REPLIES 3
Peter Paluch
Hall of Fame Cisco Employee

Hello,

You are redistributing BGP to OSPF. I believe that is a possible cause of your problem. The IP address of the loopback that is used as the endpoint of the sham link must be advertised only in BGP and not in OSPF. Otherwise, the OSPF will try to compute a route to the sham link endpoint and possibly create an unresolvable route.

Therefore, on all PE routers, remove the redistribute bgp command from the OSPF processes run in VRF a.

Best regards,

Peter

View solution in original post

You mean to prohibit   

To the BGP routes redistribute OSPF to go?

I do the following operations

R9

address-family ipv4 vrf a

  no redistribute ospf 109 metric 10

R2

address-family ipv4 vrf a

  network 22.22.22.22 mask 255.255.255.255

no  redistribute ospf 12 metric 10

But still there are problems

1.

R2 vrf routing table to see the next hop 12.1.1.1 go 99.99.99.99

————》I modified the R1-R10 backdoor link cost,Neighbors are still unable to establish

*Oct 15 08:35:46.703: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL0 from INIT to DOWN, Neighbor Down: Interface down or detached

2.

I do not know  R2 Go 99.99.99.99 ,Establish a neighbor,Should be the path,backdoor link Or Backbone。

3.

I hope MPLS CSC and sham-link coexistence

So if no redistribute MPLS VPN will not be the normal possible

I did not find my configuration errors,

So I wish I could tell me how to configure to achieve the purpose of the experiment

Thank you very much!

Peter Paluc

bye

.

Problem has been solved

I found that, flip neighbor, Routing is also flip。

R2#show ip route vrf a

      99.0.0.0/32 is subnetted, 1 subnets

O E2     99.99.99.99 [110/5] via 80.1.1.1, 00:00:04

R2#show ip route vrf a

      99.0.0.0/32 is subnetted, 1 subnets

B        99.99.99.99 [200/0] via 80.1.1.1, 00:00:04

O E2   and  B  99.99.99.99  Constantly to switch

I performed the following operations

R2#

router ospf 12 vrf a

distance 201

R9

router ospf 109 vrf a

distance 201

Neighbors normal

*Oct 15 16:31:45.151: %OSPF-5-ADJCHG: Process 12, Nbr 99.99.99.99 on OSPF_SL0 from LOADING to FULL, Loading Done

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

30.1.1.1          1   FULL/DR         00:00:38    23.1.1.3        FastEthernet0/1

10.1.1.1          1   FULL/BDR        00:00:39    12.1.1.1        FastEthernet0/0

99.99.99.99       0   FULL/  -        00:00:24    99.99.99.99     OSPF_SL0

R1#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 1 subnets

C        10.1.1.1 is directly connected, Loopback0

      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        12.1.1.0/24 is directly connected, FastEthernet0/0

L        12.1.1.1/32 is directly connected, FastEthernet0/0

      22.0.0.0/32 is subnetted, 1 subnets

O E2     22.22.22.22 [110/5] via 12.1.1.2, 00:00:48, FastEthernet0/0

      99.0.0.0/32 is subnetted, 1 subnets

O E2     99.99.99.99 [110/5] via 12.1.1.2, 00:00:48, FastEthernet0/0

      100.0.0.0/32 is subnetted, 1 subnets

O        100.1.1.1 [110/4] via 12.1.1.2, 00:00:48, FastEthernet0/0

      109.0.0.0/24 is subnetted, 1 subnets

O        109.1.1.0 [110/3] via 12.1.1.2, 00:00:48, FastEthernet0/0

      110.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        110.1.1.0/24 is directly connected, FastEthernet1/1

L        110.1.1.1/32 is directly connected, FastEthernet1/1

R1(config)#int f0/0

R1(config-if)#shu

R1(config-if)#shutdown

R1#show ip route

*Oct 15 16:33:15.627: %SYS-5-CONFIG_I: Configured from console by console

R1#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 1 subnets

C        10.1.1.1 is directly connected, Loopback0

      12.0.0.0/24 is subnetted, 1 subnets

O        12.1.1.0 [110/10003] via 110.1.1.10, 00:00:09, FastEthernet1/1

      22.0.0.0/32 is subnetted, 1 subnets

O E2     22.22.22.22 [110/5] via 110.1.1.10, 00:00:09, FastEthernet1/1

      99.0.0.0/32 is subnetted, 1 subnets

O E2     99.99.99.99 [110/5] via 110.1.1.10, 00:00:09, FastEthernet1/1

      100.0.0.0/32 is subnetted, 1 subnets

O        100.1.1.1 [110/10001] via 110.1.1.10, 00:00:09, FastEthernet1/1


Thank you

Peter Paluch

Help 

If you know the About  MPLS TE SRLG 。

I hope you can help me

https://supportforums.cisco.com/message/4025188#4025188

Thank you

bye

NEW  Configuration file download


Content for Community-Ad