cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1330
Views
0
Helpful
2
Replies
Beginner

MPLS IPv6 Inter VRF Problem

Hi,

We have a case MPLS 6PE configuration as below, we can't ping inter vrf in local router from the gateway, but i can ping & browsing from my PC/router behind PE using gateway vrf Test-IPv6, any solution regarding this issue ? Has anyone ever encountered this problem ?  Thanks.

#ping vrf Test-IPv6 ipv6 2404:8000:1745:1::CA

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2404:8000:1745:1::CA, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

#ping vrf Test-IPv6 ipv6 2404:8000:1745:1::C9

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2404:8000:1745:1::C9, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

vrf definition Internet

rd 17451:10003

!

address-family ipv4

route-target export 17451:10003

route-target import 17451:412

exit-address-family

!

address-family ipv6

route-target export 17451:10003

route-target import 17451:412

exit-address-family

!

vrf definition Test-IPv6

rd 17451:412

!

address-family ipv4

exit-address-family

!

address-family ipv6

route-target export 17451:412

route-target import 17451:10003

exit-address-family

!

interface GigabitEthernet1/26

vrf forwarding Test-IPv6

no ip address

ipv6 address 2404:8000:90:2::1/64

ipv6 enable

!

interface Port-channel2

description **** to Internet***

vrf forwarding Internet

mtu 9000

ipv6 address 2404:8000:1745:1::CA/126

ipv6 enable

!

router bgp 17451

!

address-family ipv4

  no synchronization

  no neighbor xxx.xxx.xxx.xxx activate

  neighbor xxx.xxx.xxx.xxx activate

  no auto-summary

exit-address-family

!

address-family vpnv4

  bgp scan-time 10

  neighbor xxx.xxx.xxx.xxx activate

  neighbor xxx.xxx.xxx.xxx send-community extended

  neighbor xxx.xxx.xxx.xxx advertisement-interval 10

  neighbor xxx.xxx.xxx.xxx activate

  neighbor xxx.xxx.xxx.xxx send-community extended

  neighbor xxx.xxx.xxx.xxx advertisement-interval 10

exit-address-family

!

address-family ipv6

  no synchronization

  neighbor xxx.xxx.xxx.xxx activate

exit-address-family

!

address-family vpnv6                                               ---->    to RR-Router

  neighbor xxx.xxx.xxx.xxx activate

  neighbor xxx.xxx.xxx.xxx send-community extended

  neighbor xxx.xxx.xxx.xxx advertisement-interval 10

exit-address-family

!

address-family ipv6 vrf Internet

  redistribute connected

  redistribute static

  default-information originate

  no synchronization

exit-address-family

!

!

address-family ipv6 vrf Test-IPv6

  redistribute connected

  no synchronization

exit-address-family

!

Everyone's tags (5)
2 REPLIES 2
Highlighted
Beginner

Re: MPLS IPv6 Inter VRF Problem

Did you solve this problem?

Highlighted
Cisco Employee

Re: MPLS IPv6 Inter VRF Problem

It is not possible to ping addresses in one vrf using the other vrf as a source on the local router. This does not prevent hosts in one vrf to ping hosts in the other vrf.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México