Showing results for 
Search instead for 
Did you mean: 

MPLS TE between IOS and IOS XR

Dear All,


I am currently running a lab on VIRL 2 (CML) where i am unable to establish MPLS TE between IOS and IOS XR..


i am getting the following error..i am using default bw, affinity with dynamic path selection. 


*Jan 12 08:34:17.809: TE-PCALC: Tunnel0 Path Setup [0000.0000.0022.00] (isis level-1)
*Jan 12 08:34:17.809: TE-PCALC: bw 0, min_bw 0, metric: 0
*Jan 12 08:34:17.809: TE-PCALC: setup_pri 7, hold_pri 7
*Jan 12 08:34:17.809: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF
*Jan 12 08:34:17.809: TE-PCALC path type unidirectional
*Jan 12 08:34:17.809: TE-PCALC endpoint switching capability psc1, link encoding packet
*Jan 12 08:34:17.810: TE-PCALC transit switching capability psc1, link encoding packet
*Jan 12 08:34:17.810: TE-PCALC_PATH: No Path




interface Tunnel0
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 10 dynamic
no routing dynamic


Appreciate if i can get further advice on how to move forward.




3 Replies 3

Below output for further reference.


R4#sh mpls traffic-eng topology igp-id isis 0000.0000.0022.00 brief

IGP Id: 0000.0000.0022.00, MPLS TE Id: Router Node (isis level-1)
link[0]: Broadcast, DR: 0000.0000.0033.01, nbr_node_id:22, gen:22
frag_id 0, Intf Address:, Nbr Intf Address:
TE metric:10, IGP metric:10, attribute flags:0x0
SRLGs: None

link[1]: Broadcast, DR: 0000.0000.0011.09, nbr_node_id:25, gen:22
frag_id 0, Intf Address:, Nbr Intf Address:
TE metric:10, IGP metric:10, attribute flags:0x0
SRLGs: None



R4#sh mpls traffic-eng tunnels

Name: R4_t0 (Tunnel0) Destination:
Admin: up Oper: down Path: not valid Signalling: Down
path option 10, type dynamic

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled

Time since created: 1 days, 13 hours, 43 minutes
Number of LSP IDs (Tun_Instances) used: 4580
Path Option 10:
Last Error: PCALC:: No path to destination, 0000.0000.0022.00



do you see RSVP messages make it to the IOSXR side? Could you post "show run | s router isis" ? Have e you tried deleting the tunnel and configuring it back? Are the log messages always the same?



Hi Ioris,


Thanks for your response.. Yes the log messages are always same on IOS side. I couldnt perform probably right debug command to get the path events at IOS XR side which is the next directly connected router (Midpoint).

I have tried to delete the tunnel and recreate , still the same behavior.. Below is the output for your kind reference.


router isis
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
net 49.0001.0000.0000.0004.00
metric-style wide


R4 (IOS - - Headend) - XR1 ( - IOSXR-Midpoint) - XR2 ( - IOS XR - Tailend)


Above is FYKR.




Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: