cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
443
Views
0
Helpful
5
Replies

optimal route reflection (ORR)

sachin30720041
Level 1
Level 1

Hello All,

 

I am trying to configure optimal route reflector. IOS1 is ebgp neighbor to CSR2 and CSR3. CSR2, CSR3, XRv-RR and XRv3 are part of same AS 123. I have configured optional route reflection on XR-RR. But I do not see any prefix on XRv7.

I am not sure what configuration is missing.

 

                                    ios1

                                 /        \

                               /            \

                           CSR2       CSR3

                             \              /

                                \          / 

                                XR-RR  

                                    |       

                                  XR 7

 

 

ios1
---------------
int gi0/1
ip address 100.10.20.11 255.255.255.0
no sh

int gi0/2
ip address 100.10.30.11 255.255.255.0
no sh
int lo0
ip address 11.11.11.11 255.255.255.255

router bgp 11
no bgp default ipv4-unicast
template peer-session session1
remote-as 123
exit
neighbor 100.10.20.2 inherit peer-session session1
neighbor 100.10.30.3 inherit peer-session session1
address-family ipv4 unicast
neighbor 100.10.20.2 activate
neighbor 100.10.30.3 activate


CSR2

--------------------------------

int gi1
ip address 100.10.20.2 255.255.255.0
no sh

int lo0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
no sh

int gi3
ip address 100.20.40.2 255.255.255.0
ip ospf 1 area 0
no sh

int gi4
ip address 100.20.70.2 255.255.255.0
ip ospf 1 area 0
no sh
mpls traffic-eng tunnels

router ospf 1
distribute link-state
router-id 2.2.2.2
mpls traffic-eng router-id lo0
exit

router bgp 123
no bgp default ipv4-unicast
template peer-session session1
remote-as 11
exit
template peer-session session2
remote-as 123
update-source lo0
exit
template peer-policy policy1
next-hop-self
exit
neighbor 100.10.20.11 inherit peer-session session1
neighbor 4.4.4.4 inherit peer-session session2
address-family ipv4 unicast
neighbor 100.10.20.11 activate
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 inherit peer-policy policy1

 

CSR3

----------------------
int gi2
ip address 100.10.30.3 255.255.255.0
no sh

int gi4
ip address 100.30.40.3 255.255.255.0
ip ospf 1 area 0
no sh

int gi1
ip address 100.30.70.3 255.255.255.0
ip ospf 1 area 0
no sh

int lo0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
no sh
mpls traffic-eng tunnels

router ospf 1
distribute link-state
mpls traffic-eng router-id lo0
distribute link-state
router-id 3.3.3.3
exit

router bgp 123
no bgp default ipv4-unicast
template peer-session session1
remote-as 11
exit
template peer-session session2
remote-as 123
update-source lo0
exit
template peer-policy policy1
next-hop-self
exit
neighbor 100.10.30.11 inherit peer-session session1
neighbor 4.4.4.4 inherit peer-session session2
address-family ipv4 unicast
neighbor 100.10.30.11 activate
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 inherit peer-policy policy1

 

XRV-RR
------------------------
int gi0/0/0/0
ipv4 address 100.30.40.4 255.255.255.0
no sh

int gi0/0/0/3
ipv4 address 100.20.40.4 255.255.255.0
no sh

int gi0/0/0/2
ipv4 address 100.40.70.4 255.255.255.0
no sh
mpls traffic-eng
exit

router ospf 1
distribute link-state
mpls traffic-eng router-id lo0
area 0
int gi0/0/0/0
int gi0/0/0/2
int gi0/0/0/3
int lo0
exit

router bgp 123
address-family link-state link-state
exit
address-family ipv4 unicast
no optimal-route-reflection root1 7.7.7.7
optimal-route-reflection root1 7.7.7.7
optimal-route-reflection root2 2.2.2.2
optimal-route-reflection root3 3.3.3.3
exit
session-group session3
remote-as 123
update-source lo0
exit
af-group af1 address-family ipv4 unicast
route-reflector-client
exit
neighbor 3.3.3.3
use session-group session3
address-family ipv4 unicast
optimal-route-reflection root3
use af-group af1
exit
address-family link-state link-state
exit
neighbor 2.2.2.2
use session-group session3
address-family ipv4 unicast
optimal-route-reflection root2
use af-group af1
exit
address-family link-state link-state
exit
neighbor 7.7.7.7
use session-group session3
address-family ipv4 unicast
optimal-route-reflection root1
use af-group af1
exit
address-family link-state link-state
exit

 

XR7
-----------------------------
int gi0/0/0/1
ip address 100.30.70.7 255.255.255.0
no sh

int gi0/0/0/0
ip address 100.20.70.7 255.255.255.0
no sh

int gi0/0/0/2
ip address 100.40.70.7 255.255.255.0
no sh

int lo0
ip address 7.7.7.7 255.255.255.255
no sh

mpls traffic-eng
exit

router ospf 1
distribute link-state
router-id 7.7.7.7
area 0
int gi0/0/0/0
int gi0/0/0/1
int gi0/0/0/2
exit

router bgp 123
address-family ipv4 unicast
exit
session-group session1
remote-as 123
update-source lo0
exit
neighbor 4.4.4.4
use session-group session1
address-family ipv4 unicast

 

 

 

 

5 Replies 5

CSR2 & CSR3 you need next-hop self since RR not know the connect between them and IOS1.

I have provided the next-hop-self in 'template peer-policy' on  CSR2 and CSR3 configurations.

 

template peer-policy policy1
next-hop-self
exit

 

XR-RR has the prefix from IOS1 but it does not distribute to XR7. If I remove 'optimal-route-reflection' related command then XR7 receives the prefix from XR-RR. With 'optimal-route-reflection' configuration I am trying to understand optimal route reflection.

 

Thanks,

Sachin

IOS1
neighbor 100.10.20.2 inherit peer-session session1<- here you use interface IP as neighbor 

CSR1

template peer-session session2
remote-as 123
update-source lo0<- here you use LO as update source so please correct this

There is ebgp session between ios1 and CSR2, ios1 and CSR3.

100.10.20.11, 100.10.30.11 are interfaces on IOS1.

CSR2 and CSR3 are able to create to create ebgp session with ios1.

 

IOS1

router bgp 11
no bgp default ipv4-unicast
template peer-session session1
remote-as 123
exit
neighbor 100.10.20.2 inherit peer-session session1
neighbor 100.10.30.3 inherit peer-session session1
address-family ipv4 unicast
neighbor 100.10.20.2 activate
neighbor 100.10.30.3 activate

CSR2

-----------------------------------------

router bgp 123
no bgp default ipv4-unicast
template peer-session session1
remote-as 11
exit
template peer-session session2
remote-as 123
update-source lo0
exit
template peer-policy policy1
next-hop-self
exit
neighbor 100.10.20.11 inherit peer-session session1

 

CSR3

-------------------------------------------

router bgp 123
no bgp default ipv4-unicast
template peer-session session1
remote-as 11
exit
template peer-session session2
remote-as 123
update-source lo0
exit
template peer-policy policy1
next-hop-self
exit
neighbor 100.10.30.11 inherit peer-session session1

I see there are two session 1 for IOS and other for RR,
in XR-RR
session-group session3
remote-as 123
update-source lo0 <- this must be 4.4.4.4 but you don't config this LO, config it and check again