cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1189
Views
0
Helpful
1
Replies

Prevent loop within MPLS/VPN :1 CE connects to 2 PE

Ha Dao
Level 1
Level 1

Hi all, my case is as the diagram bellow:

http://i231.photobucket.com/albums/ee227/buratino01/mpls-eigrp2.jpg

The custommer have 4 sites in which SITE 3 have 2 links to 2 PE ( one for backup )

When i finished the configuratons, i saw some loops between CE, PE1, PE2.

I tried to change AD of EIGRP from 170 to 210, after that there was no loop. But i m not sure this topology is stable or not

Pls give me some advices

==================

R1

Code:

ip subnet-zero

ip cef
no ip domain lookup
no ip dhcp use vrf connected
tag-switching tdp router-id Loopback0

interface Loopback0
ip address 1.1.1.4 255.255.255.255
!
interface FastEthernet0/0
ip address 9.0.0.17 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!

interface Serial1/0
ip address 9.0.0.9 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.13 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable

router ospf 1
router-id 1.1.1.4
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.0 0.0.0.255 area 0
!
ip http server
ip classless

R2

Code:

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip vrf cusB
rd 1:20
route-target export 1:20
route-target import 1:20
!
tag-switching tdp router-id Loopback0

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.1.0.1 255.255.255.0
!

!
interface Serial1/0
ip address 9.0.0.10 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description connect to CE Backup
ip vrf forwarding cusA
ip address 9.0.0.5 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!

router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
redistribute static metric 10000 100 255 1 1500
network 9.0.0.4 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 9.0.0.8 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.2 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community both
neighbor CORE next-hop-self
neighbor 1.1.1.2 activate
neighbor 1.1.1.3 activate
exit-address-family
!

!
address-family ipv4 vrf cusA
redistribute static metric 20
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
ip route vrf cusA 40.0.0.0 255.0.0.0 20.1.0.2

R3

Code:

hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!

interface Loopback1
ip vrf forwarding cusA
ip address 20.0.0.1 255.255.255.0
!


interface Serial1/0
ip vrf forwarding cusA
ip address 9.0.0.1 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.14 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!

router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
network 9.0.0.0 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.2
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.12 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.1 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community extended
neighbor CORE next-hop-self
neighbor 1.1.1.1 activate
neighbor 1.1.1.3 activate
exit-address-family
!

!
address-family ipv4 vrf cusA
redistribute static
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless

R4

Code:

hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!

!
interface Loopback0
ip address 1.1.1.3 255.255.255.255
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.2.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 9.0.0.18 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!

router ospf 1
router-id 1.1.1.3
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.16 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.1 peer-group CORE
neighbor 1.1.1.2 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community extended
neighbor CORE next-hop-self
neighbor 1.1.1.1 activate
neighbor 1.1.1.2 activate
exit-address-family
!

address-family ipv4 vrf cusA
redistribute connected
default-information originate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless

R5

Code:

hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected

interface Loopback0
ip address 20.3.0.1 255.255.255.0
!

interface Serial1/0
ip address 9.0.0.2 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!

!
router eigrp 123
network 9.0.0.0 0.0.0.255
network 20.3.0.0 0.0.0.255
distance eigrp 90 210
no auto-summary
!
ip http server
ip classless

1 Reply 1

Ha Dao
Level 1
Level 1

Someones can help me,plz

I read the docs Dual CE-PE connection and EIGRP:

https://supportforums.cisco.com/docs/DOC-15184

But in that doc, every sites run EIGRP, in my case , there is only a site run EIGRP