cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4085
Views
0
Helpful
5
Replies

VPLS in VIRL using CSR1000v

mmoraba
Cisco Employee
Cisco Employee

Hi All

Can anyone provide me an example of extending vlan over VPLS using ios-xe. i am more interested about the CE config as the PE config is well demonstrated on the below link:

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l2_vpns/configuration/xe-3s/mp-l2-vpns-xe-3s-book/mp-vpls.html#GUID-BAD7A7D4-0E29-4F48-8462-AF0A7FB9E4F1

However i want to see what the CE config looks like particularly with VLANs. Thanks!

2 Accepted Solutions

Accepted Solutions

Victor Acevedo
Cisco Employee
Cisco Employee

Hello Mmoraba,

The CE's will usually have subinterfaces if they are routers or they will have SVI's configured and have a trunk interface towards your PE devices. The PE devices will then be configured with EVC to accept and put the Vlans in their respective bridge-domain which will then be sent across the pseudowire. 

You can take a look at the following config snipplet for a simple VPLS setup with XE devices as the PE's and carrying Vlan Tags.

Note that this setup may not work using VIRL XE devices. 

PE1:

PE1#sh run int g0/0/0      <<<< Attachment circuit towards CE1
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service instance 192 ethernet
encapsulation dot1q 192
bridge-domain 192

PE1#sh run | sec vfi
l2 vfi VPLS1 manual
vpn id 192
bridge-domain 192
neighbor 110.2.2.2 encapsulation mpls

PE2:

PE2#sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service instance 192 ethernet
encapsulation dot1q 192
bridge-domain 192


PE2#sh run | sec vfi
l2 vfi VPLS1 manual
vpn id 192
bridge-domain 192
neighbor 110.1.1.1 encapsulation mpls

CE1:

CE1#sh run int g0/0/0.192 
interface GigabitEthernet0/0/0.192
encapsulation dot1Q 192
ip address 192.168.1.1 255.255.255.0

R11-ISR4k-2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

CE2:

CE2# sh run int g0/0/0.192
interface GigabitEthernet0/0/0.192
encapsulation dot1Q 192
ip address 192.168.1.2 255.255.255.0

CE2# ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

View solution in original post

Hey Mmoraba,

Yes, this is on a CSR1kv running IOS XE. You can use the new syntax as follows for the CE's

CE1#sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
service instance 192 ethernet
encapsulation dot1Q
192
bridge-domain 192

CE1#sh run int bdi192
interface BDI192
ip address 192.168.1.2 255.255.255.0
encapsulation dot1Q 192

CE1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
CE2# sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
service instance 192 ethernet
encapsulation dot1Q
192
bridge-domain 192

CE2#sh run int bdi192
interface BDI192
ip address 192.168.1.1 255.255.255.0
encapsulation dot1Q 192

CE2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Thanks,

Victor Hugo Acevedo

View solution in original post

5 Replies 5

Victor Acevedo
Cisco Employee
Cisco Employee

Hello Mmoraba,

The CE's will usually have subinterfaces if they are routers or they will have SVI's configured and have a trunk interface towards your PE devices. The PE devices will then be configured with EVC to accept and put the Vlans in their respective bridge-domain which will then be sent across the pseudowire. 

You can take a look at the following config snipplet for a simple VPLS setup with XE devices as the PE's and carrying Vlan Tags.

Note that this setup may not work using VIRL XE devices. 

PE1:

PE1#sh run int g0/0/0      <<<< Attachment circuit towards CE1
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service instance 192 ethernet
encapsulation dot1q 192
bridge-domain 192

PE1#sh run | sec vfi
l2 vfi VPLS1 manual
vpn id 192
bridge-domain 192
neighbor 110.2.2.2 encapsulation mpls

PE2:

PE2#sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service instance 192 ethernet
encapsulation dot1q 192
bridge-domain 192


PE2#sh run | sec vfi
l2 vfi VPLS1 manual
vpn id 192
bridge-domain 192
neighbor 110.1.1.1 encapsulation mpls

CE1:

CE1#sh run int g0/0/0.192 
interface GigabitEthernet0/0/0.192
encapsulation dot1Q 192
ip address 192.168.1.1 255.255.255.0

R11-ISR4k-2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

CE2:

CE2# sh run int g0/0/0.192
interface GigabitEthernet0/0/0.192
encapsulation dot1Q 192
ip address 192.168.1.2 255.255.255.0

CE2# ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Hi Victor

Is this on ios-xe? particularly on CSR1000v? I see you also using the legacy syntax, does the new syntax produce same results?

Hey Mmoraba,

Yes, this is on a CSR1kv running IOS XE. You can use the new syntax as follows for the CE's

CE1#sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
service instance 192 ethernet
encapsulation dot1Q
192
bridge-domain 192

CE1#sh run int bdi192
interface BDI192
ip address 192.168.1.2 255.255.255.0
encapsulation dot1Q 192

CE1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
CE2# sh run int g0/0/0
interface GigabitEthernet0/0/0
no ip address
service instance 192 ethernet
encapsulation dot1Q
192
bridge-domain 192

CE2#sh run int bdi192
interface BDI192
ip address 192.168.1.1 255.255.255.0
encapsulation dot1Q 192

CE2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Thanks,

Victor Hugo Acevedo

Hi Victor

Thanks a lot. i really appreciate all the help you provided. Thanks once again. it works just fine now!

Hey Mmoraba,

Not a problem, I am glad this information has helped. If it solved your problem please consider clicking on the "Endorse Answer" to mark this as solved. 

Thanks!

Victor Hugo Acevedo